PDA

View Full Version : dCW r2 beta 1 conversion bug with Smart setting



xoas
02-17-2004, 01:01 AM
In trying to create a 700 mb MP3 disc (Lame cbr 192 kbs) I have found that if I create a Smart button setting while I am setting up the formatting and specifications that everything gets converted to Lame 32 kps cbr regardless of the format of the original file (I tried with Ogg, Wav, MPC, and Mp3 files). If I don't set a Smart setting in the formatting then any mp3 files which had been formatted at (say) 128 kps are reformatted to 192 kps unless I click and set the Smart button prior to converting that file.
Looks like a bug or is this intentional? Seems like dCW r1 handled this more smoothly.

One other wish-I would really like to see dCW have the ability to change the formatting properties of the cd you are working on if you discover (say) that you have set the wrong format for the cd you are working on (like if you thought you were creating a 700 mb cd and found that dCW has you formatted for a 650 mb cd) only after you have converted a lot of material (without having to start over from scratch). Ditto for changing file arrangement for the cd on the fly.

best wishes,
bill mikkelsen

Spoon
02-18-2004, 06:02 AM
Can you run through how you are converting? with the smart, step by step so I can try to reproduce it.

xoas
02-18-2004, 08:09 PM
I could, but to make a long story short, when I went to replicate this problem step by step I found that I identified the wrong culprit.
My first approach had been to create a new cd by opening dCW, click on the New button to create a new cd format, click on the button that says create new cd, click on the button to designate an MP3/WMA cd, set the length for 700 mb, then select MP3(Lame) and set the bit rate (192 kbs, constant bit rate), click on the Smart button and set it so that MP3 files below 192 kps will not convert, set the file/file naming system for [artist]\[artist]-[track]. Then I click on Create New CD, and click on OK (to delect my new format). At this point I am back at the main dCW window where I browse through music files on the right, select files for adding to the disc (sometimes a single file, sometimes multiple files with the same format, never multiple files with multiple formats). Then I click on the black arrow to add the selected file(s) to the cd. My results were as I reported (regardless of the format of the original file the files added to the new cd were converted to mp3 32 kbs except that mp3 files which were originally UNDER 192 kbs came through as-is but mp3 files which had been 192 kbs. or higher were converted to 32 kbs.).

So then I tried to create a new cd by opening My Computer, and then navigated (or browsed) to music files. I then would select one or more music files, right click on the selected files, click on Convert To, select Audio CD, click on New and set the format as above. Again I had the same results.

Then I tried by accessing music files through My Computer (as in the second example) and this time when I set the cd parameters I made sure the Smart button was de-activated. I found that this seemed to correct the original problem but that then mp3 files added to the cd which had been below 192 kps. were being converted to 192 kbs. On trying to replicate this, I came to find out that success was inconsistent at best. At times, I would follow this procedure and still end up with all tracks being 32 kbs mp3 (but only when starting over from scratch-once a new cd started getting files converted right, it would keep doing so). I found that I could correct the problem with mp3 files below 192 kbs being converted to 192 kbs by clicking the Smart button on the dCW screen and then specifying that mp3 files below 192 kbs not be converted.

However, in preparing to reply to your request for details on the run-through, I was troubled by the fact that successes were inconsistent at best. To make a long story short, my problems do not appear to have been with the Smart button. What I found was the dMC had last been set with the Lame conversion setting at 0-32 kbs variable bit-rate (the result of experimenting around to see the effects of different compression settings). Once I changed the dMC conversion setting to 192 kbs. then the above problem disappeared(!) Apparently, dCW conversion settings do not seem to over-ride pre-existing lower conversion settings on dMC. Incidentally, dCW r1 has this same quirk. Still seems like a bug to me but a bug of a whole different sort. By the way, the Smart button is very nice (seems to really speed up conversion of multiple files).
So maybe it would be a good idea to edit the title of this thread to leave the Smart button out of the title to avoid impugning the reputation of the Smart button unjustly.
best wishes,
Bill Mikkelsen

Wayne
02-19-2004, 06:44 PM
I unsuccessfully tried to recreate your problem last night.

1. I started initially by making the compression settings for dMC lower than those for dCW. (i.e. 128 as opposed to 192).
2. I created definitions for various CD formats/sizes. Each time I checked the dCW settings.
3. Lastly I created an MP3 CD by adding numerous tracks. None of them were converted using dMC's settings.

Wayne

Spoon
02-20-2004, 04:25 AM
I know there has been a bug reported when using presets with lame, ie set a low bitrate profile and convert with that, then select no profile and it seems to still use the profile bitrate unless the bitrate is changed on the main page, could this be it?

xoas
02-20-2004, 07:35 AM
Thank you both. Here is what I can do to recreate this problem at will:
1. Open a music file, right click on Convert To, select Mp3 (Lame);
2. Set the bit rate to some value (from 32 kbs to 320 kbs);
3. Click cancel;
4. Open up dCW, select either an existing cd with space or create a new mp3 cd and set the bitrate for a different value (I have only been trying to run 192 kbs cbr but I see no reason why this should be different if I tried to create my mp3 cd for a different bitrate) from what I set in step 2;
5. Select music files (any file format) and click on the black arrow to add them to the cd;
6. Watch as the files are converted and added to the cd at the bitrate set in step 2 rather than in the bitrate I wanted the cd to reflect.

I have found that when this occurs I can correct this by going back to steps 1, 2 and 3 to reset my Lame setting to the value I want for my cd. It will work from there on in (unless I happen to change my Lame setting in MMC again before adding more tracks). Essentially, my conversion settings are not determined in any way by what was established in laying out the cd format, rather it is determined by what the dMC Lame conversion setting is at the time I am adding tracks. dCW does not override pre-existing conversion settings for me.

I do not have an Preset (like CD or Studio, from the Advanced settings) setting established for Lame. I don't think that a Preset setting for another codec will affect the results I am getting since manipulating the conversion setting in dMC effectively changes the conversion rate in dCW. Also, it appears that using a Preset setting in dCW still will be overridden by a differing setting in dMC. Still, if Wayne isn't replicating the problem I'm having it makes me wonder if therer are still some other factors in play.

Hope this explains the situation and allows replication. I am running Windows XP SP 1, dMC 10.1.
best wishes,
Bill Mikkelsen

Spoon
02-22-2004, 05:03 AM
I can reproduce the bug, so will look into it.