Products            Buy            Support Forum            Professional            About            Codec Central
Results 1 to 5 of 5

Thread: Batch converter aac to m4a not working

  1. #1

    Batch converter aac to m4a not working

    Just got dBpoweramp on a friend's recommendation and have been really impressed, but have just run into a snag.

    I converted my CD collection (about 400 CDs, or 4300 files) to WAV, and I'm using dBpoweramp to create a copy I can use on my Apple devices.

    Using about 3 albums as a trial, I successfully converted WAV files to 192kbs AAC files, and then converted those to m4a format which iTunes happily read.

    With this proof of concept, I then created an AAC copy of my entire WAV file collection overnight (took about 6 hours) - looks to be all good.

    The problem I have is with the aac to m4a conversion, as follows:

    When I tried to copy the files in one go, the process started but after 150 or so tracks got slower and slower. I figured perhaps I had thrown too much at it, so I cancelled and tried to convert a few albums at a time. Even after restarting the PC, it now takes ages even to examine even track one.

    In the conversion window i have "Preserve ID tags" ticked and I'm using the dynamic folder naming: [artist]\[artist] - [title]. The PC is a fairly powerful one. Both the source folder with the WAV files, and the destination folder are on the PC itself, not an external hard drive. There is plenty of space on the hard drive.

    The PC is extremely slow (almost frozen up) when I try to run this conversion - even after restarting the PC.

    Can anyone help to solve this issue?


  2. #2
    Join Date
    Apr 2002

    Re: Batch converter aac to m4a not working

    Convert to m4a directly by selecting m4a Nero (AAC) as the encoder.

  3. #3

    Re: Batch converter aac to m4a not working

    Thanks for the advice. I had some problems installing the Nero converter but with the help of this information at the linke below, it seems to be encoding ok. I'll let you know how I go.


  4. #4
    dBpoweramp Guru
    Join Date
    Feb 2007

    Re: Batch converter aac to m4a not working

    (1) This is the forum for the batch ripper

    (2) Spoon's advise to convert directly to m4a is the best. If you try to reencode aac to m4a, then most (?) applications will decode and re-encode, and you get a 'generation loss' degrading quality. That might actually be audible even at bitrates that would normally be transparent.

    (3) You may actually encapsulate aac into m4a without re-encoding. Tools like ffmpeg may do that by just wrapping the container around the stream without decoding it. But if you have the lossless originals, then ... well, I can only assume you have less chances of losing tags, if you follow Spoon's advise.

    (4) .wav is not the best idea. A lossless codec has precisely the same audio (just like a .zip'ed .doc decompresses to the original), and much better tagging support. If you are in an Apple universe, then you might consider ripping to ALAC. (However, you might consider a different format just to avoid the .m4a suffix and the possible confusion between ALAC-m4a and AAC-m4a. FLAC is a great choice, it is widely supported and it encodes and decodes very fast and with compression on par with ALAC or slightly better.)

  5. #5

    Re: Batch converter aac to m4a not working

    Thanks for the combined advice. Must admit, if I had my time again (ripping my 400 CDs into WAV with Windows Media Player) I'd have done things differently.

    Latest status is:
    1. The wav > m4a Nero encoding worked much better, but it made me realise all the track 1's had missing data so those tracks were all in separate listings
    2. I read up on this and realised this was a fault with Windows Media Player I originally used, as it starts to rip CDs before it can access the track information (why why why!!!!). Anyway, I corrected all the track 1's using dbpoweramp's [Tag from Filename] utility codec for the wav files, so the source library was better organised.
    3. Library is now much better organised - BUT, while the WAV track 1's will play happily in WMP, they will no longer play on my main Sony Media Centre (SMP-N100).

    The Sony is a fairly basic Media Centre and I suspect it's getting tripped up on some pretty basic wav tags that other players would accept. I checked for any software updates for the Sony but no luck there.

    Is there any known issue for this device?

    Any suggestions welcome. At this rate, I'm tempted to try my files on a Boxee and buy one of those instead if it works :smile2:

    (PS: This started as a batch conversion question but realise the subject matter is changing, happy to move to a different category)


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts