title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 5 of 5

Thread: QNAP / Oppo Playback question

  1. #1

    Join Date
    Jun 2016
    Posts
    15

    QNAP / Oppo Playback question

    I have a QNAP that I have just upgraded the Asset from R7.5 to R2023-5-15.
    I use an Oppo 203 on the Network function to playback the encoded albums.

    If I have encoded a various artists/compilation soundtrack using Reference R17.7 or R2023-6-26, in the "Album Artist" info I put 'Soundtrack' and the "Artist" is correctly listed, whoever it is.

    When I play back on the Oppo navigating the Asset menu, on playback it shows 4 lines of info, next to the album graphic:

    Title
    Artist
    Album
    Genre

    Question 1 - If I play the album, in the "Artist" field it is incorrectly listing the "Album Artist" info. This appears to be a bug, as it also existed on R7.5. (Note if I search on the artist, it finds the album correctly, so it is reading the tag information - but the playback behaviour is the same with the 4 lines above)

    Question 2 - Is there a way to change the information that is displayed in the 4 lines to other tag information ? I could see no easy/quick way in 'Options' (which would be the best UI approach IMHO) or in 'Advanced' menu on Asset UPnP.

    Note - My assumption is that it is Asset that is driving the information provided/shown through the Oppo.

    Thanks in advance for any pointers.

  2. #2
    dBpoweramp Guru
    Join Date
    Apr 2021
    Posts
    437

    Re: QNAP / Oppo Playback question

    Quote Originally Posted by Guy007 View Post
    Question 1 - If I play the album, in the "Artist" field it is incorrectly listing the "Album Artist" info. This appears to be a bug, as it also existed on R7.5. (Note if I search on the artist, it finds the album correctly, so it is reading the tag information - but the playback behaviour is the same with the 4 lines above)
    AssetUPnP will be sending the correct metadata to the control point/Oppo, so either the Oppo is reading the AlbumArtist field on purpose or it's mishandling the data. You can work around this (assuming the Oppo is using the metadata provided by AssetUPnP and not the file itself) by setting '[SimpleArtist]' for the Oppo, in the 'Settings Override' configuration section. This functionality is documented at the bottom of the AssetUPnP configuration page.

    Quote Originally Posted by Guy007 View Post
    Question 2 - Is there a way to change the information that is displayed in the 4 lines to other tag information ? I could see no easy/quick way in 'Options' (which would be the best UI approach IMHO) or in 'Advanced' menu on Asset UPnP.
    There isn't a way to change the tags that the Oppo presents (at least not from Asset) but you could format the values that are passed in those tags e.g. you could format the Genre tag to also include values from the DATE tag, but then these will appear in your Genre index too.

  3. #3

    Join Date
    Jun 2016
    Posts
    15

    Re: QNAP / Oppo Playback question

    Thanks simbun for the pointers. The QNAP UPnP looks slightly different from the help files, the control points are part of 'Advanced'. Once in, it lists the 'known control points' at the bottom. To that end the Oppo is listed.

    I have added the following at the rules at the bottom.

    =OPPO PLAYER
    [SimpleArtist]


    It restarted Asset, but unfortunately its done more to the information than expected. It has removed the 'artist' info, but is now showing the [artist] after the track name, and is now also showing the track number, where before it wasn't. This is showing in albums too. So it might take some edits to get it where I want it to be.

    As a side note, does it matter on sequence, i.e. should I add it at the top, or would it be better to just add to the "=AssetControl" or "={no-identification}" sections ?

    Cheers

  4. #4
    dBpoweramp Guru
    Join Date
    Apr 2021
    Posts
    437

    Re: QNAP / Oppo Playback question

    Quote Originally Posted by Guy007 View Post
    I have added the following at the rules at the bottom.

    =OPPO PLAYER
    [SimpleArtist]


    It restarted Asset, but unfortunately its done more to the information than expected. It has removed the 'artist' info, but is now showing the [artist] after the track name, and is now also showing the track number, where before it wasn't. This is showing in albums too. So it might take some edits to get it where I want it to be.
    The good news is that the changes were reflected, because it could have been that the Oppo was reading the information from the file itself.

    The bad news is that the implementation of [SimpleArtist] isn't doing what I think it is supposed to do.
    It was implemented to address a problem with another control point that was picking the first artist tag it encountered rather than the first non-AlbumArtist tag (when displaying track listing).
    I had asked to simply remove the AlbumArtist tag, but it looks like it's doing something completely different, which is what you're seeing on the Oppo.

    These are the tags sent through without the [SimpleArtist] change.
    Code:
    <dc:title>Cold Heart</dc:title>
    <dc:creator>Elton John; Dua Lipa</dc:creator>
    <dc:date>2021-01-01</dc:date>
    <upnp:artist role="AlbumArtist">Elton John</upnp:artist>
    <upnp:artist>Elton John; Dua Lipa</upnp:artist>
    <upnp:album>The Lockdown Sessions</upnp:album>
    After the [SimpleArtist] change.
    Code:
    <dc:title> 1 Elton John - Cold Heart</dc:title>
    <dc:creator>Elton John; Dua Lipa</dc:creator>
    <dc:date>2021-01-01</dc:date>
    <upnp:album>The Lockdown Sessions</upnp:album>
    Instead of simply removing "<upnp:artist role="AlbumArtist">Elton John</upnp:artist>" it has removed both artist tags and has modified the <dc:title>.


    @PeterP,
    Would it be possible to modify [SimpleArtist] to have it just remove the AlbumArtist tag, as at the moment I don't think it's working as described ("[SimpleArtist] to not supply composer, conductor or album artist (only artist) for track details to player")?

  5. #5
    Super Moderator
    Join Date
    Jul 2011
    Posts
    1,354

    Re: QNAP / Oppo Playback question

    Thanks for the bug report.

    Regarding modified title and changed album display-
    ={no-identification} is not behaving as documented and values specified there were affecting your controlpoint until you added a special section for it. It currently affects control points not maching specific criteria, not control points not sending any identification.
    This results in unrelated behavior changes from just adding a new section for the controlpoint. To work around, duplicate lines from ={no-identification} in =OPPO PLAYER.
    I'm not sure what this was changed for, searching change logs now.

    The intended behavior of [SimpleArtist] is to send no artist info other than <dc:creator>. Is <upnp:artist> duplicating value of <dc:creator> really needed here? If yes, I'll make it possible to send such.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •