Products            Buy            Support Forum            Professional            About            Codec Central
Results 1 to 4 of 4

Thread: Registration issues - Batch Ripper

  1. #1

    Registration issues - Batch Ripper

    I previously had Batch Ripper installed and running fine with my Nimbie. I hadn't used it for a while. When I ran it yesterday, it presented me with the dbPoweramp Licence Details Box stating:

    dBpoweramp reference: Trial Expired
    Component Requires dBpoweramp Reference

    I purchased the whole Music Converter packager and had it installed. I click the Register button and it takes me to the purchase page. I use my order number for the registration retrieval process, download the same version again, install it when I run it, I'm back to the first step. I uninstalled all the dBpoweramp app I had, and installed them fresh...same result. As well, CD Ripper runs, but it thinks it a trial version and won't let me search album art...something I've never had problems with in the past. So....

    - is there a simple fix for this? Can I put a license number into the app somewhere so it will know I paid?
    - will I need to go through this procedure every time I let the app set idle for a month or three?

    This process really needs to work better than this. Once installed and set up, I shouldn't have to worry about type of thing.

    Any suggestions are appreciated.


  2. #2

    Re: Registration issues - Batch Ripper

    An update to this problem;

    - I have not solved this yet, Batch Ripper will not run, CD Ripper runs, but will not let me choose Album Art from the Internet as it looking for dBpoweramp Reference or Power Pack.

    - when I run dBpoweramp Configuration it indicates that dbPoweramp 64bit: Registered Reference Release 15.3 is the current version

    - CD Ripper can see both my computer DVD drive and my external Nimbie drive

    How do I get past the registration issue so that Batch Ripper will run and CD Ripper will run as a registered version?



  3. #3
    dBpoweramp Guru
    Join Date
    Jan 2011

    Re: Registration issues - Batch Ripper

    It is likely you have a mix of 32 and 64 bit. Uninstall dBpoweramp, uninstall batch ripper, reboot, install dBpoweramp from registration retrieval, the download a new batch ripper and install to the Same location as dBpoweramp

  4. #4

    Re: Registration issues - Batch Ripper

    Thank you!
    I followed your directions and everything seems to be running. I will rip some discs later today.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts