title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 10 of 10

Thread: Batch Converter bypasses some Symbolic Linked file-types

  1. #1
    dBpoweramp Enthusiast
    Join Date
    May 2020
    Location
    Drop Bear Island
    Posts
    57

    Batch Converter bypasses some Symbolic Linked file-types

    Hi. (Sorry if this is a repeat posting but my previous post may have been rejected due to the large image I embedded in that post. This post supersedes that posting).

    I've been trying to batch convert Windows 10 Symbolic Linked music files.

    The reason I need to use Symbolic Links is because of the convenience gained by dealing with a much smaller subset of my very large music collection.

    These files will be volume normalized and converted to m4a files. The SymLinked files do not take up any space whatsoever.

    When processing original files (not SymLinked ones), I can successfully batch convert all the file types I require, such as m4a, mp3, ogg, flac, wav and even most mp4 music videos. This allows me to conveniently use these converted files with my SONOS sound system, without any other file playback issues.

    However, if I try to batch convert the same SymLinked files, the Batch Converter seems to just bypass the m4a and mp4 files, with no error messages given. It appears that the metadata is not getting through to the Batch Converter for these file-types only, whereas all the other file-types appear, (with their corresponding metadata) and convert normally. What is so special about m4a files and mp4 files (that also usually contain aac encoded audio)?

    Note: I can successfully process these files with the standard dBpoweramp Music Converter (R17 reference). Unfortunately it is only the Batch Converter that just doesn't process the m4a or mp4 SymLinked files.

    If you look at my attached image, you'll see that the files listed for conversion (at top of image) don't have any metadata associated with them (even though that metadata is in those files). This metadata info only appears when I batch convert the original files rather than the identical Symbolic-Linked ones.

    Any ideas?

    I'm hoping that it may just be a simple Windows 10 registry edit, or perhaps there is some way to force the Batch Converter to always try to obtain the metadata and hence process the m4a and mp4 SymLinked files just like it does with the other SymLinked file-types.

    The fact that the Batch Converter has no problem processing the other SymLinked file-types like mp3, flac, wav, etc makes me believe that this should also be possible with SymLinked m4a audio files, as well as (aac encoded audio) SymLinked mp4 music video files.

    Attached image: Tests.jpg
    Last edited by Dropbear; 06-02-2020 at 07:58 PM.

  2. #2
    dBpoweramp Enthusiast
    Join Date
    May 2020
    Location
    Drop Bear Island
    Posts
    57

    Re: Batch Converter bypasses some Symbolic Linked file-types

    .
    Last edited by Dropbear; 06-02-2020 at 10:08 PM.

  3. #3
    dBpoweramp Enthusiast
    Join Date
    May 2020
    Location
    Drop Bear Island
    Posts
    57

    Re: Batch Converter bypasses some Symbolic Linked file-types

    This image hopefully might make things clearer:



    The "SymLinks" folder contains Symbolic Links to the same named files in the "Original Files" Folder.

    Note that there is no metadata appearing for the m4a or mp4 files from the "SymLinks" folder, however all other file-types are ok. That's really the crux of my problem... why do all the other files-types have no problems showing their metadata when SymLinked, yet m4a and mp4 files don't? It's a puzzle to me.

  4. #4
    dBpoweramp Enthusiast
    Join Date
    May 2020
    Location
    Drop Bear Island
    Posts
    57

    Re: Batch Converter bypasses some Symbolic Linked file-types

    My other image post is still pending approval (which can now be deleted) so I'll post this image here again:

    Hopefully this image might make my issue a bit clearer:

    Attached Image: Example.png

    The "SymLinks" folder contains Symbolic Links to the same named files in the "Original Files" folder.

    Note that there is no metadata appearing for the m4a or mp4 files from the "SymLinks" folder, however all other file-types are ok. That's really the crux of my problem... why do all the other file-types have no problems showing their metadata when SymLinked, yet m4a and mp4 files won't show? It's a puzzle to me.
    Last edited by Dropbear; 06-03-2020 at 12:31 AM.

  5. #5
    Administrator
    Join Date
    Apr 2002
    Posts
    40,146

    Re: Batch Converter bypasses some Symbolic Linked file-types


  6. #6
    dBpoweramp Enthusiast
    Join Date
    May 2020
    Location
    Drop Bear Island
    Posts
    57

    Re: Batch Converter bypasses some Symbolic Linked file-types

    Quote Originally Posted by Spoon View Post
    Thanks Spoon, but I can't access that page.

    I get the forum error: "You do not have permission to access this page. This could be due to one of several reasons:

    1. Your user account may not have sufficient privileges to access this page. Are you trying to edit someone else's post, access administrative features or some other privileged system?

    2. If you are trying to post, the administrator may have disabled your account, or it may be awaiting activation."

  7. #7
    dBpoweramp Enthusiast
    Join Date
    May 2020
    Location
    Drop Bear Island
    Posts
    57

    Re: Batch Converter bypasses some Symbolic Linked file-types

    Ah thanks Spoon. I just worked out that the link you just gave me in your last post was for my "not-yet-approved" forum post (which can be deleted). I had to modify the address you gave, to enable me to see it.

    Sorry, I assumed you had perhaps not seen that post, (as it needed moderator approval) thus I had re-posted it. It gets a bit confusing with this post approval stuff. It sure is a nuisance, yet I guess it's essential to stop spammers.

    Anyway, I do use Folder SymLinks occasionally, but just don't like to use them because of the ease of accidentally erasing files that appear in the follow-through of the link. It's too easy to believe that they are different disposable files. I've been caught out with that before. File SymLinks however can so easily be created and deleted with no worries or thoughts about accidentally erasing crucial files. I create them all in one folder, thousands of them, because my SONOS system doesn't care about the folders or filenames. It only uses the metadata.

    So, I only now wish to use File SymLinks, (which work brilliantly for my specific situation) not Folder SymLinks, which brings me back to my original question...

    Do you have any idea why the m4a and mp4 file SymLinks don't pass through the file metadata? This just puzzles me. Do you think it's a Windows system thing, or is it something specific to the way that Batch Encoder parses the metadata?

    What's the difference with these specific file-types (m4a and mp4) compared to for example- ogg, flac, wav or mp3 files that do pass through their metadata? Sorry to be so persistent on this issue but it's important to me, (it's stopping me from finalizing my encoding plans, and I would rather not have to re-encode my original archive copies to different formats if possible) and I can't fathom why there is the difference in the handling of the metadata, so I need to figure it out.
    Last edited by Dropbear; 06-03-2020 at 05:39 AM.

  8. #8
    dBpoweramp Enthusiast
    Join Date
    May 2020
    Location
    Drop Bear Island
    Posts
    57

    Re: Batch Converter bypasses some Symbolic Linked file-types

    OK. After spending hours testing all this, I'm happy to say that I've solved this issue by using the Batch Video Converter rather than the Batch Audio Converter.

    It correctly passes on all the m4a aac metadata, and thus processes the files successfully. I use the Custom Encoder to ignore the video, so that it only outputs audio. Also, I just needed to rename all the m4a SymLink files with the added extension of mp4. This doesn't in any way affect the original m4a files, but fools the Batch Encoder into thinking that the audio files are video files. It works. Bit of a hack job, but it works. Shame I can't filter to allow audio files to show in the Batch Video Encoder window. Yes I know, they are "not" video files, but hey... it'd still be nice.

    *** So, I only have 1 final issue with this. My MP4 music video files mostly have embedded artwork metadata, which doesn't pass through like it does when I use the Batch Audio Encoder.

    Spoon, is there any chance of allowing the artwork (in the mp4 video file) to pass through? Then I'll be ecstatic and out of your face.

    It might just be that I don't know enough of the ffmpeg commands to choose the right encoder etc. I just used the Custom Encoder- "FFmpeg Full Command Line": -vn -qscale:a 3
    with a "Write Video File Extension" of: .m4a
    Last edited by Dropbear; 06-03-2020 at 11:49 AM.

  9. #9
    Administrator
    Join Date
    Apr 2002
    Posts
    40,146

    Re: Batch Converter bypasses some Symbolic Linked file-types

    We will take a look at this issue.

  10. #10
    dBpoweramp Enthusiast
    Join Date
    May 2020
    Location
    Drop Bear Island
    Posts
    57

    Re: Batch Converter bypasses some Symbolic Linked file-types

    Thanks for looking into this issue, Spoon.

    I've been doing some more experimenting with things, and have discovered some quirks, but good quirks (for me at least).

    Using the standard Music Converter, and not the Batch Converter, if I select a mixture of symlinked files, together with at least one non-symlinked file, everything works well and the Music Converter happily converts all files to MP3 as desired.

    However, if I don't include at least 1 non-symlinked file (or the non-symlinked files alphabetically don't come first in the list), then Music Converter (and Video Converter also, I might add) only seem to find 1 file for conversion. ie. Next to the Encoder choice drop-down box, it will always only show one file to process, and that is all the number of files that it will in fact convert.

    SymLinked Example 1.jpg

    ... and here's an image of what happens (all things otherwise remaining the same) if I "don't" have the non-symlinked files positioned first.

    SymLinked Example 2.jpg

    So, there is something strange in how it sees symlinked files. I really hope you can sort this issue out, because I really want to keep using SymLinked files. It all works so well otherwise, for how I'm organizing everything.

    If not possible then at least with this workaround, (by always having a small dummy non-symlinked file first in the list), I can process a folder of files when I need to. I know I can use the Batch Converter to process the folder, but then there are issues with MP4 video symlinked files.
    Last edited by Dropbear; 06-17-2020 at 03:28 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •