title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 3 of 3

Thread: Detect & Catalog New Tracks Not Working in Windows

  1. #1

    Join Date
    Mar 2020
    Posts
    9

    Detect & Catalog New Tracks Not Working in Windows

    I've got 6.2 running on Windows on a dedicated system that only serves up audio files. The actual library is on a WD NAS shared as \\EX2\Media\Music.


    As of late, I can drop a bunch of new files onto the NAS and they don't get detected by Asset. I have to manually run the Rescan Library function.

    I wrote a quick app to see if notifications are being properly sent by the OS and they are, my wait returns as soon as I touch anything in the target path.
    Any idea why this is failing in Asset or what I can do to make it more reliable?

    Code:
    CString path(L"\\\\EX2\\Media\\Music");
    	DWORD notifyFilter(FILE_NOTIFY_CHANGE_FILE_NAME | FILE_NOTIFY_CHANGE_DIR_NAME | FILE_NOTIFY_CHANGE_ATTRIBUTES | FILE_NOTIFY_CHANGE_SIZE | FILE_NOTIFY_CHANGE_LAST_WRITE);
    	HANDLE ffhandle = FindFirstChangeNotification(path, true, notifyFilter);
    
    	while (1) {
    		DWORD waitResult = WaitForSingleObject(ffhandle, INFINITE);
    		wprintf(L"something in the library has changed\n");
    	}
    
    	FindCloseChangeNotification(ffhandle);

  2. #2
    Administrator
    Join Date
    Apr 2002
    Posts
    41,615

    Re: Detect & Catalog New Tracks Not Working in Windows

    Asset uses the same code, perhaps it is the account it is running under?

  3. #3

    Join Date
    Mar 2020
    Posts
    9

    Re: Detect & Catalog New Tracks Not Working in Windows

    well, let me play around with that. I'm running everything as me.
    I may set up a service account to run Asset and see how that goes.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •