I am a long standing user of Asset UPNP since v4; it is an exceptional product and I have never had to seek help from the forum. Unfortunately there is always a first time.

I am trying to use the gain replay feature for the first time, triggered by the purchase of a Yamaha MusicCast system, so that I can comfortably play jukebox selections.

It works very well except that for HiRes FLAC files it is hit and miss. Specifically:
1. All MP3s play normally (but of course, with gain replay applied)
2. All 16-bit, 44.1Khz FLAC files also play normally (of course, with either LPCM and WAV transcoding)
3. I cannot get 24-bit, 44.1Khz FLAC files to play - I get an error message "Unable to Play" on the Yamaha. I have tried two software DLNA players which I use for portable music(USB Audio Pro, Bubble uPNP) and several albums but they all give the same error. This happens with both LPCM and WAV transcoding. As an experiment I selected MP3 transcoding; same result!
4. I get much the same result with 24-bit, 96Khz FLAC files; except that one particular album did play correctly.

As an experiment I switched Gain Replay off and only selected transcoding to LPCM (and then WAV) for FLAC files. Same result. So it is not the Gain Replay but the transcoding which is causing the issue.

Without transcoding the MusicCast system play everything natively perfectly.

I ran all the HiRes albums against Lossless Audio Checker to check for stream errors. All were clean.

Appreciate any advise and guidance. Is the transcoding artwork size sensitive?