Products            Buy            Support Forum            Professional            About            Codec Central
Results 1 to 3 of 3

Thread: CD Ripper/AccurateRip under Windows 10 Anniversary Version 1607 running in VirtualBox

  1. #1

    CD Ripper/AccurateRip under Windows 10 Anniversary Version 1607 running in VirtualBox

    I am encountering a strange problem in dBpoweramp CD Ripper after doing the Windows 10 64-bit (Pro) Feature Upgrade to the "Anniversary" edition version 1607. I didn't have this problem during my prior time with Windows 10 version 1511. My configuration is a bit complicated, but I had sorted it out completely before this upgrade to W10 v1607.

    My configuration:
    • Main operating system Linux Mint 18.0, 64-bit
    • Oracle VirtualBox version 5.0.24 (most recent one with the official Linux Mint repository), including Extension Pack
    • Windows 10 64-bit (Professional) running within the VirtualBox
    • dBpoweramp Registered v16.1 64-bit running under the sandboxed Windows 10

    When I had been using Windows 10 version 1511, all initial problems with dBpoweramp CD Ripper got sorted out, cf. this thread
    The point behind the issue had been that VirtualBox transfers a drive name to the operating system which then is unknown to the AccurateRip database.

    Now, I got my Windows 10 64-bit Pro upgraded to the Anniversary edition version 1607. Sigh..., for reasons maybe known to Microsoft only, a couple of problems started. The installation itself went fine, lucky me... Also, I did not encounter the problems described in

    However, my problems now are:
    1. All sounds (system sounds, audio replay) are heavily distorted in a crackling fashion.
    2. dBpoweramp CD Ripper doesn't work properly anymore. A full uninstall and re-install including setting everything up from scratch didn't help.

    Problem (1) might be a problem related to the Oracle VirtualBox, since it is discussed heavily in the corresponding forum. I'm trying to find a solution there.

    The CD ripper problem (2) shows up like this:
    • The CD drive is set up correctly, offset for AccurateRip determined with the same result as always, C2 error capability determined as well.
    • When inserting a CD in order to rip it, CD Ripper correctly finds it in the AccurateRip database.
    • However, in no instance whatsoever does the rip result agree with the AccurateRip database value. Tried with a couple of CDs and many tracks. I am always getting an "(x) AR(nnn) (tick mark) Secure" output from CD Ripper. I read this as "my rips now always seem to be error-free within themselves (just one pass), but never agree with anybody else's rips". Previously (before Anniversary), ripping these CDs did always agree with the AR database.

    Any similar observations or help out there? I admit that my computer configuration is somewhat out of the ordinary. But it had worked fine before my Windows 10 got upgraded to the Anniversary edition.

    Thanks a lot in advance!

  2. #2

    [Tentative SOLVED] CD Ripper/AccRip under Windows 10 AU v1607 running in VirtualBox

    Here's my preliminary solution to this issue. I looked again into what settings were employed in the older virtual machine with Windows 10 64-bit version 1511 as the guest system, as compared to what seems to be needed now with Windows 10 64-bit Anniversary Update version 1607 as the guest system. (Fortunately, revisiting an older operating system status is quite easy when running virtualization by means of the Oracle VirtualBox.)

    For both guest OS instances, the CD drive in Oracle's VirtualBox is set up to use "Passthrough". Oracle mentions that CD/DVD passthrough handling still is sort of experimental; only standard data CD and DVD reading is implemented in a regular fashion without this passthrough.

    My dBpoweramp CD Ripper settings were/are:
    • Windows 10 version 1511: CD ROM communication "SCSI Pass Through (SPT)", which normally is the standard; AccurateRip enabled; C2 error pointers enabled; drive offset determined correctly
    • Windows 10 Anniversary Update version 1607: CD ROM communication needs to be set to "Windows Internal", which sacrifices C2 error pointers and other advanced settings; AccurateRip enabled; no C2's; Ultra Secure settings adjusted accordingly; drive offset just the same as before

    There was no way of getting dBpa CD Ripper to do correct AccurateRips under Win 10 AU v1607 as a guest OS in Oracle VirtualBox other than reducing the CD ROM communication to "Windows Internal".

    Dear Spoon, maybe you can make sense out of this. An explanation of what "Windows Internals" means in terms of CD ROM communication might make things more transparent. Of course, my user account in both versions of the Win 10 OS has administrator rights.

    I am offering this recipe here for everybody with a similar configuration and issue. Happy to receive any feedback. It should be noted that I have neither gathered long-term experience with this setting now nor did I check into every piece of dBpa CD Ripper's features. Hope it works!

  3. #3
    Join Date
    Apr 2002

    Re: [Tentative SOLVED] CD Ripper/AccRip under Windows 10 AU v1607 running in VirtualB

    It possibly means the update breaks the virtual machine hosts ability to pass direct access to the cd drive.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts