title
Products            Buy            Support Forum            Professional            About            Codec Central
 

Asset UPnP is not showing up.

Collapse
X
 
  • Time
  • Show
Clear All
new posts
  • Jgeffen
    • Feb 2024
    • 14

    Asset UPnP is not showing up.

    I have installed the latest Asset Synology app again on my new Synology NAS with Relatek CPU, including the latest DSM version, and it seems to work fine after scanning my music, but I don't see it in my UPnP app on my Mac and other devices. I installed the Mac version too and that is working fine on all my devices.
    What can be the cause of this 'NAS failure'? In the past it was working fine too.
    Last edited by Jgeffen; February 13, 2024, 03:12 PM.
  • Spoon
    Administrator
    • Apr 2002
    • 44013

    #2
    Re: Asset UPnP is not showing up.

    Try restarting everything, including nas and router.
    Spoon
    www.dbpoweramp.com

    Comment

    • Jgeffen
      • Feb 2024
      • 14

      #3
      Re: Asset UPnP is not showing up.

      Thanks, but that did not work, unfortunately...
      Last edited by Jgeffen; February 13, 2024, 09:28 PM.

      Comment

      • Spoon
        Administrator
        • Apr 2002
        • 44013

        #4
        Re: Asset UPnP is not showing up.

        Are you able to access the settings page for Asset running on the NAS?
        Spoon
        www.dbpoweramp.com

        Comment

        • Jgeffen
          • Feb 2024
          • 14

          #5
          Re: Asset UPnP is not showing up.

          Yes, thanks, and everything on that page is working fine.
          My whole library is scanned correctly and exactly the same as with the Asset Mac UPnP scan.
          The latter is working fine on all my devices, as I wrote before.

          This page is also telling me: 'Version: R2023-06-06 [Linux-ARM64]; Functionality: Premium Registered; Updates for life'.
          But I do have the 'Realtek RTD1619B SoC' CPU. Can that be the cause, although it seems to work fine?
          Last edited by Jgeffen; February 14, 2024, 03:16 PM.

          Comment

          • Jgeffen
            • Feb 2024
            • 14

            #6
            Re: Asset UPnP is not showing up.

            Hi, thanks for helping, but I did try this but not solution.
            Last edited by Jgeffen; February 14, 2024, 03:27 PM.

            Comment

            • Spoon
              Administrator
              • Apr 2002
              • 44013

              #7
              Re: Asset UPnP is not showing up.

              Your CPU is arm v8 so should be fine.
              Spoon
              www.dbpoweramp.com

              Comment

              • Jgeffen
                • Feb 2024
                • 14

                #8
                Re: Asset UPnP is not showing up.

                Okay, clear, thanks!

                Comment

                • PeterP
                  Super Moderator
                  • Jul 2011
                  • 1370

                  #9
                  Re: Asset UPnP is not showing up.

                  If you can access settings, Asset program is running but somehow being blocked from being found by other machines on your network.

                  Please try this on your Mac: https://www.dbpoweramp.com/beta/AssetFinder.dmg
                  It's a simple app I made for listing & configuring Asset instances on your network. Does it find your Synology Asset?

                  Comment

                  • Jgeffen
                    • Feb 2024
                    • 14

                    #10
                    Re: Asset UPnP is not showing up.

                    Thanks Peter, it doesn't find my Synology Asset...

                    What I can think of is that after migrating my old NAS to the new one, by moving the WD red drives to the new NAS, perhaps some old files left behind making this situation.

                    Gr. Jos.
                    Last edited by Jgeffen; February 15, 2024, 10:50 AM.

                    Comment

                    • PeterP
                      Super Moderator
                      • Jul 2011
                      • 1370

                      #11
                      Re: Asset UPnP is not showing up.

                      Please open Synology control panel, Connectivity / Security / Firewall.
                      Is the firewall feature enabled or not?
                      If yes, please allow incoming connections on port 26125, which is being used by Asset media sharing service.

                      Comment

                      • Jgeffen
                        • Feb 2024
                        • 14

                        #12
                        Re: Asset UPnP is not showing up.

                        That did not help too. Even not when I disable the firewall.

                        Comment

                        • PeterP
                          Super Moderator
                          • Jul 2011
                          • 1370

                          #13
                          Re: Asset UPnP is not showing up.

                          In your web browser, please try loading:
                          http://[ip]:26125/DeviceDescription.xml
                          Replace [ip] with IP address of your NAS
                          Does it show anything (should show raw device description of your Asset) or does it entirely fail loading?

                          Comment

                          • Jgeffen
                            • Feb 2024
                            • 14

                            #14
                            Re: Asset UPnP is not showing up.

                            Hi Peter, I got this:

                            This XML file does not appear to have any style information associated with it. The document tree is shown below.
                            <root xmlns="urn:schemas-upnp-org:device-1-0" xmlns:dlna="urn:schemas-dlna-org:device-1-0">
                            <specVersion>
                            <major>1</major>
                            <minor>0</minor>
                            </specVersion>
                            <device>
                            <deviceType>urn:schemas-upnp-org:device:MediaServer:1</deviceType>
                            <friendlyName>Asset UPnP: HomeServer</friendlyName>
                            <manufacturer>Illustrate Ltd</manufacturer>
                            <manufacturerURL>http://www.dbpoweramp.com</manufacturerURL>
                            <modelDescription>Media Server</modelDescription>
                            <modelName>Asset UPnP Server</modelName>
                            <modelURL>http://www.dbpoweramp.com</modelURL>
                            <modelNumber>1.0</modelNumber>
                            <serialNumber/>
                            <UDN>uuid:52882137-C26F-9872-0-123456789abc</UDN>
                            <presentationURL>http://10.0.1.10:45537</presentationURL>
                            <dlna:X_DLNADOC xmlns:dlna="urn:schemas-dlna-org:device-1-0">DMS-1.50</dlna:X_DLNADOC>
                            <iconList>
                            <icon>
                            <mimetype>image/jpeg</mimetype>
                            <width>120</width>
                            <height>120</height>
                            <depth>24</depth>
                            <url>/images/platinum-120x120.jpg</url>
                            </icon>
                            <icon>
                            <mimetype>image/jpeg</mimetype>
                            <width>48</width>
                            <height>48</height>
                            <depth>24</depth>
                            <url>/images/platinum-48x48.jpg</url>
                            </icon>
                            <icon>
                            <mimetype>image/png</mimetype>
                            <width>120</width>
                            <height>120</height>
                            <depth>24</depth>
                            <url>/images/platinum-120x120.png</url>
                            </icon>
                            <icon>
                            <mimetype>image/png</mimetype>
                            <width>48</width>
                            <height>48</height>
                            <depth>24</depth>
                            <url>/images/platinum-48x48.png</url>
                            </icon>
                            </iconList>
                            <serviceList>
                            <service>
                            <serviceType>
                            urn:microsoft.com:service:X_MS_MediaReceiverRegist rar:1
                            </serviceType>
                            <serviceId>
                            urn:microsoft.com:serviceId:X_MS_MediaReceiverRegi strar
                            </serviceId>
                            <SCPDURL>
                            /X_MS_MediaReceiverRegistrar/52882137-C26F-9872-0-123456789abc/scpd.xml
                            </SCPDURL>
                            <controlURL>
                            /X_MS_MediaReceiverRegistrar/52882137-C26F-9872-0-123456789abc/control.xml
                            </controlURL>
                            <eventSubURL>
                            /X_MS_MediaReceiverRegistrar/52882137-C26F-9872-0-123456789abc/event.xml
                            </eventSubURL>
                            </service>
                            <service>
                            <serviceType>urn:schemas-upnp-org:service:ContentDirectory:1</serviceType>
                            <serviceId>urn:upnp-org:serviceId:ContentDirectory</serviceId>
                            <SCPDURL>
                            /ContentDirectory/52882137-C26F-9872-0-123456789abc/scpd.xml
                            </SCPDURL>
                            <controlURL>
                            /ContentDirectory/52882137-C26F-9872-0-123456789abc/control.xml
                            </controlURL>
                            <eventSubURL>
                            /ContentDirectory/52882137-C26F-9872-0-123456789abc/event.xml
                            </eventSubURL>
                            </service>
                            <service>
                            <serviceType>urn:schemas-upnp-org:service:ConnectionManager:1</serviceType>
                            <serviceId>urn:upnp-org:serviceId:ConnectionManager</serviceId>
                            <SCPDURL>
                            /ConnectionManager/52882137-C26F-9872-0-123456789abc/scpd.xml
                            </SCPDURL>
                            <controlURL>
                            /ConnectionManager/52882137-C26F-9872-0-123456789abc/control.xml
                            </controlURL>
                            <eventSubURL>
                            /ConnectionManager/52882137-C26F-9872-0-123456789abc/event.xml
                            </eventSubURL>
                            </service>
                            </serviceList>
                            </device>
                            </root>

                            Comment

                            • Jgeffen
                              • Feb 2024
                              • 14

                              #15
                              Re: Asset UPnP is not showing up.

                              Yes, a raw device description.

                              Comment

                              Working...

                              ]]>