title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 10 of 10

Thread: Asset-RaspberryPi64/ARM64 Install and Reboot loading issue

  1. #1

    Join Date
    Jul 2012
    Posts
    36

    Asset-RaspberryPi64/ARM64 Install and Reboot loading issue

    Hi,

    I have a Pi3 running a Linux/moodAudio 64bit OS and am hoping to set up Asset to be running on it to.

    Installing Asset-RaspberryPi64-Premium.tar from my order email link works perfectly until I reboot and then instead of continuing working it doesn't load on reboot.

    Checking the cron file and manually using the instruction in a terminal window effectively loads AssetUPnP, but only until the next reboot...

    Help

  2. #2
    Administrator
    Join Date
    Apr 2002
    Posts
    42,999

    Re: Asset-RaspberryPi64/ARM64 Install and Reboot loading issue

    Post the contents of your cron file, also which cron is it for? the user? or super user account?

  3. #3

    Join Date
    Jul 2012
    Posts
    36

    Re: Asset-RaspberryPi64/ARM64 Install and Reboot loading issue

    Its for the User and contains:

    GNU nano 5.4 /tmp/crontab.DDdXhf/crontab
    @reboot /home/pi/bin/AssetUPnP/AssetUPnP

  4. #4

    Join Date
    Jul 2012
    Posts
    36

    Re: Asset-RaspberryPi64/ARM64 Install and Reboot loading issue

    Hi,

    Sorry I replied yesterday but had a moderator review message.....anyway here is the result of cron -e for user Pi:

    GNU nano 5.4 /tmp/crontab.ezj7JN/crontab
    @reboot /home/pi/bin/AssetUPnP/AssetUPnP

    Cheers

  5. #5

    Join Date
    Jul 2012
    Posts
    36

    Re: Asset-RaspberryPi64/ARM64 Install and Reboot loading issue

    Hi,

    Sorry I replied yesterday but had a moderator review message.....anyway here is the result of cron -e for user Pi:

    GNU nano 5.4 /tmp/crontab.ezj7JN/crontab
    @reboot /home/pi/bin/AssetUPnP/AssetUPnP

    Cheers

  6. #6
    Administrator
    Join Date
    Apr 2002
    Posts
    42,999

    Re: Asset-RaspberryPi64/ARM64 Install and Reboot loading issue

    If you type:

    /home/pi/bin/AssetUPnP/AssetUPnP

    it runs?

    Try to add to:

    su crontab -e

  7. #7

    Join Date
    Jul 2012
    Posts
    36

    Re: Asset-RaspberryPi64/ARM64 Install and Reboot loading issue

    Sorry for all the repeats!

    Typing in that works and launches AssetUPnP correctly while putting it into sudo crontab -e unfortunately makes no difference, still no launch on boot.

    Is su crontab -e different to sudo cronab -e?

    Cheers

  8. #8
    Administrator
    Join Date
    Apr 2002
    Posts
    42,999

    Re: Asset-RaspberryPi64/ARM64 Install and Reboot loading issue

    Yes you would do sudo

    Check the permissions of that file, everyone should have execution and read rights of Asset and the folder it is in.

  9. #9

    Join Date
    Jul 2012
    Posts
    36

    Re: Asset-RaspberryPi64/ARM64 Install and Reboot loading issue

    Checked and made sure that /home/pi/bin recursively available to owner/group/other read/write/execution.

    Reboot still fails with /home/pi/bin/AssetUPnP/AssetUPnP in both sudo and user cron.

  10. #10

    Join Date
    Jul 2012
    Posts
    36

    Re: Asset-RaspberryPi64/ARM64 Install and Reboot loading issue

    Just to close this thread with a conclusion...this was a case of file/folder ownership as when i did a clean 64 bit raspbian lite install and assetupnp everything just worked!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •