title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 8 of 8

Thread: 17.7 Bug in tagging/file name

  1. #1

    Join Date
    Jun 2016
    Posts
    12

    17.7 Bug in tagging/file name

    On the extract :
    cd ripper / options / meta data & ID Tag / Write ID Tags / "pad disc number to 2 digits (ie 01)"
    When selected it is not adding the '0'

    The same is the case of the file name creation on the disc info, this is the output I use "[album artist]\[album]\[IFMULTI][disc] [][track] - [title]"

    It was successfully occurring on 17.6 for both file name and meta id.

    Thanks in advance Spoon.

  2. #2
    Administrator
    Join Date
    Apr 2002
    Posts
    42,691

    Re: 17.7 Bug in tagging/file name

    Windows or OS X? which audio format do you write to?

  3. #3

    Join Date
    Jun 2016
    Posts
    12

    Re: 17.7 Bug in tagging/file name

    Quote Originally Posted by Spoon View Post
    Windows or OS X? which audio format do you write to?
    Windows 10 Pro - Version 21H2 / OS Build 19044.1706
    I write to Flac and MP3

    Update - it is just impacting the filename creation, not the meta - I was mis reading a foobar location/filename field.
    Last edited by Guy007; 05-22-2022 at 12:32 PM.

  4. #4
    dBpoweramp Guru
    Join Date
    Nov 2013
    Location
    New York
    Posts
    441

    Re: 17.7 Bug in tagging/file name

    What is your naming string? That determines the file naming. If you are using the multi-encoder then please post the naming strings stored with each of the codecs the multi-encoder is using.

  5. #5
    Administrator
    Join Date
    Apr 2002
    Posts
    42,691

    Re: 17.7 Bug in tagging/file name

    Use as the naming:

    [SETLEN]2,48,,[disc][]

  6. #6

    Join Date
    Jun 2016
    Posts
    12

    Re: 17.7 Bug in tagging/file name

    schmidj - I posted the string in the original email and its the same for both Flac and MP3, I've used the same for years and its always worked fine.

    Spoon - I will try, but why is the old string now not working ?

    Edit - Spoon with the new code I see it forces the 01 for first disc regardless of whether it is multi or not, the method I was using, only added the disc info if it was multi. Is there a way of just getting the '0+disc' if its a multi. Or should I roll back to 17.6 ?
    Last edited by Guy007; 06-02-2022 at 08:58 PM.

  7. #7
    Administrator
    Join Date
    Apr 2002
    Posts
    42,691

    Re: 17.7 Bug in tagging/file name

    [IFMULTI][SETLEN]2,48,,[disc][][][!IFMULTI][disc][]

  8. #8

    Join Date
    Jun 2016
    Posts
    12

    Re: 17.7 Bug in tagging/file name

    Quote Originally Posted by Spoon View Post
    [IFMULTI][SETLEN]2,48,,[disc][][][!IFMULTI][disc][]
    Thanks Spoon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •