title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 9 of 9

Thread: https in m3u playlist not working

  1. #1

    Join Date
    Mar 2016
    Location
    UK
    Posts
    31

    https in m3u playlist not working

    I have several m3u playlists with radio stations.
    Station addresses with https do not work but usually the http version of it does.

    However one station requires https.
    How do you include https etc in m3u playlists.

    Using Windows 10 AssetUpnP, and Linn Kazoo and Serviio (both with same results).

    Sample file enclosed (1st item http works but second https does not).
    (also cannot find way to add logos either)

    *EXTM3U
    *PLAYLIST:Internet Radio: JAZZ Music

    *EXTINF:0,The Jazz Groove Mix *1 (San Francisco, USA)
    http://west-mp3-128.streamthejazzgroove.com/stream

    *EXTINF:0,Jazz 24/7 GBH (WGBH) (Boston, USA)
    https://streams.audio.wgbh.org:8117/Jazz24-7


    Any ideas/advice?

  2. #2

    Join Date
    Mar 2016
    Location
    UK
    Posts
    31

    Re: https in m3u playlist not working

    As a follow-up, I am using AssetUPnP and Linn Kazoo and I want to establish where the problem of handling https is. I am suspecting Kazoo.

    Can you confirm if Asset passes and deals with the "https://streams.audio.wgbh.org:8117/Jazz24-7" line to Kazoo unchanged in the same manner it would an "http ...." line.

  3. #3
    Super Moderator
    Join Date
    Jul 2011
    Posts
    1,197

    Re: https in m3u playlist not working

    Asset bug confirmed, https:// lines in M3U playlists are not handled correctly.
    A fix will be out shortly, thanks for reporting.

  4. #4

    Join Date
    Mar 2016
    Location
    UK
    Posts
    31

    Re: https in m3u playlist not working

    Thanks. That is good news.
    How will I know when fix is available and how do I locate fix to download etc.

  5. #5

    Join Date
    Mar 2016
    Location
    UK
    Posts
    31

    Re: https in m3u playlist not working

    Please do you have an ETA for the fix.

    Also, How will I know when fix is available and how do I locate fix to download etc.?

  6. #6
    Administrator
    Join Date
    Apr 2002
    Posts
    42,836

    Re: https in m3u playlist not working

    We work on the next update to Asset so a couple of weeks.

  7. #7

    Join Date
    Mar 2016
    Location
    UK
    Posts
    31

    Re: https in m3u playlist not working

    Thanks - https now working OK in version 7.4.

    Playlist sub-folders no longer work - although I think 1 saw earlier comment about that.
    Was it intentional?

  8. #8
    Super Moderator
    Join Date
    Jul 2011
    Posts
    1,197

    Re: https in m3u playlist not working

    Thanks for the heads up.
    Playlist subfolders not working is by design, it caused trouble for another user. I can add an option for this for the next update if you really need it.

  9. #9

    Join Date
    Mar 2016
    Location
    UK
    Posts
    31

    Re: https in m3u playlist not working

    I have created a separate folder (to keep radio station playlists together in one place for ease of editing) and added it to the Asset configuration.
    So I have got around the issue to achieve my goal.

    However as sub-folders are allowed in music section, it seems illogical to have that restriction for playlists.
    I would put it back personally.
    Last edited by Paul C; 06-01-2022 at 05:58 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •