Products            Buy            Support Forum            Professional            About            Codec Central
Results 1 to 4 of 4

Thread: I am not getting metadata in the Ripper anymore

  1. #1

    I am not getting metadata in the Ripper anymore

    Hello All-
    This is my first post but I have been using dbPoweramp for probably 10 years which says what an awesome product it is. I have ripped about 1700 albums and had little trouble, except self imposed silliness which I have been able to solve pretty quickly. Which brings me to today.

    First off I am running ver 13.1 on a Win 7 Professional machine. My problem is that I tried to fire up my ripping operation today after not doing any since March and was not able to get any album metadata to populate. I poked around a bit and see that probably that has to do with the demise of freedb. I want to move forward in as intelligent way as possible and am looking for any advice I can get. I assume that I should look for updates and go through that process, I assume it is pretty straight forward. I don't want to upset my operation any more than necessary, it has worked beautifully up til now.

    Any wise words will be appreciated, let me know if more specifics would help.


    PS are those Post Icons helpful?

  2. #2
    dBpoweramp Guru
    Join Date
    Feb 2014

    Re: I am not getting metadata in the Ripper anymore

    Both, your OS as well as your dBpa, are outdated. Win7 is unsupported and unsecure, especially if it has internet connectivity. dBpa's current version is R17. In the last year we have seen that the former metadata provider have discontinued their service and have been substituted by other metadata providers. So it is time to change the OS and the dBpa version.

    Dat Ei

  3. #3

    Re: I am not getting metadata in the Ripper anymore

    I guess I was a bit unclear in what I was looking for. I have had to poke around quite a bit to find the answers to my dilemma and was wondering if I had missed somewhere that I could have gotten the answers all in one place. I will share my solution for anyone else who like me has been running an older version and been very happy with the application. I would also be interested in the reasons for why my metadata stopped working. I have concluded that the sources for the metadata were hard coded into the software and there was no provision to update them or add another. Somewhere between March of 2020 and now several sources became unavailable and my old ver 13 could no longer get any metadata.

    The solution based on that was to upgrade dbPoweramp to ver 17 which involved buying the new version at a 50% discount. Thanks so much for that discount. This is the third time that I have bought the program, and it is well worth the money, the engineering behind it makes my life so much easier. It sucks that we live in a world where we (yes me included) expect everything to be free. I would not be happy with ads in my ripping program so paying a small price upfront is more than fair. The user interface for the new version is very similar and I was so happy that my custom profiles came through unmolested and I could be on my way ripping immediately. I always get nervous when updating an essential software because of the spiraling consequences that can follow. I am happy to report no bad side effects and I can get back to my winter's ripping.

    Cheers-- Steve

  4. #4
    dBpoweramp Guru
    Join Date
    Nov 2007
    Florida, USA

    Re: I am not getting metadata in the Ripper anymore

    Some of the metadata providers went out of business or were purchased and quit licensing their metadata. There are a number of threads on the forum about this back from when it happened. So this was about licensing from providers, not hard-coded software.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts