title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 7 of 7

Thread: Asset UPnP Raspberry Pi Install Issues

  1. #1

    Asset UPnP Raspberry Pi Install Issues

    Hello, I'm a paid user of Asset UPnP due to it kicks so much butt for what I am looking for in an UPnP program. Currently I have it running on my desktop while my music is on a network drive. However, I'm trying to install Asset UPnP on a Ras Pi 4 with the popular music OS moOde in the background. Nice thing about moOde is it gives me a web SSH terminal, which is what I been using to install stuff like the Roon Bridge. However, there are situations that I have to use UPnP over Roon.

    Anyhoo, I been following the new installations here:

    Code:
    https://forum.dbpoweramp.com/showthread.php?45478-Asset-UPnP-for-Linux-instructions-x86-Raspberry-Pi
    However, the issue is trying to install the Purchased License of Raspberry Pi/armv7, so this step here:

    Code:
    wget http://secure.dbpoweramp.com/downloadorder.aspx?ordernum=123456789 -O asset.tar.gz
    Note: I did replace the string of numbers with my order that beings with a R.

    When in terminal it installs as asset.tar.gz. When it comes to the part to untar the file, I get an error message saying file is not a valid .gz file. When I did the file command to see what type of file asset.tar.gz is really is, terminal is telling me that it is a Windows .exe file. Curious, I just put this into Chrome after changing the numbers to my order *:

    Code:
    http://secure.dbpoweramp.com/downloadorder.aspx?ordernum=123456789
    And it gives me the Windows.exe Asset UPnP to install. I was wondering if your team can review the instructions to see if the Ras Pi Purchase link with the terminal instructions is linking to the wrong OS version. The current instructions is easy enough to follow

    Thanks.

  2. #2
    Administrator
    Join Date
    Apr 2002
    Posts
    40,934

    Re: Asset UPnP Raspberry Pi Install Issues

    If your order number relates to the Windows version then only that will be downloaded. On the Asset download page is an offer link to switch licenses.

  3. #3

    Re: Asset UPnP Raspberry Pi Install Issues

    Thank you, I did the license change to Universal. I attempted to download Ras Pi version thru terminal and I'm getting the 409 Download Lock three hour error message. Is this normal for those who recently received a license?

  4. #4

    Re: Asset UPnP Raspberry Pi Install Issues

    @Spoon I'm back. I was able to get Asset installed on my PI Box. Just everyone everything works except for this one bug:

    The program doesn't autostart when rebooting the Pi Box. I checked sudo crontab -e and I can confirm the file and patch is correct. I wonder if the Asset program needs to be in a different location within the OS to have it autostart at reboot to work?

    I have the AssetUPnP and its files installed in the main program in the following:

    Code:
    /home/pi/Asset/AssetUPnP
    When opening sudo crontab -e I have the reboot script as the following:

    Code:
    @reboot /home/pi/Asset/AssetUPnP
    I'm just wondering if it is an issue on where I saved the Asset files within my PI box, or it could be a limiation of Asset for Ras Pi?

  5. #5

    Re: Asset UPnP Raspberry Pi Install Issues

    @Hyperduel I have exactly the same problem as you.
    On a Raspberry Pi3 Asset never restarts automatically at reboot, although it works well if I run the command manually with the same user.
    AssetUPnP is installed in: /usr/bin/AssetUPnP
    and the crontab contains: @reboot _APPDATA_OVERRIDE=/mnt/nas1/asset /usr/bin/AssetUPnP/AssetUPnP
    There are no logs in /var/syslog apart from the line that confirms the command is run.

    Currently in the trial period, so if this doesn't work I probably won't buy the license although the server works well apart from that issue.

  6. #6
    Administrator
    Join Date
    Apr 2002
    Posts
    40,934

    Re: Asset UPnP Raspberry Pi Install Issues

    try:

    @reboot /usr/bin/AssetUPnP/AssetUPnP

  7. #7

    Re: Asset UPnP Raspberry Pi Install Issues

    @Spoon Hi and thanks! it worked when as you suggested I removed the _APPDATA_OVERRIDE. It seems this blocked the start of the daemon, maybe because this was on the USB disk and not mounted at the time Asset started. I don't know, but with the default location (on the SD card) it works fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •