*** I am reposting this in this forum as it was posted in the wrong forum earlier ***

I've been using dbPowerAmp to rip CDs for a while now and it has always performed well. A couple of days ago, I noticed that when I tried ripping a CD, it did not use AccurateRip instead it used the Secure rip method and multiple passes (I think its 2 passes - possibly due to my config). Ripping now takes a lot longer.

I tried ripping a CD that I had ripped successfully in the past. When the CD mounts, the music converter reports that AccurateRip was used successfully previously. However, when I re-ripped that same CD, the app paused at the end of Pass 1 Ripping 99% for a long time. It finally reports an Accurate rip. This is occurring on every track.

Could it be due to a CD drive malfunction?

I am using R17.1 on an iMac with MacOS 10.13.6 (newer versions of MacOS are not supported on my iMac), though I do not think this is the problem as I had the same problem on R17 which performed well the last few months. I updated to 17.1 yesterday, thinking that my app was corrupted, as it was available.

Any help to solve this problem will be appreciated. Thanks everyone.