Products            Buy            Support Forum            Professional            About            Codec Central
Results 1 to 2 of 2

Thread: Indexing network shares with Linux Asset

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Super Moderator
    Join Date
    Jul 2011

    Indexing network shares with Linux Asset

    In order to get network shares indexed by Linux version of Asset, you must first get the network shares mounted by the Linux operating system.

    SMB network shares (commonly also referred to as Windows shares) are handled by CIFS component of Linux. Please make sure that relevant package is installed.
    For an example, on Debian, Ubuntu and derivativtes:
    sudo apt-get install cifs-utils
    Create local folders where the network shares will be mounted.
    For an example:
    sudo mkdir /mnt/mymusic
    Edit the fstab file adding a line to get the share mounted each time the system starts:
    sudo nano /etc/fstab
    At the end of the fstab file, create a line:
    //myserver/mymusic /mnt/mymusic cifs username=myname,password=mypassword,x-systemd.automount 0 0
    Replace 'myserver', 'mymusic', 'myname' and 'mypassword' with your information.
    Ctrl+X to exit the nano editor, Y to save changes when prompted.

    If your network share does not require username or password, i.e. is accessible for guest users, replace username & password info with "guest":
    //myserver/mymusic /mnt/mymusic cifs guest,x-systemd.automount 0 0
    To test if your fstab changes are operational:
    sudo mount -a
    This will automatically mount all folders referenced in fstab. If there are issues with the new configuration, they will be reported. In such case, repeat the fstab editing part and correct the errors; make sure that the IP address, share name, user name and password are correct.

    Once mount -a succeeded, check if your share content shows up in the local mount point folder:
    ls /mnt/mymusic
    Finally, point your Asset at the mount point folder, adding /mnt/mymusic to your list of folders watched by Asset.

    ==== Troubleshooting ====

    Test if your configuration changes endure reboot. Reboot the machine, log in, see if /mnt/mymusic shows your content rather than an empty folder.

    The x-systemd.automount option may not work on some Linux distributions (works on modern Debian, Ubuntu or derivatives). It is intended to delay mounting until relevant services and the network interface have started up. If it's rejected, you can try without it - however the shares may mount correctly with mount -a yet fail to mount on system startup. Refer to your Linux distro's documentation for workarounds.

    If your server address is rejected, see if your Linux can ping it:
    ping <servername>
    If it doesn't work, figure out the server's IP by pinging it on another machine (same command as above in Windows Command Prompt) and using raw IP instead of the server name.
    Last edited by PeterP; 03-20-2020 at 08:05 AM. Reason: Added info for connecting as guest

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts