Hi - essentially like my title says, metadata retrieval takes about 3+ minutes - i read somewhere about unchecking AMG - but i don't have AMG as an option, and i see discogs is already checked - i wish i could get this fixed - thank you!