So I just ripped an old CD, and one of the tracks had a couple hundred "rerips" at the beginning. I listened to the FLAC file which I had generated, using Foobar, and sure enough, there were brief repeating dropouts for the first few seconds. Sounded like one dropout per revolution of the CD. I wasn't surprised, this has happened with defective CDs before. So I thought I'd repair the track if possible and opened it in Izotope RX7 with the thought of using the interpolate function to cover the dropouts, or if they were too long, just chopping the introduction off the song. But when I opened and played the FLAC file in Izotope, it played flawlessly and there were no visible dropouts in the display. So I tried saving it with a different name. The saved file still had the dropouts in Foobar but played fine in Izotope. So I saved it again as a wave file, Foobar still had the dropouts when playing the wave file. But opening the new wave file in the editor, it played fine... Weird.

So I tried playing both the wave file and (when supported) the FLAC file in various software on my computer. It played fine in various editors, Wavelab and Sound Forge, both as FLAC and WAV. It had the dropouts in Media Monkey, and I think one other. Playing it in VLC, I think, was OK. Playing the wave file in Itunes was OK. Winamp was particularly strange, the first time I played it, the dropouts were there, if I hit "rewind to beginning" and played it again, it was clean. If I closed and reopened winamp, the first time the dropouts were there but again, backing it up and playing it again, it would be clean.

BTW, just to be clear, the CD was no longer in the player, it was sitting in front of me on the table.

So do different versions of these players/editors have different amounts of error correction? What kind of error? And how can an editor play it OK but save it, even to a different format, with the errors?? Is this actually some form of extreme jitter, but if so, why would the resaved files still have jitter.

I was thinking that this might be an issue with a cached copy of the file playing, but that wouldn't apply to a file with a new name or format.