title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 6 of 6

Thread: "Encoded by" variable not working as expected

  1. #1

    Join Date
    Nov 2011
    Posts
    18

    "Encoded by" variable not working as expected

    Hi, I would like to add a rule to the "Rule Based Mapping" in the "ID Tag Processing" DSP, which modifies the "Encoded by" field by adding the name of the encoder to it:

    IF Encoded by=[anyvalue]
    SET Encoded by=[Encoded by] & [Encoder]

    The desired result should be to set the Encoded By field to: dBpoweramp Release 16.2 & Lame 3.99.5

    However the above rule is not working. Specifically, the value of [Encoded by] doesn't get replaced with "dBpoweramp Release 16.2". I end up with this instead: [Encoded by] & LAME 3.99.5

    Interestingly, the field name "Encoded by" (directly after "IF" and "SET") works quite fine, which tells me that this is the correct name of this field.

    So why doesn't it work as [Encoded by] then?

    I've also tried [Encodedby] and [Encoded] but no luck. What's the correct name of this variable"
    Last edited by Jezz; 03-05-2017 at 03:57 PM.

  2. #2
    Administrator
    Join Date
    Apr 2002
    Posts
    39,042

    Re: "Encoded by" variable not working as expected

    Try [tag]Encoded by[]

  3. #3

    Join Date
    Nov 2011
    Posts
    18

    Re: "Encoded by" variable not working as expected

    Thanks - that worked perfectly!

    I'd love to understand why this particular tag needs to be written this way - ie. with [tag] before it, and [] after it - whereas the other tags can be written simply as [tag-name]. Why the difference?

    Also, is there any reference somewhere that lists all of the available variables that I can use here? Like [anyvalue], and all of the available tag names, and any other special variables - considering some tags are written as [tag-name] and, it seems, others are written as [tag]tag-name[] - it would be great to have a list of all possible variables.

  4. #4
    Administrator
    Join Date
    Apr 2002
    Posts
    39,042

    Re: "Encoded by" variable not working as expected

    Popular tags can be [xxx], all others are [tag]name[]

  5. #5

    Join Date
    Nov 2011
    Posts
    18

    Re: "Encoded by" variable not working as expected

    Thanks! But how do I know which ones are the popular ones? Is there a list somewhere? Or I just have to guess using trial and error?

  6. #6
    Administrator
    Join Date
    Apr 2002
    Posts
    39,042

    Re: "Encoded by" variable not working as expected

    Just the usual Artist, Album, Title, etc. I have no list, you can use [tag]artist[] and always use [tag] if you want.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •