For the last two days I have also experienced problems with accuraterip. It seems like my problems are very similar to the ones described by Jaredean. In other words, the "Communicating with accuraterip: connecting" dialogue box shows up and sits there for a while and then says "not in accuraterip"

To make sure that it wasn't the specific cds that causes me problems, I tried inserting a couple of cds into my cd writer which definitely should be in the accuraterip database (Michael Jackson "The Essential Michael Jackson" and Bob Dylan "A New Morning"), but I still get the "not in accuraterip" message.

I have tried accessing www.accuraterip.com through the Internet, but without any luck. Finally, I tried pinging the website with the following result:

Pinging accuraterip.com [89.238.133.247] with 32 byte Date
Request timed out
Request timed out
Request timed out
Request timed out

Ping statistics for 89.238.133.247:
Packages (probably wrong word!?): Sent = 4, Received = 0, Lost = 4 (100 % loss)

My results were in Danish, and therefore I have tried to translate them to English.

I am definitely no expert when it comes to routers, servers etc., and consequently I really hope that someone at this forum could give me some suggestions as to how I can solve my problems with www.accuraterip.com

At the moment I am ripping quite many cds on a daily basis with dBpoweramp CD Ripper, and therefore I am really unhappy with the problems that I am now experiencing with accuraterip.

Best regards
Sybrandt.