title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 14 of 14

Thread: Bug: "Replay Gain" utility codec drops some frames

  1. #1
    GiacomoGo's Avatar
    Join Date
    Aug 2006
    Location
    Basel
    Posts
    46

    Bug: "Replay Gain" utility codec drops some frames

    I love the "replay gain" utility... sort of.

    It drops some tags, I'm guessing those that it does not recognize.
    I tag tracks using Helium Music Manager, which stores "Release Year" as a TDRL frame (eg, 2003 for a compilation).

    After I "replay gain" such albums, the release year is gone. Obviously, it would be nice if dBpa did not do that.

  2. #2
    Administrator
    Join Date
    Apr 2002
    Posts
    40,813

    Re: Bug: "Replay Gain" utility codec drops some frames

    Noted.

  3. #3
    GiacomoGo's Avatar
    Join Date
    Aug 2006
    Location
    Basel
    Posts
    46

    Re: Bug: "Replay Gain" utility codec drops some frames

    Quote Originally Posted by Spoon View Post
    Noted.
    Hi,
    Just patiently waiting for progress or plans for progress ...
    Thanks,

  4. #4
    GiacomoGo's Avatar
    Join Date
    Aug 2006
    Location
    Basel
    Posts
    46

    Re: Bug: "Replay Gain" utility codec drops some frames

    Quote Originally Posted by Spoon View Post
    Noted.
    Saw that DSP R6 is out recently, and wondering whether this is fixed yet.

  5. #5
    Administrator
    Join Date
    Apr 2002
    Posts
    40,813

    Re: Bug: "Replay Gain" utility codec drops some frames

    Do you have a specific list of tags it is dropping?

  6. #6
    GiacomoGo's Avatar
    Join Date
    Aug 2006
    Location
    Basel
    Posts
    46

    Re: Bug: "Replay Gain" utility codec drops some frames

    Quote Originally Posted by Spoon View Post
    Do you have a specific list of tags it is dropping?
    I stopped using the RG codec after noticing the dropped element I reported originally. I'm assuming that it'd do the same for any other element it does not recognize as valid id3v2.3 or id3v2.4 elements. Can't it simply preserve any unknown or non-standard or otherwise unknown tags, since several apps apparently create these?

    edit: Seems the same as problems reported by others in the forum.
    Thanks,
    Last edited by GiacomoGo; 05-29-2010 at 10:57 AM.

  7. #7
    GiacomoGo's Avatar
    Join Date
    Aug 2006
    Location
    Basel
    Posts
    46

    Re: Bug: "Replay Gain" utility codec drops some frames

    Quote Originally Posted by Spoon View Post
    Noted.
    Coming up on a year since these dropped frames were reported/noted by myself and others. Seems like a general solution should be avail, rather than handling specific frames individually.

    Paul Taylor has a clean solution with Jaikoz.

    Just patiently wondering about any progress ...

  8. #8
    Administrator
    Join Date
    Apr 2002
    Posts
    40,813

    Re: Bug: "Replay Gain" utility codec drops some frames

    R14 preserves many more now.

  9. #9
    GiacomoGo's Avatar
    Join Date
    Aug 2006
    Location
    Basel
    Posts
    46

    Re: Bug: "Replay Gain" utility codec drops some frames

    Quote Originally Posted by Spoon View Post
    R14 preserves many more now.
    Thanks, Spoon,
    Just to confirm - you mean the same old R2 version of the Replay Gain utility codec? Using this same codec with R14 preserves all unknown/unsupported tag elements, but using it with prior dMC releases does not?

    Seems a bit counterintuitive, so would like to confirm.

  10. #10
    Administrator
    Join Date
    Apr 2002
    Posts
    40,813

    Re: Bug: "Replay Gain" utility codec drops some frames

    It is the codecs supplied with R14 which do the tagging not the ReplayGain utility.

  11. #11
    GiacomoGo's Avatar
    Join Date
    Aug 2006
    Location
    Basel
    Posts
    46

    Re: Bug: dMC R14 "Replay Gain" utility codec STILL drops some frames

    Quote Originally Posted by Spoon View Post
    It is the codecs supplied with R14 which do the tagging not the ReplayGain utility.
    Well I've had a pretty thorough go at the "Replay Gain" utility codec with the latest MC Reference R14, and it still drops frames.

    dMC still drops these tags:
    TDRL - id3v2.4 release time
    TSST - id3v2.4 Set subtitle

    I'll assume it drops quite a few of the id3v2.4 frames, but I only use a few.

    Would be nice to sort this out, so I can finally "replay gain" my library.

  12. #12
    Administrator
    Join Date
    Apr 2002
    Posts
    40,813

    Re: Bug: dMC R14 "Replay Gain" utility codec STILL drops some frames

    dBpoweramp does not support v2.4

  13. #13
    GiacomoGo's Avatar
    Join Date
    Aug 2006
    Location
    Basel
    Posts
    46

    Re: Bug: dMC R14 "Replay Gain" utility codec STILL drops some frames

    Quote Originally Posted by Spoon View Post
    dBpoweramp does not support v2.4
    Thanks for the clarification.
    So to ask the obvious question:

    Any plans to support v2.4.?

    Or is this "standard" a no-go for some reason. The ID3.org site just mentions:

    "A follow on version, 2.4, is documented on this website but has not achieved popular status due to some disagreements on some of the revisions and the tremendous inertia present in the software and hardware marketplace."

    Is the inertia simply overwhelming

  14. #14
    Administrator
    Join Date
    Apr 2002
    Posts
    40,813

    Re: Bug: dMC R14 "Replay Gain" utility codec STILL drops some frames

    Perhaps one day.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •