title
Products            Buy            Support Forum            Professional            About            Codec Central
 

Asset UPnP R4.3 - Problem with Browse Tree for Classical Music

Collapse
X
 
  • Time
  • Show
Clear All
new posts
  • manne99
    • Nov 2014
    • 7

    Asset UPnP R4.3 - Problem with Browse Tree for Classical Music

    Hi,

    Have installed the Asset UPnP R4.3 on a QNAP NAS. It works fine with one exeption:

    I'v a lot of classical music - and from some music I have more than one recording. E. g. I have Beethovens 6th symphony from Bernstein, Karajan, Furtwangler and some others (I use the album-tag of the mp3/flac file for this. So the album tag is e. g. 'Sinfony No. 6' and the title-tag of the mp3/flac has the information about the movements. So I configured a seach tree for this kind of music:

    Startpoint: --> genre -> composer -> ALBUM -> coductor
    _______________________________________-> artist

    This search tree works correct until I reach 'ALBUM'. Instead of showing one item 'Symphony No. 6' or 'Piano Concerto No. 4' I see on all clients I have tried (2 Android devices and a DENON F109) all this albums in parallel and (so I see fife times the 'Piano Concerto Nr. 3') and the browse tree stops there --- I'm not able to make the selections 'conductor' or artist ...

    I've also uploaded a screenshot of the browse tree - but exept this issue all works correct.


  • Spoon
    Administrator
    • Apr 2002
    • 44000

    #2
    Re: Asset UPnP R4.3 - Problem with Browse Tree for Classical Music

    If you set the tree to:

    Genre >> Artist >> Album

    it shows correctly the albums for the selected Artist?
    Spoon
    www.dbpoweramp.com

    Comment

    • manne99
      • Nov 2014
      • 7

      #3
      Re: Asset UPnP R4.3 - Problem with Browse Tree for Classical Music

      yes, definitely....

      it shows the correct albums for the artist.
      .. I've also added the 'year' to the tree (genre >> artist>>album >> year)... this configuration also worked perfect.....

      Comment

      • Spoon
        Administrator
        • Apr 2002
        • 44000

        #4
        Re: Asset UPnP R4.3 - Problem with Browse Tree for Classical Music

        As another test try:

        Genre >> Conductor >> Album

        does this work for you?
        Spoon
        www.dbpoweramp.com

        Comment

        • manne99
          • Nov 2014
          • 7

          #5
          Re: Asset UPnP R4.3 - Problem with Browse Tree for Classical Music

          hi,

          it works the same way as I stated in my initial post...
          ... after selecting a conductor I see three albums of the 'Triple Concerto' in 'parallel' instead of only one

          Comment

          • manne99
            • Nov 2014
            • 7

            #6
            Re: Asset UPnP R4.3 - Problem with Browse Tree for Classical Music

            hi spoon, if it helps you I can put these files in my Dropbox so that you can verify the effect with the original files....

            Comment

            • manne99
              • Nov 2014
              • 7

              #7
              Re: Asset UPnP R4.3 - Problem with Browse Tree for Classical Music

              hi spoon,

              I think I found the root cause of the problem - or ... maybe it's a feature, not a bug :-)

              Currently I'm in the process of a complete "wash-up" of my music library which means I rip all my CD's again and tag them properly.

              So today I added five versions of Beethovens 3rd symphony and also five versions of Beethovens violin concerto to the library (five versions of the triple concert has already been in the library).

              When i took my pad and browsed through the library with the UPnP audio player (genre -> composer -> album -> conductor / year) i found something strange:

              - 1 entry of Beethovens 3rd symphony (--> 5 are in the library)
              - 3 entrys of Beethovens triple concert (--> 5 are in the library)
              - 5 entrys of Beethovens violin concerto (--> 5 are in the library)

              So after checking the mp3/flac - tags again and again ther i found only one peculiarity between these files:

              - For Beethovens 3rd symphony the artist-tag was emty in all 5 albums --> only one entry in the browse tree
              - For Beethovens violin concerto tere was every artist-tag filled in the 5 albums --> 5 entys in the browse tree
              - For Beethovens triple concerto the artist-tag was filled in 3 albums and empty in two albums --> 4 entrys in the browse tree (3 with a artist shown in my upnp-media player and one with no artis shown)

              So it seems that if the artist-tag (also the case when the album-artist tag is filled)! is filled with a name it is handled by the Asset UPnP as different albums although the album-tag is identical.
              This is maybe a feature for Pop or Jazz - Albums but more or less a bug for classical albums

              My hope is now that you find a solution for the useres of classical music.....

              Comment

              • Spoon
                Administrator
                • Apr 2002
                • 44000

                #8
                Re: Asset UPnP R4.3 - Problem with Browse Tree for Classical Music

                Different artist values, would split the albums, unless you set the Compilation tag to 1, or use an 'album artist' value which is set to one value for the whole album.
                Spoon
                www.dbpoweramp.com

                Comment

                • manne99
                  • Nov 2014
                  • 7

                  #9
                  Re: Asset UPnP R4.3 - Problem with Browse Tree for Classical Music

                  thanks..... at least a workaround...
                  .... will try it today evening....

                  Comment

                  • manne99
                    • Nov 2014
                    • 7

                    #10
                    Re: Asset UPnP R4.3 - Problem with Browse Tree for Classical Music

                    I've set the 'compilation' tag to 1 and cleared all 'album artist' tags - now it works fine - thank you!

                    Comment

                    Working...

                    ]]>