title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Page 2 of 4 FirstFirst 1234 LastLast
Results 16 to 30 of 48

Thread: Can't get WinGOGO codec to work

  1. #16
    dBpoweramp Guru xoas's Avatar
    Join Date
    Apr 2002
    Location
    Durham, NC
    Posts
    2,671

    Re: Can't get WinGOGO codec to work

    So are your crashes occuring with the GoGo codec from Codec Central?
    And when crashes do not occur, conversions using dMC with this codec seem slow?
    This is a problem with a variety of files in different formats?
    What conversion settings are you using for dMC with the GoGo codec (bits, frequency, bitrate, channels?

    Just asking to make sure my assumptions about what you are posting is correct.

    Best wishes,
    Bill

  2. #17

    Join Date
    Feb 2006
    Posts
    21

    Re: Can't get WinGOGO codec to work

    Hi Bill,

    Quote Originally Posted by xoas
    So are your crashes occuring with the GoGo codec from Codec Central?
    Yes

    And when crashes do not occur, conversions using dMC with this codec seem slow?
    No, a file is created with no content (0 file size)

    This is a problem with a variety of files in different formats?
    I've only tried converting 16-bit stereo .wav files

    What conversion settings are you using for dMC with the GoGo codec (bits, frequency, bitrate, channels?
    128, 44100, CBR, stereo

    Just asking to make sure my assumptions about what you are posting is correct.
    Thanks! I wish I could make this work and would appreciate any suggestions.

    Best regards

  3. #18
    dBpoweramp Enthusiast
    Join Date
    Jun 2003
    Posts
    146

    Re: Can't get WinGOGO codec to work

    The current version of Gogo is based on parts of Lame 3.92 and optimised for speed. I believe it has not been updated since 2004. Have you tried using the generic CLI codec and gogo.exe? If you need help with the command lines just ask.
    Last edited by Tomb; 02-22-2006 at 06:44 PM. Reason: Extra Info

  4. #19
    dBpoweramp Guru xoas's Avatar
    Join Date
    Apr 2002
    Location
    Durham, NC
    Posts
    2,671

    Re: Can't get WinGOGO codec to work

    My preliminary attempts to use the GoGo codec from Codec Central have not been good.

    The dMC Conversion Progress bar never comes up, a shell file of 0 kb appears with the title of the track. This seems to be the case regardless of which boxes (MMX, KNI, etc) are checked, although a few combination have not yet been tried. More disturbing is that right-clicking and trying to delete these shell files results in an error message indicating that the file is in use.

    It looks like this codec is buggy indeed.
    I'll post further results later.

    Best wishes,
    Bill

  5. #20
    dBpoweramp Enthusiast
    Join Date
    Jun 2003
    Posts
    146

    Re: Can't get WinGOGO codec to work

    I think the problem is that the gogo.dll file on codec central is quite old. I have read on Hydrogen Audio that older compiles have problems running on P3/P4 machines and even on P2! Download the latest gogo bundle from here and replace the existing gogo.dll in the dbpoweramp folder with the one in the zip file.

  6. #21

    Join Date
    Feb 2006
    Posts
    21

    Re: Can't get WinGOGO codec to work

    I've tried substituting 2 gogo.dll files that I know work on my system (with the WinGoGo interface) but no luck. I was really hoping to be able to use dMC as a front end instead of the WinGoGo GUI or command line ... it's just more convenient. I suspect other dMC users might not mind having this option since the performance of GoGo is quite good and the speed improvement is dramatic.

  7. #22
    dBpoweramp Guru xoas's Avatar
    Join Date
    Apr 2002
    Location
    Durham, NC
    Posts
    2,671

    Re: Can't get WinGOGO codec to work

    I can report that the gogo.dll mentionned by Tomb (in post *20 of this thread) seems to make a difference on my machine (1.3 gHz Celeron Processor with 384 mb ram running Windows XP SP 2 with added video and sound cards) but it does not work.

    Rather than the results I got with the original .dll (reported in post *19), I am now consistently having the dBpowerAMP Music Converter come up. In one trial I managed to get an error message that the codec could not be opened. In every other trial the conversion timer runs and no progress is shown on the conversion and Windows Task Manager shows that 100% of the CPU is being used. The program will not cancel or close on its own. Resetting conversion priority from Below Normal to Above Normal only resulted in the computer freezing up everything but dMC. I do get the 0 kb shell files being formed but they still have no audio content.

    I have not exhausted all the combinations for the setting (MMX, 3D Now, KNI, etc) nor have I ruled out a corrupt installation. I have only looked at cbr conversions at 44.1 kHz so I can't say yet whether vbr works any better or not. But this very much looks like a bad codec. Can anyone report a successful use of the GoGo mp3 codec in dMC? If so, it would be helpful to know what version of dMC you have and what version of Windows and which settings you are using.

    Snddes- Does your WinGoGo have these same settings (MMX, etc)? If so, which do you use? Is there an active link you can furnish for WinGoGo?

    Best wishes,
    Bill

  8. #23
    dBpoweramp Enthusiast
    Join Date
    Jun 2003
    Posts
    146

    Re: Can't get WinGOGO codec to work

    It did work briefly for me but now has stopped. Is the problem not the dll but the way dbpoweramp calls up this particular codec? On another note using the gogo.exe with the generic cli codec works fine.

  9. #24

    Join Date
    Feb 2006
    Posts
    21

    Re: Can't get WinGOGO codec to work

    Quote Originally Posted by xoas
    Snddes- Does your WinGoGo have these same settings (MMX, etc)? If so, which do you use? Is there an active link you can furnish for WinGoGo?
    Bill,

    The only link I know of is the one in message *20 (v2.39c.) I don't think the version I've been using for years (v2.351) is available anywhere anymore.

    In the WinGoGO shell -> CPU Encode Method -> Extension Unit, my settings look like this:

    X Use IA-MMX Extension
    - Use 3DNow! Extension (grayed out)
    - Use AMD Enh-3DNow!/AMD-MMX2 Extension (grayed out)
    X Use SSE-SIMD Extension

    There's also an option to use Dual CPU which defaults to 'checked' although I don't have dual CPUs.

    Regards

  10. #25

    Join Date
    Feb 2006
    Posts
    21

    Re: Can't get WinGOGO codec to work

    UPDATE:

    I found a copy of the latest gogo.dll (v3.13) here: www.rarewares.org/mp3.html . Incredibly, it's even faster than the older versions ... it's able to create a 128-kbps stereo .mp3 of an hour-long .wav file in about a minute! To me the quality sounds identical to the older versions that took about 1:30.

    I also downloaded the trial version of a CD ripper called ACXtractor that is supposed to be able to use the gogo codec, and in fact it does. Which leads me to believe that dMC should be able to successfully use WinGoGo. I suspect the fact that the older version of the gogo codec is available at codec-central means that it did once work.

    I hope I'm not being a PITA! If I didn't like dMC so much better than all other file conversion/CD ripper front ends I've tested (including the one mentioned above) I wouldn't bother trying to get the gogo codec to work with it. If I could get the same speed/quality results with the internal Lame encoder, that would be fine too, but it doesn't seem to be possible.

    Any additional help or suggestions about this would be greatly appreciated.

    Thanks

  11. #26
    dBpoweramp Enthusiast gameplaya15143's Avatar
    Join Date
    Sep 2005
    Posts
    276

    Re: Can't get WinGOGO codec to work

    considering the dmc gogo plugin is being crashed by ntdll.dll... it probably works on win98

  12. #27
    dBpoweramp Enthusiast
    Join Date
    Jun 2003
    Posts
    146

    Re: Can't get WinGOGO codec to work

    Quote Originally Posted by Snddes
    I found a copy of the latest gogo.dll (v3.13) here: www.rarewares.org/mp3.html .
    That's the one I linked to in my post above.

    Quote Originally Posted by Snddes
    Any additional help or suggestions about this would be greatly appreciated. Thanks
    Have you tried gogo.exe with the generic CLI codec? You will get better results with this than the dll in any case. I used this command line [InFile] [OutFile] -v 2 -m j -q 3 without any problems.

  13. #28

    Join Date
    Feb 2006
    Posts
    21

    Re: Can't get WinGOGO codec to work

    Quote Originally Posted by gameplaya15143
    considering the dmc gogo plugin is being crashed by ntdll.dll... it probably works on win98
    Nope. :( Just tried it on an old W98SE machine.

  14. #29

    Join Date
    Feb 2006
    Posts
    21

    Re: Can't get WinGOGO codec to work

    Have you tried gogo.exe with the generic CLI codec? You will get better results with this than the dll in any case. I used this command line [InFile] [OutFile] -v 2 -m j -q 3 without any problems.
    It works fine with WinGoGo's GUI too, but I'm looking for the convenience of using dMC's right-click "Convert to" option and being able to use gogo with dMC's CD ripper.

  15. #30
    dBpoweramp Enthusiast
    Join Date
    Jun 2003
    Posts
    146

    Re: Can't get WinGOGO codec to work

    Quote Originally Posted by Snddes
    It works fine with WinGoGo's GUI too, but I'm looking for the convenience of using dMC's right-click "Convert to" option and being able to use gogo with dMC's CD ripper.
    Er you can! Any of the generic CLI codecs work in the same way as those from codec central.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •