title
Products            Buy            Support Forum            Professional            About            Codec Central
 

NOTE: Any posts to this forum on or after 16th April will disappear in few days when we transition to a new forum
Results 1 to 11 of 11

Thread: Updated to 2024-02-01 - Wav tags not showing Explorer for new rips done after update

  1. #1

    Updated to 2024-02-01 - Wav tags not showing Explorer for new rips done after update

    Running Windows 10 64 bit.
    Everything working fine.
    Updated to 2024-02-01 [64 Bit].
    Suddenly for any new rips after the update, pretty much all metadata for artist, album, title, etc. is not showing in the Explorer folder.
    Checked folders for old rips and everything still shows fine.
    Did Edit Tags to check metadata on problematic new rip and metadata is all there, but it doesn't show in Explorer folder view.

    When I rip to wav, I always run ID Tag Update to make tags items like multiple genres show up correctly in Windows.

    Why is this happening on my new rips after I updated?

    Any ideas? Thanks

  2. #2

    Re: Updated to 2024-02-01 - Wav tags not showing Explorer for new rips done after upd

    By the way, this is the 2nd attempt at updating and the same thing happened last time.
    I didn't have time to research the issue, so that time I did a system restore back to the older dbPa version and it resumed working fine.
    This only happens now when I do an update.

  3. #3

    Re: Updated to 2024-02-01 - Wav tags not showing Explorer for new rips done after upd

    Additional info: Works okay with FLAC.
    Problem only appears with wav.

  4. #4
    Administrator
    Join Date
    Apr 2002
    Posts
    43,886

    Re: Updated to 2024-02-01 - Wav tags not showing Explorer for new rips done after upd

    It is windows which are displaying the tags and it does not do a good job of it, see:

    https://forum.dbpoweramp.com/showthr...h-dBpoweramp-s

  5. #5

    Re: Updated to 2024-02-01 - Wav tags not showing Explorer for new rips done after upd

    Question remains what changed in DMC dbPoweramp in these last two updates that caused this problem?
    I have ripped over 71,000 wav tracks using dbPoweramp ripper and never had a problem until I did the recent update.
    ALL OF MY OLDER EXISTING RIPS are still showing tags in Windows Explorer folders the same as they ever have.

    The problem in displaying tags in Explorer is ONLY WITH NEW RIPS DONE AFTER I UPDATED DMC.

    For example, I was using 2023.06.23 before the update and all worked fine.
    This week, I updated to 2024.02.01 and now have the problem.
    (I think I went thru the same deal with 2023.12.22 with same problem and ended up doing a restore back to my 2023.06.23 version because older version continued to work flawlessly).

    What changed in the most recent updates that caused tags to not show ONLY ON MY NEW RIPS AFTER THE UPDATE???
    Something is not happening in the new version that was happening in the older versions because my old rips still show tags in Explorer with no problems.

    I see the 2023.12.22 update changes included "WAV: Change tag type if asked to save ReplayGain and existing tags can't hold ReplayGain.".
    Could something like this be causing the sudden new issue?
    I do write ReplayGain tags to my wav files when ripping.
    The fact that all my old existing tags are still showing fine but the new post-update ripped tags are not showing seems to indicate that something has clearly changed in the what dbPowerAmp is doing after my rip.

    Any ideas?

  6. #6

    Re: Updated to 2024-02-01 - Wav tags not showing Explorer for new rips done after upd

    Further update to above last reply:
    I noted in the 2023.12.22 update that it changed "WAV: Change tag type if asked to save ReplayGain and existing tags can't hold ReplayGain.".

    So I just did a test rip using my updated version 2024.02.01 and I turned off ReplayGain DSP in my ripper.
    Voila...the tags on the new rip came back and solved the issue...EXCEPT, of course I lost my ReplayGain tags which I need.

    If I convert these new rips using ReplayGain converter, RG tags are written AND the tags still display in Explorer after the conversion.

    This means this NEW tag display issue in Windows is something in the 2023.12.12 update regarding the writing of ReplayGain tags in the ripping process. Spoon...any chance you could review this to see if issue can be resolved?
    Otherwise, I have to rip the CD, then separately run ReplayGain converter to write RG tags on my wav files.
    It worked just fine all these years until the 2023.12.22 update...hope there can be a fix found.

    Please let me know if you need any additional info...thanks.
    Last edited by DBPA ROCKS!; 02-11-2024 at 03:45 PM.

  7. #7

    Re: Updated to 2024-02-01 - Wav tags not showing Explorer for new rips done after upd

    Please read the last two update posts above...but here is also something else I have discovered.
    AFTER UPDATE, if I rip a CD to wav with ReplayGain DSP in effect and RG tags are written to the new wav files, then Windows Explorer does not show the tags in question.
    HOWEVER, if I use Edit Tags to delete the RG tags and run ID Tag Update, then the tags that were not showing in Explorer suddenly come back in Explorer view.
    Of course, then I am missing the RG tags which I need to have.
    But the point is that simply removing the RG tags and running ID Tag Update is enough to make Windows display the tags again...so the problem definitely seems to be related to how dbPoweramp ripper now writes/handles the ReplayGain tags when ripping and this was changed in the 2023.12.22 update. This seems to be why things are not showing properly on new rips after the update.
    Can this be corrected?

  8. #8
    Administrator
    Join Date
    Apr 2002
    Posts
    43,886

    Re: Updated to 2024-02-01 - Wav tags not showing Explorer for new rips done after upd

    You must be writing only wave list ID Tags, not ID3v2 tags to wave files which can handle replaygain, but explorer cannot read. Anyhow, put dBpoweramp as the tag reader for wave files and change the tagging type for wave files to ID3v2

  9. #9

    Re: Updated to 2024-02-01 - Wav tags not showing Explorer for new rips done after upd

    Quote Originally Posted by Spoon View Post
    You must be writing only wave list ID Tags, not ID3v2 tags to wave files which can handle replaygain, but explorer cannot read. Anyhow, put dBpoweramp as the tag reader for wave files and change the tagging type for wave files to ID3v2
    I usually rip with Wave ID Tagging set to (Default - List & ID3)...in this setting, if I rip wave without ReplayGain DSP to write any RG tags, the tags will still show in Windows Explorer like it always has (of course, it's missing any RG tags now).
    If I change the Wave ID Tagging to only ID3 and rip without ReplayGain DSP to write any RG tags, Windows Explorer does not show ANY of the questionable tags...in other words it reflects the new problem that has arisen since the update.

    I have used dbPoweramp since 2013 and purchased multiple versions of the software.
    I use dbPoweramp precisely because of how well it has handled Wave tags and allowed me to use the format and still have tag functionality.
    It's really worked pretty flawlessly for me all these years.

    So I now have over 71,000 wave files ripped with dbPoweramp since 2013 that still display all tags just fine in Windows Explorer folders.
    But...every new rip I perform with dbPoweramp going forward will have this problem with wavpack handling and so the tags will not show in Explorer unless I make changes to my computer.
    You are really losing what set dbPoweramp apart for me from other ripping software.

    What was such a problem that required an update that in effect ruined the whole Wave tagging handling for dbPoweramp (at least in how it plays with Windows Explorer view)?
    I'm in several online CD collector's groups and always promote dbPoweramp to others when asked about best ripping software for uncompressed lossless files. I can tell you there are plenty of potential buyers/users of your software that will likely be turned away by these recent chenges because they don't want to do a regedit, etc to make a work around when the software has previously handled this issue flawlessly for years and years.

    I sure hope you might reconsider rolling back or finding a fix for this specific portion of the recent update in a future update because it really it affecting the usability and ease of use of the dpPoweramp software.
    Last edited by DBPA ROCKS!; 02-12-2024 at 12:35 PM.

  10. #10
    Super Moderator
    Join Date
    Jul 2011
    Posts
    1,365

    Re: Updated to 2024-02-01 - Wav tags not showing Explorer for new rips done after upd

    Thank you very much for the comprehensive bug report. Changed behavior was indeed related to writing ReplayGain tags to files with no prior tags.
    Here's a fixed version of Wave codec:
    https://www.dbpoweramp.com/beta/2024...e-fix/Wave.dll
    Put in Program Files\dBpoweramp\Decoders

  11. #11

    Re: Updated to 2024-02-01 - Wav tags not showing Explorer for new rips done after upd

    PeterP:
    THANK YOU SOOOOO MUCH!!!
    I have tested this new patch and it returns the functionality to the way I have experienced it for the last 11 years.
    Thank you so much for listening and fixing the issue.
    Now all of the tags are showing in Windows Explorer without having to do any registry edit, so this is all we were asking for.
    Thanks again!
    Last edited by DBPA ROCKS!; 02-15-2024 at 09:09 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •