title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 7 of 7

Thread: Folder View & "preformat"

  1. #1

    Folder View & "preformat"

    Hi there,

    I try to use Asset UPnP with my Linn Selekt.
    I only want to us folder view to browse.

    So far, so good - this is working.

    What I don't like:
    The Linn shows the filename (without extension) instead of the title in the display.
    My filenames are always build from tracknumber [space] title.

    I found description for the "preformat"-command in "User Rename List".
    I tried: "preformat:=filename:=[title]" and "preformat:=filename:=%title%".

    The Linn (and the Linn app) always showed the filename when playing.

    Can anybody help?

    Is it possible that the "preformat"-command is not implemented in the Asset version I am using?
    I never updatet my Synology to DSM 7 - so I'm using the latest version for DSM 6.
    Last edited by Kopfschlaechter; 01-02-2024 at 09:28 AM.

  2. #2
    dBpoweramp Guru
    Join Date
    Apr 2021
    Posts
    437

    Re: Folder View & "preformat"

    Preformat was introduced in R2023-05-15.

    The behaviour you're seeing is nothing to do with the Linn, it's the way Asset displays Folder View.
    Last edited by simbun; 01-02-2024 at 11:06 AM.

  3. #3

    Re: Folder View & "preformat"

    Okay, I updated ma Synology to DSM 7.
    I used the actual version of Asset and the preformat-command works fine.
    I see the title instead of the filename.

    Unfortunately now the sort order of albums is gone.
    Titles of an album are now in alphabetical (title) order, they are not longer sorted by tracknumber.

    I have only the folderview in my browsing tree - and I like it this way.

    What can I do to get back correct title order?

  4. #4
    dBpoweramp Guru
    Join Date
    Apr 2021
    Posts
    437

    Re: Folder View & "preformat"

    Quote Originally Posted by Kopfschlaechter View Post
    I used the actual version of Asset and the preformat-command works fine.
    I see the title instead of the filename.

    Unfortunately now the sort order of albums is gone.
    I've just looked at the data that's passed from Asset to the control point (via Debug Log) and it looks like Asset sorts by filename (because <upnp:originalTrackNumber> is not in numerical order), and as you've changed the filename to just title it's now in alphabetical order.

    I can't see any way of overriding this other than to add the tracknumber back into the filename preformat (or removing the preformat entirely if that's what the underlying filename is).

    Media Servers differ with respect "Folder View" but it appears that Asset doesn't look at any tags, just the filename for display and sorting.

  5. #5

    Join Date
    Dec 2018
    Posts
    6

    Re: Folder View & "preformat"

    I added this to the userRenameList:
    preformat:=[album]:=[year] - [album]
    preformat:=filename:=[artist] - [title]

    I restart asset and rescan, and it didn't show in Bubble or Linn app. Any clue?
    Version: 2023-05-15

  6. #6
    Super Moderator
    Join Date
    Jul 2011
    Posts
    1,354

    Re: Folder View & "preformat"

    Please follow formatting in detail:
    https://forum.dbpoweramp.com/showthr...e-List-feature
    You probably want:
    preformat:=album:=[year] - [album]
    No don't enclose first album in square brackets.

    Filename preformat is meant for browsing by folders only, not for other views which are based on tags.

  7. #7

    Join Date
    Dec 2018
    Posts
    6

    Re: Folder View & "preformat"

    Not sure I understand completely what you are saying.
    First here's the content of my userRenameList:

    * Specify tag or display mappings in this form:
    *
    * To rename a shown text, such as 'Artist / Album' type onto a new line: display:=Artist / Album:=Renamed Artist Text
    *
    * To map a tag value such as the genre 'pop/rock' to 'pop': genre:=Pop/Rock:=Pop
    *
    * Note adding a display change requires Asset to be restarted, adding a tag mapping requires a 'Refresh All' rescan.
    preformat:=album:=[year] - [album]



    What I was expecting is to see my albums listed with year prepended, so they are in chronological order.

    When I browse by genre > artist > album with no track listing I got this:

    LinnKazoo.jpgLinnKazoo.jpg

    When I'm browsing by folder and filename (is that what you mean?) I got the same results, but without [All Tracks] and [Shuffle Tracks].

    Is there something I don't understand or not working on my end?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •