hi

I've just upgraded from R16 to R17 of DBPoweramp, and one after having purchased have I've realised (as it wouldn't install, then through reading all of the version logs) that the latest version 17.7 isn't compatable with my version of OsX (el Capitain). I'm not quite sure what to do, as I can't find any way of accessing a slightly older version that is compatible (I think 17.4 and 17.5 should be).

Thanks

richard