title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 12 of 12

Thread: "Error valid mp3 frame not found [clsmpeg123::Init]"

  1. #1

    Join Date
    Oct 2021
    Posts
    6

    "Error valid mp3 frame not found [clsmpeg123::Init]"

    Hi there, anybody got this error message - "Error valid mp3 frame not found [clsmpeg123::Init]"? Im trying to convert mp3 to flac using both Music and Batch converter. Please help. Thanks.

  2. #2
    dBpoweramp Guru
    Join Date
    Dec 2008
    Location
    London, UK
    Posts
    3,888

    Re: "Error valid mp3 frame not found [clsmpeg123::Init]"

    What is the source of your mp3 files?

    Try running Test Conversion on your mp3 files and report the results here.

  3. #3
    Administrator
    Join Date
    Apr 2002
    Posts
    42,163

    Re: "Error valid mp3 frame not found [clsmpeg123::Init]"

    It means the mo3 files are corrupted.

  4. #4

    Join Date
    Oct 2021
    Posts
    6

    Re: "Error valid mp3 frame not found [clsmpeg123::Init]"

    Hi Mville, So the i have converted this song from youtube to mp3 and it plays well no problem - here is the sample of the song.

    https://www.youtube.com/watch?v=D-h6...tqpDV&index=36

    This is in high resolution version. But when i try to convert the song to flac. It gave me the error message but the rest of the song i have managed to source and convert from youtube is fine.

    Thanks for taking time to reply.

  5. #5

    Join Date
    Oct 2021
    Posts
    6

    Re: "Error valid mp3 frame not found [clsmpeg123::Init]"

    Hi Spoon, it plays well though. Im only having issues with the high res versions. Most of the files, i have converted from youtube to mp3 will convert to flac with dbamp no problem. Thanks for your time.

  6. #6
    Administrator
    Join Date
    Apr 2002
    Posts
    42,163

    Re: "Error valid mp3 frame not found [clsmpeg123::Init]"

    Youtube has no default download option, if you use a stream ripper then it is likely that that is not an mp3 file, could be OPUS, or Ogg, or AAC.

  7. #7

    Join Date
    Oct 2021
    Posts
    6

    Re: "Error valid mp3 frame not found [clsmpeg123::Init]"

    Quote Originally Posted by Spoon View Post
    Youtube has no default download option, if you use a stream ripper then it is likely that that is not an mp3 file, could be OPUS, or Ogg, or AAC.
    Thanks. When i check the file type. It says - MP3.

  8. #8
    dBpoweramp Enthusiast
    Join Date
    Oct 2009
    Location
    Bradford, ON Canada
    Posts
    68

    Re: "Error valid mp3 frame not found [clsmpeg123::Init]"

    This seems to be a common theme of late, I have seen identical thread requests elsewhere. I believe these YT &*8220;rippers&*8221; using questionable methods to pull audio streams. These are using m4a containers but putting mp3 extensions. Some players resolve and play them but the tagging throws the file into corrupted status. The issue needs to go back to the ripper and their software. The original files are not downloadable for a reason.

  9. #9

    Join Date
    Oct 2021
    Posts
    6

    Re: "Error valid mp3 frame not found [clsmpeg123::Init]"

    Quote Originally Posted by GBrown View Post
    This seems to be a common theme of late, I have seen identical thread requests elsewhere. I believe these YT &*8220;rippers&*8221; using questionable methods to pull audio streams. These are using m4a containers but putting mp3 extensions. Some players resolve and play them but the tagging throws the file into corrupted status. The issue needs to go back to the ripper and their software. The original files are not downloadable for a reason.
    Lol. Perhaps i should stop using ytmp3 converter.

    The Canadian fall has been nice so far! Enjoy!

    Thanks bro!

  10. #10
    dBpoweramp Enthusiast
    Join Date
    Oct 2009
    Location
    Bradford, ON Canada
    Posts
    68

    Re: "Error valid mp3 frame not found [clsmpeg123::Init]"

    Quote Originally Posted by db fan View Post
    Lol. Perhaps i should stop using ytmp3
    That would be one of them!

    I&*8217;m not sure if there is a fix, but the file type is definitely an issue. I&*8217;d start there.

  11. #11

    Join Date
    Oct 2021
    Posts
    6

    Re: "Error valid mp3 frame not found [clsmpeg123::Init]"

    Quote Originally Posted by GBrown View Post
    That would be one of them!

    I&*8217;m not sure if there is a fix, but the file type is definitely an issue. I&*8217;d start there.

    Thanks! Please spread the love if you get any luck. lol

  12. #12
    dBpoweramp Guru
    Join Date
    Nov 2013
    Location
    New York
    Posts
    421

    Re: "Error valid mp3 frame not found [clsmpeg123::Init]"

    My method for capturing YouTube audio without any (further) degradation:

    Using an audio interface that has digital (such as SPDIF, AES3 or Dante) ins and outs, and an audio editor (Audacity is free and works well): Direct the output of the computer audio to the digital audio output of the interface. Connect or patch the digital output to the digital input. Set audio editor to record from the digital input, start recording. Start the YouTube clip playing. When complete, stop the editor record, use the editor software to set beginning and end of file to save, remove any commercial that appears in the middle. Save/render the edited audio in your desired format. Open the saved file with the contextual dBpoweramp tag editor and add appropriate tags, "cover" artwork and save.

    This may be more work, but it will work if you can play the YouTube item, it is "what you see, what you get" and it will not result in a corrupt file.

    Be aware that most of the items on YouTube are copyright and copying them in this manner might be a copyright violation. YouTube generally does not provide a means to download their content.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •