title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 7 of 7

Thread: Asset 7.3 for RPi - Custom Artwork upload change

  1. #1
    dBpoweramp Enthusiast
    Join Date
    Dec 2013
    Posts
    263

    Asset 7.3 for RPi - Custom Artwork upload change

    Hi, There was a late change to the 7.3 Release of Asset, following Beta releases 1-4. It is the loading of upstream custom artwork. This previously was undertaken as Asset started up and if there are a number of images could delay the availability of Asset in the Controller. However in thr final 7.3 version this upload is undertaken on the fly. Startup performance is without delay, but every time you enter a folder the loading of the images delay the browsing of the folderís content.
    I have over 1,700 custom images loaded, in a library of 7,000 Albums & 90k tracks - not sure how many Album Artists, which is my default folder, say 2,500.
    Can I have the startup load back as an option, over the dynamic loading, as this is affecting usability and navigating through my Album Artist folders.
    I would of given this feedback during the Beta, but this change was made during the release, after Beta 4 had been out for some time.
    Alternatively I will go back to Beta 4, but I donít want to be left at this version over this.
    Thanks,
    Simon

  2. #2
    Super Moderator
    Join Date
    Jul 2011
    Posts
    1,107

    Re: Asset 7.3 for RPi - Custom Artwork upload change

    Addressed in R7.4 beta-
    https://forum.dbpoweramp.com/showthr...inux-R7-4-beta

    New option added to preload the images, under general settings.
    Enabling this will no longer stall Asset startup like it did before, only actual browsing will stall until the image cache has been populated.

  3. #3
    dBpoweramp Enthusiast
    Join Date
    Dec 2013
    Posts
    263

    Re: Asset 7.3 for RPi - Custom Artwork upload change

    Quote Originally Posted by PeterP View Post
    Addressed in R7.4 beta-
    https://forum.dbpoweramp.com/showthr...inux-R7-4-beta

    New option added to preload the images, under general settings.
    Enabling this will no longer stall Asset startup like it did before, only actual browsing will stall until the image cache has been populated.
    Perfect - trying it now.

    Many thanks.
    Simon

  4. #4
    dBpoweramp Enthusiast
    Join Date
    Dec 2013
    Posts
    263

    Re: Asset 7.3 for RPi - Custom Artwork upload change

    Quote Originally Posted by simes_pep View Post
    Perfect - trying it now.

    Many thanks.
    Simon
    Hi,
    On the Asset 7.4 Beta Release 1

    I have the set the 'Preload Images to Memory' flag, and on restart Asset can be seen in HTOP working away processing the uploaded images, as it did with pre Asset 7.3 production release. However, once the preload is complete, the Library is not displayed or available in the Controller (the Naim App on iPadOS), however, is available on the unit (Naim NDS)

    I have tried unsetting the 'Preload' flag and restarting Asset (also a reboot of the RPi) and the Library is not available in this mode either.

    If you could have a look at this version compared to one of the 7.3 Beta releases to see what is different resulting in this behaviour.

    Thanks, Simon.

  5. #5
    Super Moderator
    Join Date
    Jul 2011
    Posts
    1,107

    Re: Asset 7.3 for RPi - Custom Artwork upload change

    Thanks for the details.

    Beta 2 posted, further performance optimizations have been added.
    Enabling "load images to memory" should now result in identical behavior as the old versions.
    I added some tweaks and it should now be usable on your system with this option off also.

  6. #6
    dBpoweramp Enthusiast
    Join Date
    Dec 2013
    Posts
    263

    Re: Asset 7.3 for RPi - Custom Artwork upload change

    Thanks for the update - away for the rest of this week, but will provide feedback as soon as I apply the revised release.

  7. #7
    dBpoweramp Enthusiast
    Join Date
    Dec 2013
    Posts
    263

    Re: Asset 7.3 for RPi - Custom Artwork upload change

    Hi, Applied the R7.4 Beta 2 release, and this now works perfectly with the images loaded into memory. The display of the artwork in my Album Artist / Album is almost instant.
    Since the RPi2 is dedicated to running Asset UPnP server, it is fine for me, to have all available memory used for this purpose.
    Many thanks, Simon.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •