title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 2 of 2

Thread: M4A/AAC broken

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    M4A/AAC broken

    For some reason converting to AAC is just not working. I get the following error : dbpoweramp error writing audio data to StdIn Pipe [dEncoder::EncodeBlock]

    The audio file is 16bit/44.1khz/flac. Nothing unusual. Antivirus is disabled and exceptions added just to be safe. iTunes is installed. I really have no idea anymore.



    Edit & Fix: I fixed it - there's an issue with the current dbpoweramp m4a encoder http://www.dbpoweramp.com/codec-central-m4a.htmfrom here.

    I just downloaded the latest version from https://github.com/nu774/qaac/releases/tag/v2.71 then extracted it to C:\Program Files (x86)\Illustrate\dBpoweramp\encoder\m4a QAAC (iTunes) . Then the EXE had to be renamed to just qaac.exe and rfalac.exe and replace all other files, while keeping encoder.txt
    Last edited by xxtensazenxx; 01-25-2021 at 08:57 PM.

  2. #2
    Administrator
    Join Date
    Apr 2002
    Posts
    41,594

    Re: M4A/AAC broken

    It was not working because you had the 32 bit version of dBpoweramp installed, and this would install the 32 bit version of QAAC, but that would not work with the 64 bit version of iTunes, hence why when you replace with the 64 bit but renamed to the 32 bit filenames it works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •