title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Page 1 of 3 123 LastLast
Results 1 to 15 of 31

Thread: Changed Behavior In Character Mapping

  1. #1
    dBpoweramp Enthusiast
    Join Date
    Dec 2013
    Posts
    52

    Changed Behavior In Character Mapping

    I haven't ripped any classical CDs in a long time (prior to R17), and I'm having difficulty now.

    I had extensive character replacements. For example:

    1. I want to remove any comma - I would do a character replacement for , and then nothing
    2. Replace a colon with a space hyphen space

    I have several more examples that don't seem to work now.

    I found the global option for the semicolon - but it will not accept/save a space hyphen space

    The comma deletion just doesn't work at all.

    These worked OK in previous versions - is there a way I can get this functionality back?

  2. #2
    Administrator
    Join Date
    Apr 2002
    Posts
    41,124

    Re: Changed Behavior In Character Mapping

    To remove a comma in CD Ripper >> CD Ripper Options >> Filename Restricted Characters

    Enter , on the left side and * on the right.

    To replace ';' with '; ' that would be in DSP effect 'ID Tag Processing' under Word / Character replacement, however you will stop multi-artist aware programs from working correctly

  3. #3
    dBpoweramp Enthusiast
    Join Date
    Dec 2013
    Posts
    52

    Re: Changed Behavior In Character Mapping

    Quote Originally Posted by Spoon View Post
    To remove a comma in CD Ripper >> CD Ripper Options >> Filename Restricted Characters

    Enter , on the left side and * on the right.

    To replace ';' with '; ' that would be in DSP effect 'ID Tag Processing' under Word / Character replacement, however you will stop multi-artist aware programs from working correctly
    OK, so now the asterisk is a blank space? Does the comma replacement have to be in the main CD Ripper Options, or can it be a DSP effect?

    You typed a semi colon, then a semi colon space. What I need is to replace ': ' with ' - '

  4. #4
    dBpoweramp Enthusiast
    Join Date
    Dec 2013
    Posts
    52

    Re: Changed Behavior In Character Mapping

    For example - I need this

    Les Francs-Juges, Op. 3, H. 23d: Overature

    to look like this

    Les Francs-Juges Op. 3 H. 23d - Overature

  5. #5
    Administrator
    Join Date
    Apr 2002
    Posts
    41,124

    Re: Changed Behavior In Character Mapping

    Yes you can still do that with the DSP effect.

  6. #6
    dBpoweramp Enthusiast
    Join Date
    Dec 2013
    Posts
    52

    Re: Changed Behavior In Character Mapping

    Quote Originally Posted by Spoon View Post
    Yes you can still do that with the DSP effect.
    OK, given my example above, can you please tell me how to setup DBPoweramp? What used to work no longer works.

  7. #7
    Administrator
    Join Date
    Apr 2002
    Posts
    41,124

    Re: Changed Behavior In Character Mapping

    DSP effect 'ID Tag Processing' under Word / Character replacement

    add ':' to ' - '

  8. #8
    dBpoweramp Enthusiast
    Join Date
    Dec 2013
    Posts
    52

    Re: Changed Behavior In Character Mapping

    Quote Originally Posted by Spoon View Post
    DSP effect 'ID Tag Processing' under Word / Character replacement

    add ':' to ' - '

    Yes, that is what I've been trying to say. That no longer works - you get an error on file write, and it leaves a misnamed 0 byte file. See screenshots below:


    Untitled 2.jpgUntitled 3.jpgUntitled.jpg

  9. #9
    Administrator
    Join Date
    Apr 2002
    Posts
    41,124

    Re: Changed Behavior In Character Mapping

    You would have to refresh the disc so the metadata is processed again, I can see you still have ':' in the filename which is an illegal character.

  10. #10
    dBpoweramp Enthusiast
    Join Date
    Dec 2013
    Posts
    52

    Re: Changed Behavior In Character Mapping

    Quote Originally Posted by Spoon View Post
    You would have to refresh the disc so the metadata is processed again, I can see you still have ':' in the filename which is an illegal character.
    Please understand - that is the problem! DBPoweramp is not processing the DSP properly. I have the ':' replaced with ' - ' and DBPoweramp is not processing that correctly. I provided the screenshots in the previous post.

  11. #11
    dBpoweramp Enthusiast
    Join Date
    Dec 2013
    Posts
    52

    Re: Changed Behavior In Character Mapping

    Quote Originally Posted by Spoon View Post
    You would have to refresh the disc so the metadata is processed again, I can see you still have ':' in the filename which is an illegal character.
    Spoon, can you please help me with this problem.

  12. #12
    Administrator
    Join Date
    Apr 2002
    Posts
    41,124

    Re: Changed Behavior In Character Mapping

    It is working for me, try this:

    Load any CD into CD Ripper, add the DSP effect 'ID Tag Processing' on Word / Character replacement add:

    :
    -

    (in first then 2nd box, ensure no blank lines after).

    Then right click on where it says 'Rip Status' above the track listing, enable the 'Filename' column, so you can see the output filename.

    Next change the album title, enter:

    Album: Test

    You should see instantly the filenames change to show Album - Test

    Try the above, does it work like that for you?

  13. #13
    dBpoweramp Enthusiast
    Join Date
    Dec 2013
    Posts
    52

    Re: Changed Behavior In Character Mapping

    Quote Originally Posted by Spoon View Post
    It is working for me, try this:

    Load any CD into CD Ripper, add the DSP effect 'ID Tag Processing' on Word / Character replacement add:

    :
    -

    (in first then 2nd box, ensure no blank lines after).

    Then right click on where it says 'Rip Status' above the track listing, enable the 'Filename' column, so you can see the output filename.

    Next change the album title, enter:

    Album: Test

    You should see instantly the filenames change to show Album - Test

    Try the above, does it work like that for you?
    I followed your instructions. I enabled the Filename column, ensured that the DSP is correct (screenshot attached), and changed the Album title. What is interesting is that that filename column never changes. It stays blank no matter what change I make at the top (album, artist, year, anything). Screenshot is also attached. So, I guess it is never reading the DSP.


    Capture.JPGCapture2.jpg

  14. #14
    Administrator
    Join Date
    Apr 2002
    Posts
    41,124

    Re: Changed Behavior In Character Mapping

    What naming string do you have? (file naming in the lower left corner)

    What happens also if you remove the DSP effect?

  15. #15
    dBpoweramp Enthusiast
    Join Date
    Dec 2013
    Posts
    52

    Re: Changed Behavior In Character Mapping

    Quote Originally Posted by Spoon View Post
    What naming string do you have? (file naming in the lower left corner)

    What happens also if you remove the DSP effect?
    I setup a brand new profile for testing, so the naming is simple: [Composer]\[album]\FLAC\[track] - [title]

    Removing the DSP has no effect - same ripping error, and the filename column does not populate.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •