title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 5 of 5

Thread: Mac: Assigning shortcut to Services > "Edit Tags with dBpoweramp" quit working in R8

  1. #1
    dBpoweramp Enthusiast brandonjp's Avatar
    Join Date
    Mar 2003
    Location
    Chicago, USA
    Posts
    51

    Mac: Assigning shortcut to Services > "Edit Tags with dBpoweramp" quit working in R8

    After a recent upgrade of the beta 17.1 for Mac (I think it was when I upgraded to R7 or R8), the ability to use a shortcut key stopped working for me for the entry "Edit Tags with dBpoweramp"

    I had "Edit Tags with dBpoweramp" assigned to a shortcut in Finder: https://cln.sh/k5RwzB -- And it was working perfectly until I upgraded at some point it stopped working. Using the mouse to select Services > "Edit Tags with dBpoweramp" does work, but using a shortcut does not. I also tried adding "Edit Tags with dBpoweramp" as a shortcut for the PathFinder app & that also doesn't work.

    I switched it to use "Edit Tags with PerfectTUNES" and that one works fine: https://cln.sh/GvkBFB (however, "Edit Tags with PerfectTUNES" doesn't allow drag and drop of artwork - separate issue, see here: https://forum.dbpoweramp.com/showthr...013*post199013 )

    Just curious if anyone has also had this issue or if there are any ideas how to resolve it?
    Last edited by brandonjp; 06-16-2020 at 11:29 AM.

  2. #2
    Super Moderator
    Join Date
    Jul 2011
    Posts
    989

    Re: Mac: Assigning shortcut to Services > "Edit Tags with dBpoweramp" quit working in

    Thanks for the bug report.

    It appears that the commands are referenced by plaintext name. dBpoweramp publishes two commands of the same name, one for files, another for folders; as a result you have no control over which of the two is actually invoked. I'm cleaning this up for the next update.

  3. #3
    Super Moderator
    Join Date
    Jul 2011
    Posts
    989

    Re: Mac: Assigning shortcut to Services > "Edit Tags with dBpoweramp" quit working in

    Should be addressed in latest. Two distinct commands have been replaced with one that takes both files and folders.

  4. #4
    dBpoweramp Enthusiast brandonjp's Avatar
    Join Date
    Mar 2003
    Location
    Chicago, USA
    Posts
    51

    Re: Mac: Assigning shortcut to Services > "Edit Tags with dBpoweramp" quit working in

    Hmmm.. Now I'm getting nothing from Folders.

    Using R 17.1 b12 - For all Services: "Convert with dBpoweramp" & "Convert Folder with dBpoweramp" as well as "Edit Tags with dBpoweramp"

    * Folders - clicking the Services menu item does nothing & using keyboard shortcut does nothing
    * Files - Services menu works, but keyboard shortcut does not

    I'll do a re-install, restart & rebuild of services, then test again

  5. #5
    dBpoweramp Enthusiast brandonjp's Avatar
    Join Date
    Mar 2003
    Location
    Chicago, USA
    Posts
    51

    Re: Mac: Assigning shortcut to Services > "Edit Tags with dBpoweramp" quit working in

    Quote Originally Posted by brandonjp View Post
    I'll do a re-install, restart & rebuild of services, then test again
    It all works. In latest release I've got services for:
    * Convert with dBpoweramp
    * Edit Tags with dBpoweramp
    Both work on files and folders.

    Case closed. Thanks as always!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •