title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 12 of 12

Thread: Help setting up AssetUPnP on Raspberrypi

  1. #1

    Join Date
    Aug 2015
    Posts
    9

    Help setting up AssetUPnP on Raspberrypi

    Hoping for some help - About 5 years ago I bought a raspberrypi and successfully managed to setup and run Asset on it. However it recently stopped working - the pi just sat there with the light on but no other evidence of life - so I decided to wipe the SD card and start again. This seemed to solve the problem of the pi being dead, but setting it up again this time I canít for the life of me seem to get Asset working!

    Iíve followed Spoonís instructions as far as I can tell, but Asset isnít finding any music. This is the line I have at the end of the /etc/fstab file:

    //192.168.1.66/Public /home/pi/nas cifs guest,_netdev,sec=ntlm 0 0 (the NAS has a fixed IP)

    And on the configuration page of Asset I have /home/pi/nas in the ĎWatched media foldersí box.

    My knowledge of Linux is basically zero outside of Spoonís instructions, although I did manage to get it working last time!

    Any help would be very much appreciated (please spare me from having to use the inbuilt Twonky server on my NAS!)

    Phill

  2. #2
    dBpoweramp Enthusiast
    Join Date
    Dec 2013
    Posts
    231

    Re: Help setting up AssetUPnP on Raspberrypi

    Is the RPi mounting the NAS volume?
    Where the mount command being executed?

    Have you created the directory in \home\pi\nas on the RPi and applied the right permissions?
    If you open a command shell, can you navigate to this directory and &*8216;see&*8217; the contents of the volume on the NAS volume?

    Once Asset can &*8216;see&*8217; the folders to scan, it does the rest.

  3. #3

    Join Date
    Aug 2015
    Posts
    9

    Re: Help setting up AssetUPnP on Raspberrypi

    Thanks simes_pep,

    Is the RPi mounting the NAS volume? - Iím afraid I donít know - how would I find this out?
    Where the mount command being executed? - /etc/fstab? Or have I got the wrong end of the stick?

    Have you created the directory in \home\pi\nas on the RPi and applied the right permissions? - I entered these lines, as per Spoonís instructions:

    cd /home/pi
    sudo mkdir nas
    sudo chmod 777 nas

    Does that answer your question?

    If you open a command shell, can you navigate to this directory and íseeí the contents of the volume on the NAS volume? - does this tell you anything:?

    214BD543-C2F3-444E-9F91-1B81D6F173AF.jpg

  4. #4

    Join Date
    Aug 2015
    Posts
    9

    Re: Help setting up AssetUPnP on Raspberrypi


  5. #5
    Administrator
    Join Date
    Apr 2002
    Posts
    38,886

    Re: Help setting up AssetUPnP on Raspberrypi

    It does not look mounted, ls -l would list all the folders on the nas.

    Does your nas not require a password? cifs is based on passwords unless the guest account is active.

    NFS is another linux methos of sharing, based on ip addresses allowed.

  6. #6
    dBpoweramp Enthusiast
    Join Date
    Dec 2013
    Posts
    231

    Re: Help setting up AssetUPnP on Raspberrypi

    No if you run a df or even a du command it should give you the usage of the mounted file store

    149606AF-8207-41C3-9361-F0A5AB672C8D.jpg

    Where are you running a sudo mount -a command to actually execute on the contents of the fstab file?

  7. #7

    Join Date
    Aug 2015
    Posts
    9

    Re: Help setting up AssetUPnP on Raspberrypi

    Quote Originally Posted by simes_pep View Post
    Where are you running a sudo mount -a command to actually execute on the contents of the fstab file?
    As far as Iím aware, Iím not!

    Could you suggest where I should be, and what such a command may look like?

    I would probably be giving up at the point if it wasnít for the fact that I have had it running before!

  8. #8
    dBpoweramp Enthusiast
    Join Date
    Dec 2013
    Posts
    231

    Re: Help setting up AssetUPnP on Raspberrypi

    Type crontab -e
    Enter
    @reboot sudo mount -a

    Then reboot

    I found that later versions of rasbian stopped automounting what was listed in the fstab file.

    I then rebuild my RPi to DietPi, as my existing version was stuck back in Jessie/Wheezy and I wanted to move to Stretch/Buster versions.

  9. #9

    Join Date
    Aug 2015
    Posts
    9

    Re: Help setting up AssetUPnP on Raspberrypi

    I am getting somewhere in that I have managed to manually mount the NAS volume by typing the line:

    Sudo mount //192.168.1.66/Public /home/pi/nas

    and Asset then sees my music and I can play it!

    However, itís not auto mounting it on a reboot. I have added the line Ď@reboot sudo mount -aí to the crontab file, but not much seems to be happening.

  10. #10

    Join Date
    Aug 2015
    Posts
    9

    Re: Help setting up AssetUPnP on Raspberrypi

    Oh dear, thought I was getting somewhere, and then on a reboot nothing happened, so I plugged the pi into the TV and it came up with this:

    E8E7B88D-44B3-4000-AB64-DFB0A2288402.jpg

    This likely to be something Iíve done, or a faulty pi?

  11. #11
    dBpoweramp Enthusiast
    Join Date
    Dec 2013
    Posts
    231

    Re: Help setting up AssetUPnP on Raspberrypi

    Sorry, thats a new one to me.
    What OS are you running on the RPi?

  12. #12

    Re: Help setting up AssetUPnP on Raspberrypi

    I may have something similar happening. I got it to work by using the rescan detecting changes options.
    If I use rescan all, no media gets detected.

    Let me know if this works for you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •