title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 4 of 4

Thread: Issue getting car (Toyota) to sort audio properly (yes using disk&track*s)

  1. #1

    Join Date
    Apr 2010
    Posts
    8

    Issue getting car (Toyota) to sort audio properly (yes using disk & track*s)

    So I have a ton of live music like Grateful Dead etc. I have been using this command to get the songs to play in the proper order for many years when writing to a USB to use in the vehicle. It has worked in BMW , Honda and others.

    [artist]\[album]\[disc][track][title]

    This has always ensured that the audio files sort properly in the car especially when a song is played more than once in the show.

    The problem I have been wrestling with is in a new Toyote 4runner. It seems to basically ignore the numbers that are appended to each filename above. So if I have a 3 CD show, the first song of each CD all show up in the list (with a 1 next to it) and those will be be the first, second, and third songs to play. So any live show is completely hosed ordering wise. It seems to only use the absolute track number and is ignore the info I create above. I have verified that the filenames are written as they should, like 101Song1, 102Song2, ....201Song8, 203Song10 etc. There must be a way to alter something here to get this sort and play correctly.

    I apologize if this has been answered 1000 times. I learned the above here many moons ago and worked like a charm. Thanks in advance.
    Last edited by JBS; 05-26-2019 at 01:18 PM.

  2. #2
    Administrator
    Join Date
    Apr 2002
    Posts
    38,903

    Re: Issue getting car (Toyota) to sort audio properly (yes using disk & track*s)

    Sometimes these car players go off write order, or FAT32 order. There is an option in Tunefusion to sort a fat32 drive by filename.

  3. #3
    dBpoweramp Enthusiast
    Join Date
    Dec 2009
    Posts
    114

    Re: Issue getting car (Toyota) to sort audio properly (yes using disk & track*s)

    Do you have the track numbers set properly in the metadata? I just got a new 4Runner too, and I copied WMA files to a thumb drive and they all show and play in the correct order.

    2019-05-27 07_26_39-dBpoweramp_ Edit ID-Tag '03 Famous Blue Raincoat'.png

    Hope this helps,
    Mike

  4. #4

    Join Date
    Apr 2010
    Posts
    8

    Re: Issue getting car (Toyota) to sort audio properly (yes using disk & track*s)

    Thanks guys,

    K, I have tried quite a few things again and seem to get the same issue. It works fine for any single CD show. But that is rarely the case in my live music collection.

    Let's take this "show" it is on 3 CDs ripped into itunes. All the meta data looks correct. It shows disc 1/3 2/3 etc. Yet when I play in the new car the first song from each "disc" is played first. So any track *1 (from disc 1, 2, or 3) is played before any track 2. This is obviously a real PITA for any live show.

    The track meta data look OK and looks like this.


    Screenshot (10).jpg

    I did even modify the scrip in tunefushion to add the numerical info as I used to and did the Fat32 sort.

    [MAXLENGTH]100,[IFVALUE]album artist,[album artist],[IFCOMP]Various Artists[][IF!COMP][artist][][][]\[MAXLENGTH]100,[disc][track][title][]

    Not that is matters but via Bluetooth (which I am trying to avoid) or a direct USB cable to the iPhone the same show is tracked and ordered correctly. That is w.o. the adding the disc and track number to the filename just straight itune synch to iphone.
    Last edited by JBS; 05-27-2019 at 09:39 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •