title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 13 of 13

Thread: Multiple Asset UPnP instances do not show in Yamaha Musiccast Receiver

  1. #1

    Multiple Asset UPnP instances do not show in Yamaha Musiccast Receiver

    I've just purchased Asset UPnP v6.2 for my new Synology DS218play, and in general I am so far very happy with this purchase! I've set up two instances: one that basically streams all audio "as is" (Asset-as-is), and one (Asset-transcode) that transcodes M4A (and DSD) to WAV (since most of my M4A files are ALAC codec versions, as some gear I have do not support ALAC). My Yamaha receiver R-N803D supports "all formats", though, including ALAC, FLAC, DSD, etc. The strange thing now is that:
    * The Yamaha will only directly see either "Asset-as-is" or "Asset-transcode", but not both. It seems that it will see the last one modified, or started. I have other DLNA servers on other platforms that it sees all the time, in addition to the native Media Server that comes with Synology DSM OS.
    * All other gear, including a Sony Blu-ray player, and Android DLNA players (Bubble UPnP, e.g.), see both Asset instances simultaneously.

    So, this behaviour is by no means a show stopper, since the Yamaha receiver works with both instances. But why is this happening? I might plan different detailed configuration later, and it would be nice to have this issue sorted out. A workaround now is to have Bubble UPnP app to access the wanted instance and render it on the Yamaha, but it would be better to use the native Yamaha Musiccast app.

    Best regards
    Arne

  2. #2
    Administrator
    Join Date
    Apr 2002
    Posts
    38,172

    Re: Multiple Asset UPnP instances do not show in Yamaha Musiccast Receiver

    It must be a bug in the Yamaha. Each new asset gets a new UPnP ID and name...

  3. #3

    Re: Multiple Asset UPnP instances do not show in Yamaha Musiccast Receiver

    Quote Originally Posted by Spoon View Post
    It must be a bug in the Yamaha. Each new asset gets a new UPnP ID and name...
    Thanks for this fast reply! I agree, but still, the Yamaha bug must be trapped by "some similarity" in these instances, and is fouled to think it is the same UPnP, since, as I said, this is the first time I encounter this bahaviour of the receiver. Is there other tags/IDs that uniquely describes a UPnP than an ID and its associated name?

  4. #4
    Administrator
    Join Date
    Apr 2002
    Posts
    38,172

    Re: Multiple Asset UPnP instances do not show in Yamaha Musiccast Receiver

    Not that I am aware, it could be that they only use the first X chars of the ID, but that is just a guess.

  5. #5

    Re: Multiple Asset UPnP instances do not show in Yamaha Musiccast Receiver

    And with the ID, you do not mean the name? I've tried to give the two instances completely different names (from first character on), but with no different results. I'm just guessing now, but the ID you talk about is that a some-byte-width integer number?

  6. #6
    Administrator
    Join Date
    Apr 2002
    Posts
    38,172

    Re: Multiple Asset UPnP instances do not show in Yamaha Musiccast Receiver

    UPnP has a hidden server ID which is unique to the instance.

  7. #7

    Join Date
    Feb 2019
    Posts
    1

    Re: Multiple Asset UPnP instances do not show in Yamaha Musiccast Receiver

    I am also having issues with Yamaha Musiccast WXC-50 , was working until this morning, do not know if Apple update this morning
    is what caused issue?

  8. #8

    Re: Multiple Asset UPnP instances do not show in Yamaha Musiccast Receiver

    I did some testing now with the Windows version of Asset UPnP (trial version): the problem of seeing only one instance does NOT apply to Windows version! So, either there is some kind of "bug" in Asset for Synology (which only Yamaha is vulnerable of), or there is someting to do with my Synology DS218play. Any clue?

  9. #9

    Re: Multiple Asset UPnP instances do not show in Yamaha Musiccast Receiver

    Quote Originally Posted by kememe View Post
    I am also having issues with Yamaha Musiccast WXC-50 , was working until this morning, do not know if Apple update this morning
    is what caused issue?
    are you saying that you too have multiple instances of Asset on Synology, but it has worked well until this date but not after?

  10. #10
    Administrator
    Join Date
    Apr 2002
    Posts
    38,172

    Re: Multiple Asset UPnP instances do not show in Yamaha Musiccast Receiver

    We will test this platform

  11. #11

    Re: Multiple Asset UPnP instances do not show in Yamaha Musiccast Receiver

    Quote Originally Posted by Spoon View Post
    We will test this platform
    Sounds good, hope you'll able to spot the difference (I'm hoping it is nothing to do with my local ds218 setup).
    /Arne

  12. #12
    Super Moderator
    Join Date
    Jul 2011
    Posts
    732

    Re: Multiple Asset UPnP instances do not show in Yamaha Musiccast Receiver

    New Asset beta version posted-
    https://forum.dbpoweramp.com/showthr...inux-R6-3-beta

    Asset's unique ID generation now behaves the same way as on Windows, which will hopefully address this issue.

  13. #13

    Re: Multiple Asset UPnP instances do not show in Yamaha Musiccast Receiver

    Quote Originally Posted by PeterP View Post
    New Asset beta version posted-
    https://forum.dbpoweramp.com/showthr...inux-R6-3-beta

    Asset's unique ID generation now behaves the same way as on Windows, which will hopefully address this issue.
    I have just downloaded and installled r6-3-beta1 on my Synology NAS, and now the Yamaha can see both instances, hurray! Thanks a lot for this fast execution of the source fix.

    Best regards
    happy Asset user
    /Arne

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •