title
Products            Purchase            Codec Central            Forum & Support            Professional            About
  
Results 1 to 3 of 3

Thread: Apple Lossless encoding error when filename contains both ? and Japanese

  1. #1

    Join Date
    Aug 2018
    Posts
    9

    Apple Lossless encoding error when filename contains both ? and Japanese

    dBpoweramp masters,

    Another weird little issue where I'm sure I'm missing something.

    I've found that when ripping CDs with Japanese track names, if the track name contains a ? (question mark) character, the output file will encode with an error. (It seems to be when trying to add tags/artwork.)

    If I remove the question mark, the file encodes properly!

    If I rename the track to ENGLISH with a question mark, the file encodes properly!

    For example:

    1. Rip a track titled: Japan-Filename.png
    Result: the following error: Japan-Error.png

    2. Rename the track to Testing?
    Result: encodes properly!

    3. Rename the track back to Japanese but remove the question mark from the end
    Result: encodes properly!

    I thought I could fix this with Preferences > File Name Restricted Characters, where there actually is an entry for "?", but oddly, in no circumstance is the "?" replaced with "_" in my filenames. Separate issue/failure on my part? See screenshot: Screenshot 2018-08-25 22.09.02.jpg

    Details: I am using Multi Encoder (Apple Lossless and Apple AAC), and dBpoweramp 16.3 (1).

    Any thoughts are appreciated! Let me know if there's more information I can provide!

    Best,
    Cabel

    PS: My trial is complete, and I'm a paying customer now! Thanks for making a useful app!

    PPS: It's easy enough for me to remove the "?" from my Japanese track names, it'll just slow down my ripping.
    Last edited by cabel; 08-26-2018 at 12:33 AM.

  2. #2
    Super Moderator
    Join Date
    Jul 2011
    Posts
    676

    Re: Apple Lossless encoding error when filename contains both ? and Japanese

    Thanks for the bug report.

    Apple's filesystem puts strange restrictions on what's allowed in the filenames. I'll amend dBpoweramp code to handle this better.

    As for substitution rules being disregarded -
    There are two places in dBpoweramp application where these things are configured - regular Converter settings and CD Ripper settings.
    Currently, the multi encoder does not know which one it should be obeying, so it obeys the former. It can indeed be annoying. It will be addressed in a future update.

  3. #3
    Super Moderator
    Join Date
    Jul 2011
    Posts
    676

    Re: Apple Lossless encoding error when filename contains both ? and Japanese

    What kind of device are you ripping to? Local hard drive (what filesystem, HFS or APFS?) or a network share (what kind?), or other?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Copyright 2018 Illustrate. All Rights Reserved.