title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 7 of 7

Thread: DSP "Folder.jpg Preserve" not working...

  1. #1

    Exclamation DSP "Folder.jpg Preserve" not working...

    I searched the forums and found several other posts that have brought forward problems with the DSP Folder.jpg Preserve but see no responses with regards to a fix. This DSP appears to have had issues for quite some time based on previous posts.

    The issue I am experiencing is when I am converting multiple tracks (e.g. one album) from FLAC (level 5) to MP3 (VBR -V 0), artwork is not consistently copied from the source directory to the destination. Some folder.jpg files are copied while the vast majority are not. I have checked to see if capitalization of the folder.jpg makes a difference and it does not. Also disabling/enabling read-only on the individual folder.jpg as well as the entire source and destination directories has not made a difference. I have also tried adding and removing the backup flag from the individual files and folders to no avail.

    The "Folder.jpg, Folder.png, Cover.jpg & Cover.png" option is checked and I have ".jpg" defined as the extension. I am using the 16.4 version of dbPoweramp Reference. The Music Converter version is 16.4.0.2.

    Is there anyway we can get this DSP issue addressed please?

  2. #2
    Administrator
    Join Date
    Apr 2002
    Posts
    42,960

    Re: DSP "Folder.jpg Preserve" not working...

    If it fails to copy, then something external is blocking the copy (security software?). The copy operation is very simple.

  3. #3

    Re: DSP "Folder.jpg Preserve" not working...

    Quote Originally Posted by Spoon View Post
    If it fails to copy, then something external is blocking the copy (security software?). The copy operation is very simple.
    I am using Windows 10 x64. The only security software is the integrated Windows Defender software. I added an exclusion for the entire directory that includes the source directory as well as the destination and all files therein. The DSP still fails to reliably copy. Is there a file size limitation perhaps?

  4. #4

    Re: DSP "Folder.jpg Preserve" not working...

    So I stumbled across something interesting that I cannot explain. When I started manually copying over the Folder.jpg files from the FLAC source directories into the target MP3 directories, I was prompted to select which file I wanted to keep. In my Windows Explorer window there is no visible Folder.jpg file. Hidden files and folders are enabled. I went one step further and enabled the display of protected system files and now I can see why this is a problem. There are reduced file size versions of the artwork already in the directory which have a system file property in that they are not visible unless expressly enabled. The files seem to be about a tenth of the size of the artwork the DSP is trying to copy over. They are not read-only.

    I did load this MP3 directory into iTunes in order to load this music onto my iPhone. Has anyone else experienced this issued with thumbnail sized versions of the Folder.jpg blocking a copy operation? I am stumped as to how they got there as there are several folders that do not have these and in those folders the DSP copy operation of course succeeds.

  5. #5

    Re: DSP "Folder.jpg Preserve" not working...

    Hmm, I think I understand what is happening. Apparently a fair number of people have complained about Windows Media Player creating small versions of artwork named folder.jpg and albumartsmall.jpg in their media directories. Sure enough when I opened WMP the options had it actively monitoring my music and video directories. What launches it is our Outlook client when you listen to a voicemail that is attached to an email. So I had effectively left WMP running briefly and in that time it had overwritten my folder.jpg files at their normal resolution of around 250 kb and then reduced them to roughly 10% of their original size. Additionally it also created the albumartsmall.jpg files in numerous directories as well.

    Anywhere this had been done, the modified files inherited hidden and system flags that prevents other programs from modifying them (unless I suspect they are run as administrator). Searching for all folder.jpg and albumartsmall.jpg files and then adding the attribute column in the Windows Explorer results window made it easy to sort and locate the HS attribute files and delete them. Once that was done I ran Batch Converter and used the test profile and added the ID Tag Processing DSP and on the additions tab told it to output Folder.jpg. It took some time to run as I included all files rather than jus tselecting one file per directory, but it was able to restore the missing artwork files. Thank you Microsoft.

    I apologize for rambling and spewing out so many updates but I wanted to document the issue in case anyone else might be able to glean any insight into their issues with the Folder.jpg Preserve DSP issues.

    Cheers!

  6. #6
    dBpoweramp Guru
    Join Date
    Dec 2008
    Location
    London, UK
    Posts
    3,961

    Re: DSP "Folder.jpg Preserve" not working...

    Yes, allowing Windows Media Player access to your audio library causes several issues, especially issues related to artwork, which you have discovered.

    Unless you are familiar with the implications of using WMP, users are advised against using it.

  7. #7

    Re: DSP "Folder.jpg Preserve" not working...

    Duly noted. In this instance part of my job process relies on it in order to open wav files directly from Outlook. I removed the directories from the WMP library actively monitored folders and so far so good. No problems since.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •