title
Products            Buy            Support Forum            Professional            About
 
  
Results 1 to 15 of 15

Thread: Disabling automatic rescan on Raspberry Pi

  1. #1

    Join Date
    Mar 2015
    Posts
    32

    Disabling automatic rescan on Raspberry Pi

    I understand there is a setting to enable this but I can't find it anywhere through the Raspbi interface.
    Am I missing something or being thick?........you can be quite candid!
    Thanks.

  2. #2
    dBpoweramp Enthusiast
    Join Date
    May 2014
    Location
    England
    Posts
    104

    Re: Disabling automatic rescan on Raspberry Pi

    Quote Originally Posted by PSH View Post
    I understand there is a setting to enable this but I can't find it anywhere through the Raspbi interface.
    Am I missing something or being thick?........you can be quite candid!
    Thanks.
    In configuration uncheck "Detect & Catalog New Tracks"

  3. #3

    Join Date
    Mar 2015
    Posts
    32

    Re: Disabling automatic rescan on Raspberry Pi

    Perfect - thank you!

  4. #4

    Join Date
    Mar 2015
    Posts
    32

    Re: Disabling automatic rescan on Raspberry Pi

    ...........except on reboot the library is cleared to zero. This was really the bit I had been hoping to avoid.

  5. #5
    Super Moderator
    Join Date
    Jul 2011
    Posts
    682

    Re: Disabling automatic rescan on Raspberry Pi

    Are your other settings also reset on reboot?
    Sounds like your $home is in a location that does not survive reboots - such as a ramdisk.
    You can override Asset's data location with _APPDATA_OVERRIDE environment variable:
    Code:
    _APPDATA_OVERRIDE=/some/path /path/to/Asset/bin/AssetUPnP
    A more elaborate way to do this:
    Code:
    export AssetPath=/path/to/Asset
    export _APPDATA_OVERRIDE="$AssetPath/data"
    mkdir -p "$_APPDATA_OVERRIDE"
    "$AssetPath/bin/AssetUPnP"

    edited: forum won't let me use hash character
    Last edited by PeterP; 08-06-2018 at 04:22 AM.

  6. #6

    Join Date
    Mar 2015
    Posts
    32

    Re: Disabling automatic rescan on Raspberry Pi

    Thanks Peter.
    In answer to your initial question, no, all the other settings (which I take to be those on the configuration page) survive a reboot.
    Regarding your suggestions, I'm afraid these go over my head somewhat.
    I was running a previous version of Asset before my big Raspberry Pi crash and didn't have this problem so it is all a bit curious.
    Where should the hash character(s) be?........and where does the code need to go?

  7. #7
    Super Moderator
    Join Date
    Jul 2011
    Posts
    682

    Re: Disabling automatic rescan on Raspberry Pi

    You can disregard most of the previous post if your settings survive and just the library disappears.

    Can you please enable debug logging in Asset configuration, apply settings, reproduce the library-disappears issue and email library logs to peter@dbpoweramp.com for analysis?

    Thanks.

  8. #8

    Join Date
    Mar 2015
    Posts
    32

    Re: Disabling automatic rescan on Raspberry Pi

    Have sent through the debug log.

    Is there anything that is immediately obvious?

    Thanks

  9. #9
    Super Moderator
    Join Date
    Jul 2011
    Posts
    682

    Re: Disabling automatic rescan on Raspberry Pi

    Thanks for the log. It is most interesting.

    From the Asset log, it looks like the net share mount points (the filesystem path where Asset looks for the network shares) already exist on Asset startup, but they are empty - as if they have not yet finished mounting.

    Asset already checks for network-share-offline scenario (missing indexed folder), but that does not help here, because the shares appear to exist but show no content. We'll keep this in mind for the next time we redesign Asset library scanning.

    Anyway. Unchecking "Detect & Catalog New Tracks" was supposed to have helped with such. It seems to not prevent the startup scan correctly due to a bug. It will be fixed in the next update.

  10. #10

    Join Date
    Mar 2015
    Posts
    32

    Re: Disabling automatic rescan on Raspberry Pi

    Thank you very much Peter for looking into it.
    Although there is a setting in the Raspberry Pi to wait until the network is up and running, it maybe that additional time is required for shares to mount properly..........but this is an amateur speaking!
    I'll recheck the "Detect & Catalog New Tracks" for the moment so that it can get on with business in the background in the event of a reboot.

  11. #11
    Super Moderator
    Join Date
    Jul 2011
    Posts
    682

    Re: Disabling automatic rescan on Raspberry Pi

    New beta version posted-
    https://forum.dbpoweramp.com/showthr...-for-Mac-Linux
    The behavior of "Detect & Catalog New Tracks" has been corrected.

  12. #12

    Join Date
    Mar 2015
    Posts
    32

    Re: Disabling automatic rescan on Raspberry Pi

    Thanks for the quick work.
    I'm having a bit of trouble installing the new version. When I try to start AssetUPnP in the new directory it claims the old version is still running, which it is.
    I had thought the new version installed on top of the old but seemingly not.
    How do I get out of this?

  13. #13

    Join Date
    Mar 2015
    Posts
    32

    Re: Disabling automatic rescan on Raspberry Pi

    Peter - can you get me out of this hole please.
    It seems the extraction / unzipping creates an additional instance of Asset rather than replacing the previous version.
    Many thanks in advance.

  14. #14
    Super Moderator
    Join Date
    Jul 2011
    Posts
    682

    Re: Disabling automatic rescan on Raspberry Pi

    Terminal:
    killall AssetUPnP

    Then you should be able to start the new version.

    Alternatively:
    AssetUPnP --shutdown
    ... will cause Asset to try to talk any running instance of itself into shutting down gracefully.

  15. #15

    Join Date
    Mar 2015
    Posts
    32

    Re: Disabling automatic rescan on Raspberry Pi

    Many thanks Peter - all working now - scanning away.
    I couldn't get the shutdown option to work but killall did the trick.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •