title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 10 of 10

Thread: OS X version, multi-encoder, weird album art, folder.jpg behaviour

  1. #1
    dBpoweramp Enthusiast
    Join Date
    Jan 2006
    Location
    Norway
    Posts
    93

    Question OS X version, multi-encoder, weird album art, folder.jpg behaviour

    Hi!
    After ripping quite a few CD's with my regular setup, a multi-encoder with 2 or 3 codecs (2xAAC and for some 1 ALAC), I just discovered that there was quite a few folders extra.
    It seems in the main dialog, after selecting "Multi Encoder", whatever is selected under Path, now gets a new folder for each CD, with just the Folder.jpg in it.
    This is quite unexpected, as I used to only get the Folder.jpg in each of the encoders' output dirs. (It's there also, so I now get one Folder.jpg for each encoder in my Multi Encoder setup + one extra ...

    Maybe some setting somewhere changed back when I reset everthing due to a bug in the beta? Or might it be a bug?

  2. #2
    Administrator
    Join Date
    Apr 2002
    Posts
    38,765

    Re: OS X version, multi-encoder, weird album art, folder.jpg behaviour

    What naming do you have set on the main page in cd ripper?

    On each of the codec pages in multi encoder?

  3. #3
    dBpoweramp Enthusiast
    Join Date
    Jan 2006
    Location
    Norway
    Posts
    93

    Re: OS X version, multi-encoder, weird album art, folder.jpg behaviour

    On the CD Ripper main page as opposed to the settings of each encoder's Settings in the Multi Encoder
    dbpoweramp-setting.png

    As it turned out, they were not the same. The main page Naming probably had the default values.
    I changed the main Naming now, to:
    [IFCOMP][IFVALUE]album artist,[album artist],[artist][][][IF!COMP][IFVALUE]album artist,[album artist],[artist][][]/[album]/[IFMULTI]CD[disc]-[][track]-[title]

    I'll let you know if the issue persists after this ... Will try ripping more when I get back to the DVD-ROM drive ...
    Last edited by flips; 08-31-2015 at 07:07 AM.

  4. #4
    dBpoweramp Enthusiast
    Join Date
    Jan 2006
    Location
    Norway
    Posts
    93

    Re: OS X version, multi-encoder, weird album art, folder.jpg behaviour

    Still the same issue, with all encoders and the main screen settings using the Naming as mentioned in my previous post ...

  5. #5
    Administrator
    Join Date
    Apr 2002
    Posts
    38,765

    Re: OS X version, multi-encoder, weird album art, folder.jpg behaviour

    Try only have one encoder on multi encoder, check that the naming matches the naming on the main cd ripper page.

  6. #6
    dBpoweramp Enthusiast
    Join Date
    Jan 2006
    Location
    Norway
    Posts
    93

    Re: OS X version, multi-encoder, weird album art, folder.jpg behaviour

    Using the multi encoder with just one encoder sort of beats the purpose of the multi encoder ...
    This behaviour is definitively new at some point, since I don't have lots of remains from earlier sessions.
    It makes no sense that the multi encoder itself stores album art, since each encoder does it ...
    But it's no big deal, I'll just delete the extra folder structure after ripping.

  7. #7
    Administrator
    Join Date
    Apr 2002
    Posts
    38,765

    Re: OS X version, multi-encoder, weird album art, folder.jpg behaviour

    It was meant as a test, so you could see what is happening, then set the multi encoder to use just the other encoder on its own.

  8. #8
    dBpoweramp Enthusiast
    Join Date
    Jan 2006
    Location
    Norway
    Posts
    93

    Re: OS X version, multi-encoder, weird album art, folder.jpg behaviour

    I haven't gotten around to rip more CD's yet. I can test this when I do, but I'm sure it will work if both the multi encoder and the embedded encoder is set to save album art to the same folder. (Not that I understand why the multiencoder itself should save anything/have a Naming setting, as it's only embedding other encoders ... Also it did not save it's own album art before, so something changed at some point in the code tree ...)

    I'm afraid I don't understand what you mean by "set the multi encoder to use just the other encoder on its own" ...

  9. #9
    Administrator
    Join Date
    Apr 2002
    Posts
    38,765

    Re: OS X version, multi-encoder, weird album art, folder.jpg behaviour

    I mean instead of having 2 encoders, only have 1, if the first one works, remove and add the 2nd to test.

  10. #10
    dBpoweramp Enthusiast
    Join Date
    Jan 2006
    Location
    Norway
    Posts
    93

    Re: OS X version, multi-encoder, weird album art, folder.jpg behaviour

    I was about to test this today, but it seems the current version (15.4) has fixed the issue (of the multiencoder itself seemingly saving folder art in addition to the included encoders themselves) ...
    So, thanks! :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •