title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 7 of 7

Thread: playback problem

  1. #1

    Join Date
    May 2007
    Posts
    24

    playback problem

    At first congratulations Spoon!
    AssetUPnP is a really great product and has almost all features I could ever dream of.
    There is no other UPnP music server on the market which combines all these features.

    There is only a small problem.
    At least every ten minutes the playing title is skipped to the next one.
    mpd (see below) log shows entries like these:

    Code:
    	Jun 25 20:23 : curl: curl failed: transfer closed with 83023188 bytes remaining to read
    	Jun 25 20:23 : flac: FLAC__STREAM_DECODER_ABORTED
    Here's my setup:

    For comparison reasons I have installed 5 UPnP servers on the same system, which is a
    Windows Server 2012R2 KVM VM on a Debian Linux server (this linux server also hosts the music
    via samba share):

    - AssetUPnP
    - MinimServer
    - Serviio
    - foobar2000 with UPnP plugin
    - Logitechmediaserver (actually no "real" UPnP server, but it can also handle this task)

    Music is played this way:

    UPnP server (controlled via BubbleUPnP) ->1Gb network 5metres-> Upmpdcli (on an CUBOX) -> mpd (on same CUBOX) -> USB connected DAC

    All UPnP servers use the same music share (only .flac files).
    foobar2000 has the same problem (and I found no possibility for improvement).
    The other 3 UPnP servers didn't have any playback problems at all.
    An that's what really astonishes me. The log entries above seem like network problems but
    why do 3 of the installed servers then have no problem at all!?
    Possibly the music is played differently. Maybe there's caching with some servers...

    I played around with settings and found "as is single" for FLACs to (possibly?)
    improve but not resolve the problem.
    What is the exact meaning of "as is" and "as is single"?

  2. #2
    Administrator
    Join Date
    Apr 2002
    Posts
    38,663

    Re: playback problem

    'as is' and 'as single' are the same if the player can play flac, try as wave instead.

    The other 3 might not show a network error if they transfer in different amounts, but that is not to say foobar or Asset transfer wrong...

  3. #3

    Join Date
    May 2007
    Posts
    24

    Re: playback problem

    F-A-B-U-L-O-U-S!
    Thanks a lot, Spoon!

    The "as WAV" setting definitely resolved the problem.
    The same setting "UPnP-Server-Streaming Profiles-Decode always to wav" resolved the problem for foobar2000 as well.

    But I'm still wondering wherefrom the .FLAC-streaming problem stems because as mentioned the 3 other UPnP servers stream unconverted FLAC without any problems. Maybe mpd is the culprit. I will try to further investigate.

  4. #4

    Join Date
    May 2007
    Posts
    24

    Re: playback problem

    continuation of the playback problem - .DSF-files:

    with DSF-files "as is" and "as single" is obviously NOT the same.
    "as is" plays .dsf-files as 24/96 PCM. "as single" plays the files
    correctly as DSD on my DAC.

    The same skip problem occurs here too:

    Jul 01 22:26 : player: played "http://192.168.1.203:26125/content/c2/b24/f96000/d-3622534937948678629-coF6B05E552D66F674-C4412154BE9A769E-355DA734E143144F.dsf"
    Jul 01 22:28 : curl: curl failed: transfer closed with 113142462 bytes remaining to read
    Jul 01 22:28 : player: played "http://192.168.1.203:26125/content/c2/b24/f96000/d-5274265428938127587-coF6B05E552D66F674-C4412154BE9A769E-355DA734E143144F.dsf"

    And now I can't use "as WAV" because I don't want my DSD files converted to 24/96 PCM.

    Probably the problem lies in the development environment.
    The perfectly "working" UPnP servers are written in JAVA (MinimServer,
    Serviio) or Perl (LMS) whereas AssetUPnP and Foobar2000
    are written in C[++|*].
    There must be a different way how the audio files are
    retrieved from the folders/shares...

    Got an idea, spoon?

  5. #5

    Join Date
    May 2007
    Posts
    24

    Re: playback problem

    I'm happy to announce that the Linux version of AssetUPnP fixes the above mentioned problems.
    The "as-wav" setting fixed the problem with FLAC but not without flaws because it was impossible
    to jump to a certain position in a song.


    Now that AssetUPnP v5 with DSD playback is available and perfectly usable for me
    under Linux I'd like to replace the "faulty" windows version which never worked for me.

    Could the windows license be exchanged against a Debian Linux license?

  6. #6
    Administrator
    Join Date
    Apr 2002
    Posts
    38,663

    Re: playback problem

    Personal Message your order number please.

  7. #7

    Join Date
    May 2007
    Posts
    24

    Re: playback problem

    just bought the Debian version when I saw that it costs only 13Euros when you already own the windows version.
    that's really a fair price (and maybe one day I will also find a way to use the windows version).

    continue your fantastic work!
    marc

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •