title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 7 of 7

Thread: Volume Normalize: No option to allow clipping?

  1. #1

    Join Date
    Jan 2015
    Posts
    11

    Question Volume Normalize: No option to allow clipping?

    Hi,
    This is my final hurdle in a long going project.

    I am trying to build a loudness leveling process that destructively adjusts the gain on a number of files.
    The basic chain consists of:
    [calculate EBU-R128/ITU-R BS.1770-3 gain] > [work at 32bit floating point] > [apply adjustment to meet target LUFS] > [VST Hard limiter]

    I had previously (wrongly) assumed using "ReplayGain" followed by "ReplayGain (Apply)" as part of a DSP chain would work, but I can see how the first DSPs tags are not written for the (apply) DSP to action.
    After reading the DSP documentation a little more carefully, I understand I should be using "Volume Normalize".

    I run into a snag:

    Code:
    Information converting to mp3 (Lame), '<path to mp3 file>'
       Warning: Normalisation gain would have resulted in clipping, gain has been reduced to prevent this: Loudness=-26.34LUFS, Gain=3.34dB, Maximum True Peak=-1.00LUFS, True Peak=-4.00LUFS, New gain=3.00dB  [clDSP::PassNonLive]
    How do I turn clip prevention off, I can't find the option for it? I have a limiter to take care of overs.

    I'd rather not have to use a lengthy process involving ffmpeg to scan the file for EBU-R128 loudness, extract this value, apply conversion to integers, apply maths to meet the target loudness, apply this again adjustment, then pipe into CoreConverter.exe just to use the VST plugin DSP.

    Am I missing something?
    Is there an option to ignore the peak in the normalization process?
    Can ReplayGain tags be held in memory and passed the RepalyGain (apply)?

    Thanks

  2. #2
    Administrator
    Join Date
    Apr 2002
    Posts
    38,575

    Re: Volume Normalize: No option to allow clipping?

    >How do I turn clip prevention off

    One option would be to go into floating point, then apply a fixed -12dB gain, run EBU then add a +12dB gain to restore.

  3. #3

    Join Date
    Jan 2015
    Posts
    11

    Re: Volume Normalize: No option to allow clipping?

    Thanks for the quick reply!

    Ah, I see where you are going. I would normally have some concern over performing addition gain adjustment steps (as each adds quantisation error), but at 32bit fp these will be VERY small, and when the output delivery format is 192CBR MP3, I'd place a large bet on it not even being audible.

    If there a limit to how much gain can be added to volume normalize? My target maybe considerably higher than -23LUFS.

    An additional question:
    Regarding Mono single channel files. Will these be scanned as dual channel, but still processed as single channel, or will I need to apply an additional +3dB?

    Thanks

  4. #4

    Join Date
    Jan 2015
    Posts
    11

    Re: Volume Normalize: No option to allow clipping?

    Ah, a snag in that plan Spoon.

    [Bit depth 32fp] > [Volume Normalize Fixed -12dB] > [Volume Normalize EBU-R128] > [VST Limiter]

    Same error comes up from the EBU-R128 scan. I have a file that is less than -23 LUFS normally, and it's peaks are close to 0 dBFS, so the algorithm is looking at the data and failing to raise the level to -23 LUFS because of the peak clipping. It's like ReplayGain calculation with the "Prevent Clipping" permanently on, no switch to turn it off.

    I can't think of an internal way around it. I can't apply limiting before loudness adjustment because there maybe some full scale files which are highly compressed/limited. These would be turned down by the loudness calculation, with no need to limit.

  5. #5

    Join Date
    Jan 2015
    Posts
    11

    Re: Volume Normalize: No option to allow clipping?

    For the mean time I'll use the ReplayGain codec utility to just apply ReplayGain tags. Then use a second run of CoreConverter.exe with the ReplayGain (Apply) DSP to actually adjust the gain.

    Whilst the Volume Normalise (EBU-R128) would most likely work in most situations with commercial music, I think it may fail with Classical music and also with un-mastered and home recorded stuff, with insanely large crest factors, and low loudness.

    I'll create a temporary working directory to copy the input files into, write the tags, process to an output folder and that'll do it until an option appears to override the clip detection in the Volume Normalize DSP.

    Great program all the same though, easier than anything else even the CLI is most straight forward and more powerful.

    Thanks

  6. #6

    Join Date
    Jan 2015
    Posts
    11

    Re: Volume Normalize: No option to allow clipping?

    Re the ReplayGain utility codec.

    "It is not possible to use this utility codec from the command line."
    OK, well that sucks.

    It seems to run via CLI, but doesn't write the tags to the file for some reason.

    It does indeed look like I will have to use ffmpeg and some annoyingly lengthy code just to do a really simple task.
    All really because Foobar2000 doesn't return error codes from it's GUI and doesn't really have a CLI interface.

  7. #7

    Join Date
    Jan 2015
    Posts
    11

    Re: Volume Normalize: No option to allow clipping?

    @Spoon

    I've found a workaround for the time being.
    I am rendering to a lossless format with the ReplayGain DSP, with Disable Clip Prevention ticked.
    This gives me some intermediate files with correct gain adjustment amounts in their tags.

    I then use ReplayGain (Apply) DSP on these intermediates, along with VST DSP to run a limiter.
    I now get the file adjusted by loudness only, and peaks are completely ignored, and handled by the limiter.

    It would be great if you made an update to the Volume Normalize DSP to turn off clip prevention, that one little button (I confess I don't know how much code it takes) would mean I could just use the one DSP and no intermediate files. A nice 'n easy one process fix.

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •