title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Page 1 of 3 123 LastLast
Results 1 to 15 of 38

Thread: Asset UPnP on Raspberry Pi buffering in middle of every track

  1. #1

    Asset UPnP on Raspberry Pi buffering in middle of every track

    I'm running the registered version of Asset on a Pi, connected to the same switch as a Linn KDS. Music is stored on a 2TB USB ext4 disk.

    In the exact middle of every track playback is paused for a second or two while the KDS buffers. I'm transcoding Flac to Wav in Asset. When the buffering happens the CPU loading for the AssetUPnP process increases from around 7% to over 40% (using 'top' to watch the processes).

    Has anyone else hit this issue? Are there any obvious settings I can check?

    Apart from this issue playback sounds superb.

    Thanks
    Graham

  2. #2

    Re: Asset UPnP on Raspberry Pi buffering in middle of every track

    Quote Originally Posted by Graham Russell View Post
    I'm running the registered version of Asset on a Pi, connected to the same switch as a Linn KDS. Music is stored on a 2TB USB ext4 disk.

    In the exact middle of every track playback is paused for a second or two while the KDS buffers. I'm transcoding Flac to Wav in Asset. When the buffering happens the CPU loading for the AssetUPnP process increases from around 7% to over 40% (using 'top' to watch the processes).

    Has anyone else hit this issue? Are there any obvious settings I can check?

    Apart from this issue playback sounds superb.

    Thanks
    Graham
    Some additional information:
    Playing Flacs without transcoding still buffer in the middle of every track
    Minimserver on the Raspberry Pi plays the same tracks with no buffering. But the CPU loading for Java process running Minimserver is significantly higher than AssusUPnP process when playing.

  3. #3
    Administrator
    Join Date
    Apr 2002
    Posts
    40,377

    Re: Asset UPnP on Raspberry Pi buffering in middle of every track

    Describe your network please.

  4. #4

    Re: Asset UPnP on Raspberry Pi buffering in middle of every track

    Pi and KDS are connected to the same dedicated Netgear 100Mbit switch. A patch cable connects this switch to another switch for access to the rest of the house network and internet access.

    As a test I've just disconnected the patch cable between the two switches so the Pi and KDS are the only 2 devices on their private network. Again in the exact middle of a track the KDS stopped for a second. I was watching the traffic lights on the switch and when the buffering occurred the traffic lights stopped flashing.

    This problem is consistent with every track I play. The buffering happens at the exact middle of the track regardless of track length. Very weird.

  5. #5
    dBpoweramp Guru
    Join Date
    Jan 2011
    Posts
    937

    Re: Asset UPnP on Raspberry Pi buffering in middle of every track

    You are playing CD quality material?

  6. #6

    Re: Asset UPnP on Raspberry Pi buffering in middle of every track

    Yes CDs ripped with dbpoweramp. I have some high res downloads I can easily try too.

    I did wonder whether there are network config settings I can change on the Pi but because the buffering happens in the exact middle of each track it seems to point to an application issue rather than a system issue. But if there is a system config I can change then it's an easy fix :-)

  7. #7

    Re: Asset UPnP on Raspberry Pi buffering in middle of every track

    I think I may have fixed the problem. I killed AssetUPnP processes, deleted ~pi/.dBpoweramp and restarted AssetUPnP. The library is still rescanning but the first couple of tracks have played without buffering. I should have tried this sooner.

    It looks like I'm up and running properly now.

    Thanks

  8. #8
    Administrator
    Join Date
    Apr 2002
    Posts
    40,377

    Re: Asset UPnP on Raspberry Pi buffering in middle of every track

    How many tracks do you have?

  9. #9

    Re: Asset UPnP on Raspberry Pi buffering in middle of every track

    Currently on the USB disk attached to the Pi are around 19000 tracks. But I'm copying over all the music from my main PC music server onto the local disk. AssetUPnP on the PC reports 27000 tracks so that's what I'll end up with on the Pi's disk.

    Is this quantity of tracks OK?

  10. #10
    Administrator
    Join Date
    Apr 2002
    Posts
    40,377

    Re: Asset UPnP on Raspberry Pi buffering in middle of every track

    Yes should be ok.

  11. #11

    Re: Asset UPnP on Raspberry Pi buffering in middle of every track

    Unfortunately the buffering problem has returned in the middle of tracks.

    I've deleted ~pi/.dBpoweramp again and will try and work out if it's any of the settings in there that are causing the problem.

  12. #12

    Re: Asset UPnP on Raspberry Pi buffering in middle of every track

    I'm close to giving up as I can't stop the buffering problem. I've tried music on the local USB disk and after deleting ~pi/.dBpoweramp again I configured AssetuPnP to read from a NAS containing another copy of all the music files. I get exactly the same problem with local disk and NAS.

    The frustration is that minimserver works perfectly with music on the local USB disk.

  13. #13
    Administrator
    Join Date
    Apr 2002
    Posts
    40,377

    Re: Asset UPnP on Raspberry Pi buffering in middle of every track

    Try having only 1000 tracks indexed as a test.

  14. #14

    Re: Asset UPnP on Raspberry Pi buffering in middle of every track

    650 tracks seem to work OK and 7500 tracks cause buffering in the middle of each track. So it does look like it's related to the volume of music.

  15. #15
    Administrator
    Join Date
    Apr 2002
    Posts
    40,377

    Re: Asset UPnP on Raspberry Pi buffering in middle of every track

    Your Pi it is a fresh or has many applications installed?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •