title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 7 of 7

Thread: Unable to get sorting working to my liking....

  1. #1
    dBpoweramp Enthusiast
    Join Date
    Sep 2010
    Location
    London UK
    Posts
    144

    Unable to get sorting working to my liking....

    I didn't want to thread crap over Biggsy's request, but I have a similar query.

    Currently, I have "The Beatles" appearing under "B", which is what I want. However, I'd like artists to be sorted under their surname rather than first, whilst keeping my control point's display to 'firstname lastname'; ie Kate Bush displayed as Kate Bush but appearing under "B".

    My tags are set thus:-



    ...and Asset is set thus:-



    I've performed refreshes and rescans, but whatever I do, the above album, when scrolling through artists, always appears under "A" for Al rather than "G" for Garner, which is what I'd like.

    Not the end of the world but I'd like it to work this way. Any thoughts as to why it's not?

    Many thanks

    Mick

  2. #2
    dBpoweramp Guru
    Join Date
    Dec 2008
    Location
    London, UK
    Posts
    3,524

    Re: Unable to get sorting working to my liking....

    What file format are you using?

  3. #3
    dBpoweramp Enthusiast
    Join Date
    Sep 2010
    Location
    London UK
    Posts
    144

    Re: Unable to get sorting working to my liking....

    Quote Originally Posted by mville View Post
    What file format are you using?
    Hi - FLAC only...

  4. #4
    dBpoweramp Guru
    Join Date
    Dec 2008
    Location
    London, UK
    Posts
    3,524

    Re: Unable to get sorting working to my liking....

    If you are using MP3Tag (screenshot suggests so), take 1 track or album, change the ArtistSort tag to Artist Sort (with a space). Then try Refresh All in Asset UPnP Configuration.

    Let us know what happens.
    Last edited by mville; 09-12-2013 at 08:06 PM.

  5. #5
    dBpoweramp Enthusiast
    Join Date
    Sep 2010
    Location
    London UK
    Posts
    144

    Re: Unable to get sorting working to my liking....

    I tried changing the first track to Artist Sort from Artistsort as you suggested, and selected Refresh All, and guess what? ALL tracks in the album now appear under "G", with none under "A", suggesting that both Artistsort and Artist Sort are equally ok.
    Really don't undersand why earlier refreshes didn't have this effect, but it's as it should be now so thank you very much for your help.

    Mick

  6. #6
    dBpoweramp Guru
    Join Date
    Dec 2008
    Location
    London, UK
    Posts
    3,524

    Re: Unable to get sorting working to my liking....

    When using Asset UPnP and editing tags in MP3Tag:

    FLAC artist sort tag should be Artist Sort (%artist sort%)
    MP3 artist sort tag should be ArtistSort (%artistsort%)

  7. #7
    dBpoweramp Enthusiast
    Join Date
    Sep 2010
    Location
    London UK
    Posts
    144

    Re: Unable to get sorting working to my liking....

    Ok, I shall use the seperated version - ta...

    Mick

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •