title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 6 of 6

Thread: Search trouble

  1. #1
    dBpoweramp Enthusiast
    Join Date
    Sep 2012
    Location
    Portland, Oregon, USA
    Posts
    59

    Question Search trouble

    I am using UPnPlay as control point and Asset (registered) as server on Windows 7/64.

    When I use "Search > Songs", I get the expected result. I searched for "nearness," and all versions of "The Nearness of You" came up.

    When I use "Search > Albums", I get "No data available". I searched for "Goldberg" and nothing came up, though I have 20+ albums with "Goldberg" in the title.

    Same with "Search > Artist/Album". I put in "Beatles" and nothing.

    What am I doing wrong?

  2. #2
    Administrator
    Join Date
    Apr 2002
    Posts
    38,380

    Re: Search trouble

    This 'Search' is handled by the control point, Asset supports simple search, UPnPplay must be searching in a way we are not expecting, if you enable debug mode on Asset (remember to turn it off when finished) you can view the actual search 'code' as Asset sees it, it will help us if you post the search here.

  3. #3
    dBpoweramp Enthusiast
    Join Date
    Sep 2012
    Location
    Portland, Oregon, USA
    Posts
    59

    Re: Search trouble

    ===========OnSearch================
    0 searchCriteria: (upnp:class derivedfrom "object.container.album.musicAlbum") and ((dc:title contains "Goldberg"))
    Filter: * Start Idx: 0 Count: 300
    =============================================

    SELECT * FROM uDBColumns;

    SELECT * FROM t_artist;

    SELECT * FROM t_album;

    SELECT * FROM t_genre;

    SELECT * FROM t_conductor;

    SELECT * FROM t_soloists;

    SELECT * FROM t_orchestra;

    SELECT * FROM t_chorus;

    SELECT * FROM t_instrument;

    SELECT * FROM t_period;

    SELECT * FROM t_style;
    Search ContainerLong: 0\
    SQL:
    OnSearch Calling OnBrowseDirectChildren =======

    OnBrowseDirectChildren::object_id: 1 ControlPoint: UPnPlay/0.0.80pre (Linux; Android 2.3.4; HTC ADR6350)
    ContainerLong: 0\UNIQUE-SEARCH\Album
    SQL: (t_album=0)

    SELECT t_album, albumartsize, albumartcrc, t_genre FROM uMediaTable WHERE (t_album=0);

    ========================FOLDERS==================

    ========================TRACKS==================

    <DIDL-Lite xmlns="urn:schemas-upnp-org:metadata-1-0/DIDL-Lite/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:upnp="urn:schemas-upnp-org:metadata-1-0/upnp/" xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/"></DIDL-Lite>
    NumberReturned: 0 TotalMatches: 0 UpdateId: 50

  4. #4
    Administrator
    Join Date
    Apr 2002
    Posts
    38,380

    Re: Search trouble

    Asset does not support partial match searching, you have to type the whole album name to get a match (It will be improved in R5)

  5. #5
    dBpoweramp Enthusiast
    Join Date
    Sep 2012
    Location
    Portland, Oregon, USA
    Posts
    59

    Re: Search trouble

    Thanks. Do you have a release date in mind for R5?

  6. #6
    dBpoweramp Guru
    Join Date
    Jan 2011
    Posts
    937

    Re: Search trouble

    Not currently

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •