title
Products            Buy            Support Forum            Professional            About
 
Page 1 of 3 123 LastLast
Results 1 to 15 of 41

Thread: No CD Drive Found

  1. #1

    Join Date
    Dec 2012
    Posts
    7

    No CD Drive Found

    Hello,

    I've just bought a new PC. It's running Windows 8 Pro 64-bit and has two LG BH10LS38 bluray drives installed.

    Windows recognises the drives, but dBpoweramp says "No CD drive found".

    Any idea why the software doesn't recognise the drives?

    Thanks,

    Ian

  2. #2
    Da Man
    Join Date
    Apr 2002
    Posts
    37,433

    Re: No CD Drive Found

    CD Ripper, or CD Writer?

  3. #3

    Join Date
    Dec 2012
    Posts
    7

    Re: No CD Drive Found


  4. #4
    Da Man
    Join Date
    Apr 2002
    Posts
    37,433

    Re: No CD Drive Found

    Which program are you using?

    dBpoweramp CD Ripper

    or

    dBpoweramp CD Writer

    ?

  5. #5

    Join Date
    Dec 2012
    Posts
    7

    Re: No CD Drive Found

    dBpoweramp CD Ripper.

  6. #6
    Da Man
    Join Date
    Apr 2002
    Posts
    37,433

    Re: No CD Drive Found

    Close CD Ripper. Run dBpoweramp Configuration, the Music Converter Tab and enable Music Converter Debug. Click Ok, then start CD Ripper, wait 30 seconds, then close CD Ripper, a debug log will show in notepad, copy and paste the text here please.

  7. #7

    Join Date
    Dec 2012
    Posts
    7

    Re: No CD Drive Found

    Thank you for your help so far. The debug log is pasted below:

    Using SCSI PassThrough [clCDDA::SetCommunication]
    ->-> [frmMain::RefreshTrackListing]
    Quitting Meta Thread: Quit
    ->-> [clCDDA::ReturnDriveList]
    Got drive C:\ ** not CD Rom, type: 3 [cddaSCSIPassTru::FillDriveList]
    Got drive D:\ ** not CD Rom, type: 3 [cddaSCSIPassTru::FillDriveList]
    Got drive E:\ ** not CD Rom, type: 3 [cddaSCSIPassTru::FillDriveList]
    Got drive F:\ ** not CD Rom, type: 3 [cddaSCSIPassTru::FillDriveList]
    Error Cannot Open Drive [cddaSCSIPassTru::GetDriveInfo]
    Got drive G:\ CD ROM ** ERROR getting drive info [cddaSCSIPassTru::FillDriveList]
    Error Cannot Open Drive [cddaSCSIPassTru::GetDriveInfo]
    Got drive H:\ CD ROM ** ERROR getting drive info [cddaSCSIPassTru::FillDriveList]
    <-<- [clCDDA::ReturnDriveList]
    <-<- [frmMain::RefreshTrackListing]

  8. #8
    Da Man
    Join Date
    Apr 2002
    Posts
    37,433

    Re: No CD Drive Found

    G and H are the cd drives? something on your system is blocking access to those drives (potentially security software)

  9. #9

    Join Date
    Dec 2012
    Posts
    7

    Re: No CD Drive Found

    Yes G and H are the CD drives. I have four hard drives, hence G and H are allocated to CD. I don't have any security software installed. It's a new PC and simply has Windows 8 Pro installed. Other software can read the drives, including Exact Audio Copy (EAC), and AnyDVD. I'd really like to get dBpoweramp working since I've purchased a license and it's my preferred tool for backing up my CD collection. Any ideas?

  10. #10

    Re: No CD Drive Found

    Hi,
    i have a similar issue:

    Owning a MacBook Air with USB superdrive. Running a Win8 under Parallels. Unfortunately my dvd drive is not identified. I have copied the debug txt file:

    Using SCSI PassThrough [clCDDA::SetCommunication]
    ->-> [frmMain::RefreshTrackListing]
    Quitting Meta Thread: Quit
    ->-> [clCDDA::ReturnDriveList]
    Got drive A:\ ** not CD Rom, type: 2 [cddaSCSIPassTru::FillDriveList]
    Got drive C:\ ** not CD Rom, type: 3 [cddaSCSIPassTru::FillDriveList]
    Got drive D:\ CD ROM [cddaSCSIPassTru::FillDriveList]
    Got drive Y:\ ** not CD Rom, type: 4 [cddaSCSIPassTru::FillDriveList]
    Got drive Z:\ ** not CD Rom, type: 4 [cddaSCSIPassTru::FillDriveList]
    <-<- [clCDDA::ReturnDriveList]
    ->-> [clCDDA::ReadTOC]
    LBA FirstIndex: 0 last Index: 0
    Type: Audio Track 0 LBA Address: 0
    MSF FirstIndex: 0 last Index: 0
    Type: Audio Track 0 MSF: 0/0/0
    <-<- [clCDDA::ReadTOC]
    <-<- [frmMain::RefreshTrackListing]

    Win Explorer shows me drive letter Y assigned to the DVD drive and its working fine.

    Could you give advise how to resolve this issue?

    Cheers

  11. #11
    Da Man
    Join Date
    Apr 2002
    Posts
    37,433

    Re: No CD Drive Found

    @irumsey try running cd ripper as an elevated administrator (right click >> run as administrator).

    @ralphisto what is drive D on your system?

  12. #12

    Join Date
    Dec 2012
    Posts
    7

    Re: No CD Drive Found

    Ok, I've tried running as administrator. The two Blu-Ray drives are still not detected. It did however pick-up my virtual clone drive, which is obviously no good to me but it does show that there's a difference when running with elevated permissions.

    To confirm, I've attached the debug for this scenario:

    Using SCSI PassThrough [clCDDA::SetCommunication]
    ->-> [frmMain::RefreshTrackListing]
    Quitting Meta Thread: Quit
    ->-> [clCDDA::ReturnDriveList]
    Got drive C:\ ** not CD Rom, type: 3 [cddaSCSIPassTru::FillDriveList]
    Got drive D:\ ** not CD Rom, type: 3 [cddaSCSIPassTru::FillDriveList]
    Got drive E:\ ** not CD Rom, type: 3 [cddaSCSIPassTru::FillDriveList]
    Got drive F:\ ** not CD Rom, type: 3 [cddaSCSIPassTru::FillDriveList]
    Error Cannot Open Drive [cddaSCSIPassTru::GetDriveInfo]
    Got drive G:\ CD ROM ** ERROR getting drive info [cddaSCSIPassTru::FillDriveList]
    Error Cannot Open Drive [cddaSCSIPassTru::GetDriveInfo]
    Got drive H:\ CD ROM ** ERROR getting drive info [cddaSCSIPassTru::FillDriveList]
    Got drive I:\ CD ROM [cddaSCSIPassTru::FillDriveList]
    <-<- [clCDDA::ReturnDriveList]
    ->-> [clCDDA::ReadTOC]
    LBA FirstIndex: 1 last Index: 1
    Type: Data Track 1 LBA Address: 0 Length: 43:37:48.800
    Type: Lead Out LBA Address: 11780160
    MSF FirstIndex: 1 last Index: 1
    Type: Data Track 1 MSF: 0/2/0 Length: 00:57:48.800
    Type: Lead Out MSF: 57/50/60
    <-<- [clCDDA::ReadTOC]
    <-<- [frmMain::RefreshTrackListing]
    ->-> [frmMain::RefreshTrackListing]
    Quitting Meta Thread: Quit
    ->-> [clCDDA::ReadTOC]
    LBA FirstIndex: 1 last Index: 1
    Type: Data Track 1 LBA Address: 0 Length: 43:37:48.800
    Type: Lead Out LBA Address: 11780160
    MSF FirstIndex: 1 last Index: 1
    Type: Data Track 1 MSF: 0/2/0 Length: 00:57:48.800
    Type: Lead Out MSF: 57/50/60
    <-<- [clCDDA::ReadTOC]
    <-<- [frmMain::RefreshTrackListing]
    ->-> [frmMain::RefreshTrackListing]
    Quitting Meta Thread: Quit
    ->-> [clCDDA::ReadTOC]
    LBA FirstIndex: 1 last Index: 1
    Type: Data Track 1 LBA Address: 0 Length: 43:37:48.800
    Type: Lead Out LBA Address: 11780160
    MSF FirstIndex: 1 last Index: 1
    Type: Data Track 1 MSF: 0/2/0 Length: 00:57:48.800
    Type: Lead Out MSF: 57/50/60
    <-<- [clCDDA::ReadTOC]
    <-<- [frmMain::RefreshTrackListing]

  13. #13

    Re: No CD Drive Found

    Hi Spoon,

    Microsoft explorer is saying dvd drive...

    thx

  14. #14

    Re: No CD Drive Found

    but ms explorer also says 'virtual dvd'...

  15. #15
    Da Man
    Join Date
    Apr 2002
    Posts
    37,433

    Re: No CD Drive Found

    > It did however pick-up my virtual clone drive,

    This is causing the issues, uninstall it and dbpoweramp will work (the clone program inserts its self between dbpoweramp and all CD drives, if the driver is missing features then dbpoweramp cannot work).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •