title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 8 of 8

Thread: Inconsistent multi disc results

  1. #1

    Join Date
    Aug 2012
    Posts
    17

    Inconsistent multi disc results

    I'm having mixed results when ripping multi CD sets.

    Some are displayed as 1 album with multiple discs but others are displayed as seperate albums.

    In all cases Album Name and Album Artist are identical and all have disc number e.g. 1/5 etc

    What other criteria does Asset use to determine if the tracks are part of a multi disc album?

  2. #2
    Administrator
    Join Date
    Apr 2002
    Posts
    39,046

    Re: Inconsistent multi disc results

    A disc count tag is used, perhaps you have 'Disc' somewhere already in the album name for the split albums?

  3. #3

    Join Date
    Aug 2012
    Posts
    17

    Re: Inconsistent multi disc results

    All tracks have identical Album names e.g 'Beethoven: The 9 Symphonies' - there is no 'Disc' in the album name.

    All tracks have the disc tag set 1/5, 2/5 etc

    Are any other tags used to determine if the tracks are part of the same set?

  4. #4

    Join Date
    Aug 2012
    Posts
    8

    Re: Inconsistent multi disc results

    Yes, I can confirm the problem. May be I can help to find the bug by describing it how it pops up on my site. In case of multi discs I made the following discoveries:

    1. tracks are only sorted correctly if under general setting the Multi-Disc-Albums shown as '[Disc][Track] [Titel]' is ticked

    [IMG]file:///C:/Users/USER/Desktop/General%20Settings.JPG[/IMG]

    2. if the sorting is correct, because it's ticked, usually [Disc] is not depicted, therefore tracks are counting from 1 to x, restart form 1 to y for the second CD and so on. One has to calculate the CD-number by counting the first tracks, which is odd.
    3. In the general setting menu exists the possibility to tick for 'Multi-Disc-Albums show as 'Album, Disc x''. This adjustment has no effect on my system. I believe it should be responsible for the descript effect (Inconsistent multi disc results). I think if this is active one should get several pictures of the multidisc album noted as 'album name, disc x'.
    4. Some times it occurs, that one CD of a multi disc album shows up in another way as mentioned before. Then the sorting is "more" correct. That means, it shows up as '[Track] [Disc] [Titel]' . Not exactly what was planned, there is a turner, but anyway this is more helpful.

    file:///C:/Users/USER/Desktop/Walcha%20Spruch%201%20auf%202.JPG
    (here only the first 3 tracks)

    I installed asset UPnP two times on my computers to figure out the problem.
    First installation is on my RipNas Windows Home Server, second installation is a Win 7 Ultimate Installation. The music files are identically on both systems.

    Now the different observations:

    Windows Home Server: These CD's with the '[Track] [Disc] [Titel]' depiction, were also combined to a separate album. The album is named Walcha, Disc 1. This shouldn't happen, because the for 'Multi-Disc-Albums show as 'Album, Disc x'' was not aktive.

    file:///C:/Users/USER/Desktop/Walcha,%20Disc1.JPG

    Win 7 Ultimate: These CD's with the '[Track] [Disc] [Titel]' depiction, were not combined to a separate album. But unfortunately the "nearly correct" numbering is only valid for the first disc.

    file:///C:/Users/USER/Desktop/Walcha.JPG


    I found a difference between this specific CD 1 and the others and I though this is the bottom line difference, but it finally didn't solve the problem. Anyway I mention it hoping to give the right hints to more clever ones.
    There is a very rarely used tag, because only a few tagging or ripping software are listing this tag and that is: 'Total Discs'. EAC and foobar 2000 are listing this tag other software as for example Mp3tag or media monkey didn't. In my case only CD 1 was tagged correctly with 'Total Discs = 10' all the following discs got the wrong attribute 1.
    Anyway I changed it forth and back. Nothing changed.

    Conclusion:

    There is something buggy. But I have only a fragmentary understanding of what it really is.

    Spoon, we really need an experts help!

    Sorry I tried to append some screen shots, but I failed.
    Last edited by UDI; 08-07-2012 at 04:54 PM. Reason: I fail to copy the screen shots

  5. #5
    Administrator
    Join Date
    Apr 2002
    Posts
    39,046

    Re: Inconsistent multi disc results

    Install R14.3 beta (of dbpoweramp) to the same folder as Asset (normally Program Files\Illustrate\dBpoweramp)

    It has an updated flac decoder which can read the 'DISCTOTAL' tag that many programs standardize on now.

  6. #6

    Join Date
    Aug 2012
    Posts
    17

    Re: Inconsistent multi disc results

    Can i just confirm a few things before i try this:
    1. I'm running Asset on WHS, can i install dbpoweramp on there?
    2. My files are ripped to WAV not FLAC, does that alter your suggestion?
    3. It is asset or the control sw that links the discs as one album?

  7. #7

    Join Date
    Aug 2012
    Posts
    8

    Re: Inconsistent multi disc results

    I have made a new observation which explains the differences between my two computers and explain where the bug is located.
    It's all about the order in which you tick the 'Multi-Disc Albums shown as '[Disc][Track][Titel]'' and the "Multi-Disc Albums show as 'Album, Disc x''. What I mean is, the result you get is dependent on which of the both attributes are ticked first. If the 'Multi-Disc Albums shown as '[Disc][Track][Titel]'' is active nearly no or no reproducible reaction of the "Multi-Disc Albums show as 'Album, Disc x'' is observed. So, if you start from the situation '[Disc][Track][Titel]'' is active you can't change back, you first have to deactivate '[Disc][Track][Titel]'' and only then a clear response of the "Multi-Disc Albums show as 'Album, Disc x'' is possible. After that is chosen in the appropriate way, then 'Multi-Disc Albums shown as '[Disc][Track][Titel]'' could be ticked.
    Nevertheless, some albums shown are listed in the form [Track][Disk][Titel] and others of the same multi album with [Track] [Titel]. This might depend on the 'DISCTOTAL' tag.
    Thanks for the fast availability of a new version. I will test it and report again.

  8. #8

    Join Date
    Aug 2012
    Posts
    17

    Re: Inconsistent multi disc results

    Hi UDI, you've hit on something there. I thought i'd tried all combinations of 'Multi-Disc Albums show as..' but was getting no-where.

    I've just tried again first turning of '[Disc][Track][Title]', now 'Album, Disc x' does what i expect from it's description. The give-away is that following the automatic re-scan the album count goes up or down depending on whether 'Album, Disc x' is checked or not.

    There's does appear to be some sort of interaction depending and the combination and/or sequence that these two options are changed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •