title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 7 of 7

Thread: Command line flags ignored with m4a

  1. #1

    Command line flags ignored with m4a

    executing command line converter as follows:

    C:\Program Files (x86)\Illustrate\dBpoweramp>coreconverter.exe
    -infile="O:\ABBA\Gold- Greatest Hits\01 Dancing Queen.wma"
    -outfile="c:\temp\ABBA\Gold- Greatest Hits\01 Dancing Queen.m4a"
    -convert_to="m4a Nero (AAC)" -q .95 -ignorelength -if - -of {qt}[outfile]{qt}

    The -convert_to string was taken directly from regedit. I can use dbPowerAmp GUI interactively to encode to m4a Nero (AAC) at q .95, to get about 400 VBR. When I use the command line above, it gives me 151kbps encoding instead. No matter what number I use after the -q, I still get 151kbps from a command line encoding (whereas I can vary it fine in the GUI).

    Can you point to what I might be doing wrong?
    Thanks.

  2. #2

    Re: Command line flags ignored with m4a

    The same is true if I use dmc in c*blooper*:

    dMC.Convert(file.FullName, targetName, "m4a Nero (AAC)", "-q 0.95 -ignorelength -if - -of {qt}[outfile]{qt}", "");

    This still produces a 151kbps output file, even though -q 0.95 should produce a 390kbps output file. To reiterate, doing a conversion manually with dbPowerAmp and selecting 0.95 DOES produce a correct 390kbps m4a, so the problem is in the script syntax somehow. Can someone help?
    Last edited by spyros@spyros.c; 04-14-2010 at 08:29 AM. Reason: clarification

  3. #3
    Administrator
    Join Date
    Apr 2002
    Posts
    40,645

    Re: Command line flags ignored with m4a

    See:

    http://forum.dbpoweramp.com/showthread.php?t=18997

    To get the correct commandline.

  4. #4

    Re: Command line flags ignored with m4a

    that's where I got it from, before posting both the command line and the dMC.convert examples. Cut and pasted from there (meaning from the registry location shown by the example):

    CodecCLI_m4a Nero (AAC)

    -cli_encoder="C:\Program Files (x86)\Illustrate\dBpoweramp\encoder\m4a Nero (AAC)\neroAacEnc.exe" -cli_cmd="-q .95 -ignorelength -if - -of {qt}[outfile]{qt}" -selection="0,10,0"

    I tried exact cut and paste, changing .95 to 0.95, and also removing anything after the .95 in the string. All with same result.
    Last edited by spyros@spyros.c; 04-14-2010 at 06:13 PM. Reason: clarification

  5. #5

    Re: Command line flags ignored with m4a

    :komisch12 Ah! so the trick was to include the whole -cli_encoder string from the very beginning, not just the -cli_cmd params. Got it working. Thanks! For anyone else who wants to do in C*blooper*, here was the complete command, properly escaped:

    dMC.Convert(file.FullName, targetName, "m4a Nero (AAC)", " -cli_encoder=\"C:\\Program Files (x86)\\Illustrate\\dBpoweramp\\encoder\\m4a Nero (AAC)\\neroAacEnc.exe\" -cli_cmd=\"-q .95 -ignorelength -if - -of {qt}[outfile]{qt}\" -selection=\"0,10,0\"", "");

    FYI, running on win 7, 64 bits.

  6. #6

    Join Date
    Mar 2011
    Posts
    5

    Re: Command line flags ignored with m4a

    Hello Spyros,
    I have the same problem, but I can't programm in C + +.
    How should I handle it using the commandline-converter?

    Thanks for your attention...

  7. #7

    Join Date
    Mar 2011
    Posts
    5

    Re: Command line flags ignored with m4a

    Got it.....

    C:\Program Files\Illustrate\dBpowerAMP>coreconverter.exe -infile="i:\Source.mp2" -outfile="i:\Destination.m4a" -tag="Artist=Me"{qt} -tag="Title=Titeltje"{qt} -ta
    g="Year=2012"{qt} -convert_to="M4a Nero (AAC)" -cli_encoder="C:\Program Files\Illustrate\dBpowerAMP\encoder\m4a Nero (AAC)\neroAacEnc.exe" -cli_cmd="-q .15 -ignorelength -if - -of {qt}[outfile]{qt}" -selection="1,2,0"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •