title
Products            Buy            Support Forum            Professional            About            Codec Central
 
Results 1 to 9 of 9

Thread: Possible Bug - Occasional Metadata Missing on WMA files even when filenames have it.

  1. #1

    Join Date
    Jan 2011
    Location
    Worksop, UK
    Posts
    9

    Possible Bug - Occasional Metadata Missing on WMA files even when filenames have it.

    I've currently ripped 337 discs using dBpoweramp and I've noticed that there are a number of tracks that have been ripped that don't have any metadata attached to them, even though the file name for the WMA file does have the metadata in the file name.

    I'm ripping using two instances of dBpoweramp at the same time (2 drives) and I'm using a multi-encoder setting ripping to WMA lossless and a lossy VBR WMA encoding (something the PS3 can play, it doesn't like WMA lossless). The missing metadata rarely affects both instances and mostly seems to affect the WMA lossless tracks - the side effect of this is that the track that have no meta data at all don't who up in the media player library!

    Therefore, could this bug be verified and fixed and could you suggest an automated way of detecting the tracks in question and correcting the metadata?
    Last edited by johngla; 01-29-2011 at 01:49 PM. Reason: Completing post.

  2. #2
    Administrator
    Join Date
    Apr 2002
    Posts
    39,021

    Re: Possible Bug - Occasional Metadata Missing on WMA files even when filenames have

    Have you used R14 to rip?

  3. #3

    Join Date
    Jan 2011
    Location
    Worksop, UK
    Posts
    9

    Re: Possible Bug - Occasional Metadata Missing on WMA files even when filenames have

    Yes, registered reference release 14 and check for updates say I have the latest.

    I generally listen to music whilst ripping and one of the rip destinations in the media player 12 monitored library folder so not sure if the interaction is there. It's only occasionally that it happens, maybe a few tracks every 10 or so disc's, plus when it does happen it's amost always more than one track on a disc but not necessarily adjacent tracks.

  4. #4

    Join Date
    Jan 2011
    Location
    Worksop, UK
    Posts
    9

    Re: Possible Bug - Occasional Metadata Missing on WMA files even when filenames have

    An image showing the files and missing meta data:
    http://www.flickr.com/photos/58918742@N07/5401204496/

    The other symptom is that the tracks with no meta data dont' end up getting added to the media player library.

    The accurate rip disc ID and rip result appears to have been tagged into the file.

  5. #5
    Administrator
    Join Date
    Apr 2002
    Posts
    39,021

    Re: Possible Bug - Occasional Metadata Missing on WMA files even when filenames have

    You have a virus checker which is blocking the file? (after writing the file the tags are applied).

  6. #6

    Join Date
    Jan 2011
    Location
    Worksop, UK
    Posts
    9

    Re: Possible Bug - Occasional Metadata Missing on WMA files even when filenames have

    I wouldn't have thought so, I use MS security essentials which is pretty non-intrusive, plus other than the album/artist/album art tags being missing the file is fine; like I said, there are accurate rip result and disc id tags there so those tags made it.

  7. #7
    Administrator
    Join Date
    Apr 2002
    Posts
    39,021

    Re: Possible Bug - Occasional Metadata Missing on WMA files even when filenames have

    There is the [audio info] codec in Codec Central which if you convert all the wma files to it (with Batch Converter) you can load the output into excel to spot the ones with no metadata.

  8. #8

    Join Date
    Jan 2011
    Location
    Worksop, UK
    Posts
    9

    Re: Possible Bug - Occasional Metadata Missing on WMA files even when filenames have

    Thanks, that's locating the tracks sorted - do you have any suggestions for patching them up automatically (i.e. not typing all the data into the tag editor?)

  9. #9
    Administrator
    Join Date
    Apr 2002
    Posts
    39,021

    Re: Possible Bug - Occasional Metadata Missing on WMA files even when filenames have

    Try converting to them individually

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •