Products            Buy            Support Forum            Professional            About            Codec Central
Results 1 to 9 of 9

Thread: Totally stuck on .m4a to .mp3 conversion

  1. #1

    Unhappy Totally stuck on .m4a to .mp3 conversion

    Hi. Please help me :-) ... I am new to dbPoweramp ... am trying to convert an iTunes .m4a library to .mp3 so that I can import it into SAM Party DJ, which does not open .m4a files. I know I am missing something dead obvious, so I apologize in advance.

    I am using an ASUS notebook with Intel Centrino duo core (1800) and external storage (lots of free space) on a USB 2.0 drive (I've tried conversion on C drive and it doesn't work there either). Windows XP/SP3 with 2 GB RAM and lots of open, fast HD storage. Registry cleaned weekly, drives defragged nightly, scan lots for viruses and spyware. i.e. clean, reasonably fast machine - runs most programs flawlessly.

    I tried .m4a to .mp3 conversions using the demo/trial version and it always got stuck at the very beginning of the "Converting" dialog box. It correctly identifies the number of files it is to convert but then does nothing. The dialog box just sits there looking like it is thinking :-) ... below file number it says "examining source & overwrite check" with one "+" sign in the bracketed progress (?) field. The files that I am converting are NOT read only or otherwise write-protected, and I have full administrator privileges for the write.

    The problem is the same with a single file and with a number of selected files (with either right click in Explorer or manual start of program both). Won't convert 1 song, won't convert 21 songs. No matter how long you wait for it.

    I had the current codecs installed for .mp3 and .m4a and .aac

    Batch conversion also "does nothing" when the Convert button is pressed. I get the "Converting" dialog box (correct number of files) but again, no action on conversion. I can leave the dialog box alone for hours - for a single song, for a number of songs, or for a batch conversion.

    So I bought the Powerpack + MP3 version for $24. Uninstalled the demo, installed that, checked Configuration to make sure all needed codecs present.

    Same problem. I have the most current codecs. The most recent everything - demo was downloaded yesterday, and full version today (Monday, May 11th).

    LAME settings are quality, normal, original folder with the Volume Normalize DSP running (replay gain - makes no difference if Volume Normalize is disabled).

    All extraneous programs are shut down. (Possible interference from Firebird [embedded] as a process running for SAM?)

    Antivirus (Trend Micro) is turned on (but gives no error messages); internet connection is open.

    My files were ripped from CD using 320 .aac, which iTunes converts to 320 .m4a ... they are all organized in a standard iTunes library format. i.e. Music Directory/Artist/Album/Song. I am working with an exact copy of the iTunes library.

    Any help/suggestions/guesses would be *greatly* appreciated. Couldn't find this problem in the forums (.mp4 files, yes, unprotected .m4a files, no).

    ***BUG*** (?) when I pull up "List" from the Batch Conversion Box and look at songs, then decide you want to change things, the app locks up when cancel is clicked (at least on my machine with Win XP/SP3). You get the batch conversion main screen, but it is white with only the "List" button showing. The entire window is completely unresponsive, and the app has to be closed by the operating system.

  2. #2
    Join Date
    Apr 2002

    Re: Totally stuck on .m4a to .mp3 conversion

    Please email one .m4a file which causes the lockup:


  3. #3

    Re: Totally stuck on .m4a to .mp3 conversion

    Sent to the non-support email address that is referenced on that page you linked to.

    It appears that .m4a files that arose from ripping CDs with iTunes as 320 .aac format are the ones that don't process.

    An .m4a file recently downloaded from iTunes converts just fine.

    Other questions are in the email - I don't need to clutter the forum with those, although I will post the solution to the problem.

  4. #4
    Join Date
    Apr 2002

    Re: Totally stuck on .m4a to .mp3 conversion

    I have the file and they are quite revealing, have any tools except Apple Tools touched the file? because the ID Tags are seriously corrupted (it is a good file for us to improve our code on though because the code is locking up and sticking).

  5. #5

    Re: Totally stuck on .m4a to .mp3 conversion

    The file info was adjusted with iTunes, correcting some omissions, e.g. artist, and changing genres of certain songs on a CD ... e.g. if one track on a rock album was fairly "bluesy", I would change the genre for that track only to blues.

    The files have also been opened with Winamp, and broadcast through the Shoutcast DSP and DSAP to a shoutcast server. Some file info was changed in Winamp, but not much.

    I also tried to open the files in SAM DJ (to get them into media library or playlist) ... it would only open .mp3 files. Don't think any corruption there.

    The file that I sent you was not messed with in any way. I just played it in iTunes and Winamp and it plays fine, and the "file info" such as artist, genre, year, album title, track title, album art etc looks intact ... that is all that I can look at with what I have.

    So bottom line, the file as you got it was ripped straight off the 1993 CD with iTunes using 320 .aac ... which becomes .m4a. Anything else that saw it was either only reading (like Winamp) or trying to read it (djpoweramp).

    - A

  6. #6
    Join Date
    Apr 2002

    Re: Totally stuck on .m4a to .mp3 conversion

    I took the m4a file you sent, and created a fresh PC, latest iTunes and dropped the file on to it, no tags were shown (as I said the block is corrupted).

    Foobar also does not show any ID Tags.

  7. #7

    Re: Totally stuck on .m4a to .mp3 conversion

    Spoon - would it be helpful if I were to send along 2 or 3 other iTunes-ripped 320 .aac files? (.m4a files)

    It seems that ALL of the tracks that I recorded fail to load into dbpoweramp, or perhaps it just trips over the first such track and cannot continue.

    Tracks were ripped with iTunes 7, now using iTunes 8. I even used error correction in the ripping process.

    I mentioned that I have Firebird database management loaded as a process in connection with SAM - it handles the database side of things for SAM DJ. SAM DJ just seemed to fail on the read (would not, and does not, load .m4a files, which is what led me to dbpweramp.) While I have trouble imagining how that could mess things up, I guess it is conceivable.

    I'm a bit stuck as to what to do. Do I need to re-rip the CD collectiion and, if so, is there a lossless format (or pretty darn good format) I can write in that (a) will play in that state on my iPod, and (b) will read properly into dbpoweramp so it can generate, say 160 kbps .mp3 files for streaming with SAM at 128 kbps? For the iPod stuff, I am definitely an audiophile - I might not need lossless but I need very high quality.

    Should I be waiting for a code fix on your end? If so, any idea as to ETA? Am I the only one who has had this issue? (it appears that I may be from the forum postings).

    What info are you seeing as corrupted? I would think that whatever it is would prevent either iTunes or Winamp or both from treating it like any other .m4a track, but as far as those programs are concerned it looks like everything is just fine.

    Thanks for your thoughts and efforts on this.


  8. #8
    Join Date
    Apr 2002

    Re: Totally stuck on .m4a to .mp3 conversion

    The fix would not recover the ID Tags, as they were missing - you could see where the Genre was written, but it was cut short. Try re-ripping just that one CD again (the one where you sent the track to me) and see if dBpoweramp can read it straight after an itunes rip.

  9. #9

    Smile Workaround to: Totally stuck on .m4a to .mp3 conversion

    I couldn't find that CD in the stacks and stacks and stacks, but I did re-rip "Deuces Wild" by B.B.King, which had the same problem.

    When re-ripped as 320 .aac, dbpoweramp opened and converted the files to 320 kbps .mp3. Batch conversion converted to .mp3, but it seemed to force a very low bit rate .mp3 (like 32 kbps) ... and I could find no way to adjust that. Same story with Apple lossless conversion. So newly ripped .aac/.m4a tracks seem to be fine.

    But here is the way out for someone who already has 6000 .m4a tracks that dbpoweramp can't read ... someone who doesn't want to take the time just now to re-rip 600 CDs. Or for someone who ran across an iTunes bug in the original ripping and now has a problem (my CDs were ripped with iTunes 7).

    Cleverly hidden away in iTunes 8 is a right click feature called "convert to MP3".

    If you look at any list of tracks in the iTunes window and right click on selected file(s) ... there it is in the context menu ... convert to MP3. It uses the same settings that are currently set for CD ripping on the "General" tab of Preferences. In my case, starting from my 320 .aac files (the corrupted ones), I chose: .mp3, ECC on (as it was for original rip), VBR on but also highest quality which seemed to force it to CBR 320, auto sample, auto channels, normal stereo (don't use joint), smart encoding adjustment, and filter below 10 Hz.

    I just listed all files in the iTunes window, selected them all, right clicked, and chose "Convert to MP3". Ran like clockwork, although it took about 15 hours to crank through 6000 tracks.

    Now when I download a tune from the iTunes store, I just have to find it in iTunes, right click, and choose "Convert to .mp3". I then have a 320 .mp3 file that I can read directly into my SAM Party DJ program. (I could convert those with dbpoweramp, but it would be an unnecessary extra step).

    At some point, I will re-rip into Apple lossless and probably use dbpoweramp reference to batch convert into 320 MP3 ... assuming dbpoweramp will be able to do that batch conversion.

    Note that iTunes makes a COPY of the track in the new format in the same directory the original was in ... you do not lose your original track upon "conversion." And it does not appear twice in the library file list.

    With iTunes 8 I can rip a CD into AAC, AIF, Apple lossless, MP3 or WAV ... so those are the formats you can convert your iTunes library to. Of course, you can't go from 128 MP3 to Apple lossless, or if you can it would be Apple lossy :-)

    The only thing I could see wrong with the iTunes database was that some album art had been lost, and it would not let me cut and paste new art into the cover art window under "file info". All the genre info was present and intact, along with everything else I could see (artist, year, track, time, type, bitrate, you name it). So for now, and until I get everything into SAM, I'm going with the "corrupted ID tag" files.

    Spoon, you saw a problem with genre being cut off in the ID tags. I added a whole lot of new genres (such as "American Classics" for the Rod Stewart American Songbook CDs) when setting up songs in iTunes. It may be that these new tags were causing problems??? That being said, the genre for the track I sent you is "Rock," one of the standard choices and not something that should present a problem looking at ID tags. So I dunno.

    Since iTunes was capable of converting a 6000 tune library with one right click and only a handful of fails ... there may be an issue with dbpoweramp. As you said, Spoon, that file I sent you is probably a good one to use for debugging code. You might also try some ripping in iTunes and then playing around with genre info. Once you get it to work, make a number of copies of the original corrupted ID tag file, and see if you can batch-convert to 320 mp3.

    Whatever corruption is present in the ID tags, it doesn't bother iTunes nor SAM DJ ... I didn't dare try with Windows Media Player. And I have now disabled Winamp for all types of files except Winamp-specific (no audio files) ... the only reason I need to have Winamp on my machine is that the Shoutcast DSP used by SAM is the same as the one for Winamp and you have to config it in Winamp (bug in SAM DJ prevents you from adjusting it there ... or maybe that is a feature).

    Sorry for the long post, but wanted to get this info out in sufficient detail to help others ... and djpoweramp coders. Let me know if I can help in any way with the latter ... my library is still in 320 .aac "corrupted" form ... I just have added .mp3 copies. If you want any more of the "corrupted" .aac files, for example, just let me know.

    All of the above on an ASUS notebook, external storage of tracks on USB 2.0 drive, Intel Centrino Duo @ 1800, 2 GB RAM, Windows XP/SP3 fully patched.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts