PDA

View Full Version : Connecting to media in WMP



gilligan
01-18-2006, 01:30 PM
Hi,

Sorry if I'm not in the right forum. My question is: does any one know how to get rid of that problem of Windows Media Player that says "Connecting to media" when you try to watch a streaming video/audio? I looked everywhere on the internet. No forum has the solution. Even Microsoft knows about that, but they never tried to help people to fix that. I think this problem has no cure right now. I updated, installed and resintalled everything, but still doesn't work. I'm not the only one, but thousands of people.

Thanks a lot for you help

ChristinaS
01-18-2006, 03:50 PM
Well, this is WMP's way of informing you that it takes some time to actually connect to the server where the video is located. The only way not to see that is to download the video itself (not the meta file) and store it on your pc and then watch it directly.

The "Connecting to media" message is better than seeing a blank screen until such time as the file starts streaming - which might never happen if the server is busy.

ChristinaS
01-18-2006, 03:57 PM
But you can change the skin and several skins don't display those messages.

gilligan
01-19-2006, 02:45 AM
Thanks for you answers. But the problem is that is keeps saying "Connecting to media" and it lasts for ever. If I let it for 24 hours, it would do the same thing. Thousands of people have this problem and Microsoft doesn't want to do anything to fix that.

I can't download the video ai want to watch, because it is a live streaming.

Thanks s lot

Wayne
01-19-2006, 05:10 AM
What exactly do you want WMP to do in this situation?

The message occurs because WMP is trying to gain a connection so that it can download the live stream and for some reason (too many other people are doing the same or the server is busy) it is having problems.

Wayne

gilligan
01-19-2006, 08:22 AM
There is only one thing I want WMP to do in this situation, is to play online streaming videos and audio. It's not a question of too many other people are doing the same or the server is busy. It's a problem within WMP.

ChristinaS
01-19-2006, 11:28 PM
If WMP cannot connect to the server, despite your having used the proper settings, then there's nothing else you can do.

gilligan
01-20-2006, 04:28 AM
I tried all the settings. No chance. The only solution is to format the HD and reinstall the whole system. This problem has been posted many times in Microsoft forums. They know about that. Why don't they fix it!!

Wayne
01-20-2006, 05:19 AM
I've never had any problems connecting to streaming media in WMP except when the server I'm trying to connect to has been busy.

What version of WMP and Windows are you using? Do you have the same problems with Quicktime streams?

Wayne

ChristinaS
01-20-2006, 08:37 AM
I tried all the settings. No chance. The only solution is to format the HD and reinstall the whole system. This problem has been posted many times in Microsoft forums. They know about that. Why don't they fix it!!
Have you looked at Proxy connections for instance? At Allow WMP to connect to the internet, etc?

Why don't you post the link here so we can see if it's accessible or not?

Actually I'll move thsi thread to Spoon's Forum, not a dB issue.

gilligan
01-20-2006, 02:14 PM
Yes, I allowed WMP to connect to the internet. There is not a specific link. I tried all the links to all streaming videos. The version of WMP I have is 10 with WIndows XP PRO SP2.

If I try to watch videos for Quicktime and Real Player, I have no problem. These 2 programs work perfectly. But whem it comes to WMP, it only says "Connecting to media" and it lasts for ever.

ChristinaS
01-20-2006, 08:06 PM
You must have a firewall or proxy settings that are blocking WMP's access to the net.

gilligan
01-23-2006, 03:40 AM
No, it's not a problem of firewall of proxy. I use no proxy and WMP is allowed in the firewall. It's just a problem of WMP.

Wayne
01-23-2006, 06:57 AM
Can you supply us with links to examples of those you are having problems with?

Wayne

gilligan
01-24-2006, 03:18 AM
Hi,

Now WMP works perfectly AFTER I reinstalled the whole system. Thanks a lot for your help.

gilligan
01-24-2006, 11:55 PM
Hi,

Sorry for being back. In my last message, I said that WMP works fine. Yes, it did the first day I reinstalled the whole system! But the day after, back to the same problem!! Connecting to media and nothing!!

Here is a link as an example:

http://videos.tf1.fr/video/archivesJT/0,,-31924-721469-202-201-1--,00.html

Thanks a lot

LtData
01-25-2006, 11:28 AM
If that link is supposed to display a video, it isn't working properly. WMP isn't even launching in the box, its just displaying HTML code.

gilligan
01-25-2006, 11:05 PM
HI,

I just tried to watch the videos on that link I reffered to in my last message and it works perfectly, but not with the WMP 9 or 10. Surprise!! It works with Media Player Classic version 6!!! With WMP 9 and 10, still nothing works!! Even the radios work fine!!

ChristinaS
01-26-2006, 01:25 AM
It is not a Windows Media file at all, it is Real Media (.rpm). This explains why WMP did not play it, but Media Player Classic did, probably with the DirectShow codec and filter for .rpm files.

The video normally shows embedded however, so it's hard to know which player is being used, or I didn't find the proper way to launch them standalone.

Incidentally the videos don't show at all in Firefox, I probably need extra plugins.

gilligan
01-26-2006, 04:50 AM
No, it's not a Real Media file because I used to watch that video with WMP.

ChristinaS
01-26-2006, 06:13 PM
For me, accessing the site in Firefox, it reported needing a plugin for an .rpm file, so that didn't play at all. You can play most media files in WMP once you have installed Real Alternative with the DirectShow filters.

If I access the site in IE, I simply see the video embedded, with no information about what it is and what player plays it. A transparent gif is superimposed so right clicking is useless. I tried in vain to look at the source code, it's all very well hidden in frames and the frames cannot be accessed separately apparently, it redirects immediately to a framed page again. I've not attempted any further to find out precisely what it is.

ChristinaS
01-26-2006, 06:37 PM
Ok, got it. It is indeed windows media: http://s.tf1.fr/FluxJt/jt20d26012006/jt20d26012006.asx but this is a meta file that points to http://viptf1.yacast.net/tf1jt/jt20d26012006.asf which is another meta file in turn pointing to


Ref1= http://viptf1.yacast.net/tf1jt/jt20d26012006.asf
Ref2= http://213.205.97.105:80/tf1jt/jt20d26012006.asf


In fact you'll never find the actual media file because it is a stream. Deeply embeded in this the stream refers to mms:// which the protocol of a multi media server.

It is possible to capture it using the program SDP. But it is a 37 minute stream, which can only be captured in real time.

Anyway, that was not your problem. I think waht you are experiencing is a conflict between Media Player Classic and WMP 10.

That site serves the same video in different formats depending on what it detects you have on your system: browser, palyer and plugins. I suppose it detected Media Player Classic for you, or perhaps Real Player and it's going with it.

zarf
11-14-2008, 01:10 AM
I had the same problem, and I have fixed it.

it seems nobody on the entire internet has a clue, not microsoft, not the people who want you to listen to their streaming media that doesn't work, certainly not the thousands of people who have the same problem, and least of all our hapless gilligan here whose replies to his problem must have made him more frustrated than the problem itself.

when you search for an answer to this problem with the terms "windows media player" and "connecting to media" forever, this thread comes up the most. so I will respond to this 3-year old thread that everybody reads. I would urge readers to cut-and-paste this wherever else it can be useful.

I don't have the exact answer, and I don't know exactly what I did to get it working, but some major things can be ruled out and the ultimate cause of the problem can be narrowed down and discovered- by somebody else. I'm too lazy to do that now that it works. so I'll lay it all down on the table for you to figure out.

first thing I noticed was that in WMP 9, some things would play but some wouldn't. different media types from different sources.

next, I noticed that the Radio Tuner started off on a page that wanted me to connect to the internet. I clicked on the link and got an error. it wouldn't connect.

next, I noticed I could load a web page with the embedded WMP9 and it would do everything but actually start buffering and play the music. same problem as the standalone WMP.

it wasn't WMP because I tried different players. VLC, Winamp, and WMP Classic 6, and assorted downloaded freeware. same problem.

I noticed that with the media that does work, in WMP9 Now Playing window it looks like a browser window is being loaded. I ruled out the browser or a browser plugin because I had google chrome as my default, I switched back to IE and restarted, no change.

I created a new user (limited account) in XP and logged on to that. when opening up Windows Media Player for the first time, it had the splash screen that had some check boxes on it, then loaded. the streaming media worked right away. that's when my ears perked up.

I could rule out having to reinstall windows or codec problems. it's probably a configurational error I could hunt down.

but when I logged back on to my regular account, running WMP got me the same "first time" splash screen. it said it had to connect to the internet and download an update. I let it do so, then it said there must have been a mistake, there was no update found to download. I assume it did that only for nefarious purposes. maybe giving information about the new "other account" on the computer to microsoft?

then when I tried to use it, it did work.

I tried to narrow down what the problem was, so I changed a bunch of settings in WMP options, Internet Options, IE security settings (just in case they acted globally) and the firewall. then it STOPPED working. it was back to the same problem, Radio Tuner also not connecting like before.

I tried to put the settings back as best as I could remember, and it started working again.

then I tried to make it not work again, with no success. I couldn't recreate the problem. as far as I can tell,

it's not the firewall, because I had it turned on all the time and the changed settings made no difference.

it wasn't the security settings in Internet Options. that must mean that scripting, activeX/java or cookies weren't the problem.

it's not those multicast/udp/tcp/http checkboxes in WMP options. they have no effect.
it might be the streaming proxy settings in WMP options. http should be set to BROWSER, not "autodetect" or "none".
I don't think the rest of the settings in WMP Options was the problem, such as detect (or not) connection speed or buffer size, and "connect to the internet (overrides other commands)" had no effect. as far as I remember. I was having the same problem with other players so I don't think it's the configurations here.

it wasn't the "autodetect" settings for the connection in Internet Options or the LAN setting or if it should "never dial a connection" or not.
it wasn't "enable 3d party browser extensions" or "play sounds in web pages" in Internet Options.

so now you're almost at the answer to how to fix this problem. I put this much effort into it, I'm sure a lot of people would appreciate it if whoever narrows it down exactly would post a reply with what it was.

Habu
01-04-2009, 02:38 PM
Hi all!

I stumbled on this problem this evening and did some research too. Since this thread comes out as the first solution from google's "connecting to media..." and I didn't find the correct solution anywhere yet, here's my bit:

It's a codec problem. Try to uninstall any recent codec pack, or if you have ffdshow, go to Video decoder configuration, DirectShow control, uncheck the "Use ffdshow only in:", click on edit at the "Don't use ffdshow in:" and add wmplayer.exe (it should by located in the Program Files\Windows Media Player folder), so the ffdshow won't be used for the windows media player. The streaming video file can be now played in the windows media player itself (outside the browser), however I didn't figure how to make it work using this wmp.dll plugin in IE yet. It's not a complete solution, but I think it's a good start! :D

CodyG WIN-TEAM
01-05-2009, 01:05 PM
Hi, my nameís Cody, and Iím working with the Windows Media Outreach Team to help answer questions folks might have about their Windows-related media files.

If Habu is correct, and the issue is related to improper or disagreeing codecs on your system, you also might want to try using a codec tool instead of just randomly downloading codec packs with the hope that one of them works. A codec tool will analyze your particular video file and tell you exactly what codec(s) youíll need to play the files.

Here are a couple of free tools that will do this for you: Gspot (http://www.headbands.com/gspot/) and Sherlock (http://www.updatexp.com/sherlock-codec-detective.html) Both of these work great, and using these on your file will tell you what codecs you need to get a file running properly, without making you download anything that you donít need.

If your system is showing that you have all the codecs you need to correctly play a file and it still isnít working, then you can typically rule out codecs as the source of the problem.

I hope this is helpful!

Thanks,

Cody
Windows Media Outreach Team

Habu
01-06-2009, 02:50 PM
PROBLEM SOLVED... at least here by me. :o

I found this out before I read the CodyG WIN-TEAM post, so the following does not apply to previous advice.

I solved my problem this way:


I uninstalled ffdshow and Morgans stream switcher.
I installed the newest version of ffdshow and set it's use on every format during the installation.
I set the security in the security option in IE to default.
I set the option to no proxy in the WMP network option menu. ('cause I'm not behind a proxy)


And the streaming videos work now in the IE well.

Good luck! :thumbup:

CodyG WIN-TEAM
01-12-2009, 09:36 AM
Habu-

Sorry I couldn't be more helpful, but glad to see you got your issue resolved! Thanks for posting your solution!

Thanks,

Cody
Windows Media Outreach Team

meyerovb
03-06-2011, 12:13 PM
My solution: found the mms:// video URL using fiddler/viewing source. Went directly to the asmx URL in ie replacing mms:// with http://, opened the file in WMP directly (not embedded in the browser). The stream played correctly in WMP stand-alone. Then tried playing embedded in the browser again and it worked fine. This was on a new win 7 install, seems WMP 12 needed to stream one time fresh to wire up it's internals, then embedded began working correctly.