View Full Version : Strange Problem

09-10-2005, 01:33 PM
I've encountered a strange problem when trying to convert some mp3 files into cd format and burn to cd. The following error message (eventually) comes up, after several minutes trying to convert:

Unable to write to 'c:\foldername\filename,IGNORE',disk full?
Error copying CD File, lack of space on drive c?

There is plenty of space on c drive and nearly 2gb of ram, so I am confused as to what the problem is. I have emptied all temp files and even resorted to re-encoding the files, but no joy. This problem arose with Version 1, which I reinstalled, but is also present with R2, which I downloaded to see if that would make a difference. I've also installed both versions on another pc with the same error arising. Other files work ok, although I've encountered the same error with one or two other folders now as well.

To make it even more bizarre, Nero converts and burns to cd with no problem at all, so the files themselves seem to be ok.

Any suggestions?


09-10-2005, 02:14 PM
What size cd did you select in dCW? If you picked 650MB and your tracks take more than that (when converted from mp3 to uncompressed wav) this would explain why it has no room as it makes a disk image first and it's limited to that size as you asked for. How long is the total playing time for all the files?

Check the indicator at the bottom of the screen in dCW to see how much space it's using as you add files to it.

09-11-2005, 11:16 AM

Thanks for your response.

I selected standard 80 mins cd. I was trying to convert 12 mp3 files - a standard sized audio cd, into cd format so that I could play it in my car.

I don't think that the size had much to do with it - as I said, Nero converted and burned to cd with no problems at all.

It is a bizarre problem. I have now tried with a few other folders of mp3 files -some convert and burn with no problem and others generate the same error message. I have used the CD writer since it first came out and this is the first time that I have experienced any problems with it. I could just use Nero to burn all my cd's, but I prefer CD writer and would like to find out what the problem is.

Any further suggestions?

09-11-2005, 11:18 AM

Further to the above, it didn't convert any files - not even when done one at a time. It just hung there after reaching 86%.

Hope this might help.


09-11-2005, 12:40 PM
Try installing the latest dMC beta. It includes an updated mp3 decoder that may help.

09-11-2005, 01:57 PM
Further to the above, it didn't convert any files - not even when done one at a time. It just hung there after reaching 86%.
You had earlier stated that some mp3 files would convert and some would not (in CD Writer). Is this still accurate or now do no mp3 files convert ok in CD Writer?
If some do not work and some do, can you check the settings for some of the mp3 files (bitrate, frequency, channels, and whether they are constant, variable or average bitrate)?

The most likely fix is to upgrade to the latest dMC beta, as LtData has suggested. This is especially true if you have any "Free Format" mp3 files-the latest dMC can read these but the standard version of dMC does not. The other thing you could try is to reduce your conversion priority to Below Normal, if it is not not already set to that setting.

Should this not work, try doing some test conversions on some of the problem files and let us know whether they will successfully test convert, in addition to the information about the characteristics if the problem mp3 files.

Best wishes,

09-11-2005, 02:04 PM
Clarification: test conversion here means a conversion using the "test conversion (no write)" codec in dMC.

If that fails or somehow does not end, there's a problem with the input file or the codec used to interpret it.

09-11-2005, 06:10 PM
OK, thanks for the help.

Here goes:

Original files are coded at 192 / 44100 / Joint Stero / FHG(Guess)*

* taken from tag

These are downloaded files, so I cannot confirm if the tag information is accurate.

Test conversion works ok. They play in DBPowerAmp with no problem.

I can convert and burn them in Nero and in Jet Audio ok.

I have re-encoded them in APE format and they will convert and burn fine in CD writer.
I have used the new Beta version of DMC to convert to WAV format - these too will convert and burn fine in CDwriter.
I have re-encoded them in MP3 Lame format using the new version of DMC - still unable to burn in CDwriter and still getting the same error.

I am really puzzled by this. OK, I can get round the problem, but it is slightly irritating as I am just used to clicking on convert to audio cd and burning a disc without having to go to the trouble of re-encoding the files first.

Since this problem cropped up I've tried a few other folders of files and get the same error with some, but not all, of them. The mp3 formats vary from Lame, FHG and Xing, although other files with these formats work fine.

Any further suggestions? If not, don't worry about it too much. As I said, I can get round the problem but would like to solve it if possible.

Thanks again for your help.

09-12-2005, 02:58 PM
What type of audio cd are you creating? Standard Audio CD or an mp3 Audio CD?

09-12-2005, 09:04 PM
Hi there

Just a standard audio cd using the pre-set standard 80 mins cd format.

I usually just click the files I want and have a perfect audio cd at the end of it.

I like a simple life :))


09-13-2005, 06:31 AM
I don't suppose any of these files would be from "gapless" live cd's or from tracks that have seemingly seamless transitions from one track to the next?

I also don't suppose that there are any tag anomalies in the tags of the files which don't convert?

I do suppose that the same files consistently fail to convert in CD Writer (as opposed to crashes occurring seemingly at random)?

Can you provide some examples of tracks that are not working (that we can seek to replicate your problem)?

Best wishes,

09-13-2005, 07:39 AM
>Unable to write to 'c:\foldername\filename,IGNORE',disk full?
>Error copying CD File, lack of space on drive c?

Looking at the code it is a simple file copy it shouldn't ordinarily fail, so unless there are somekind of strange characters in the filename (if you can copy the exact message shown and paste into the forum).

09-13-2005, 07:07 PM

Thanks for your continued help.

I'm quite happy to upload the tracks concerned if that would help. Just tell me where to post them.

I don't think that they are "gapless" tracks, although they could be. I downloaded them from usenet as I wanted to hear what this particular band sounded like as they are new to me.

The error message is the exact message given. It wouldn't let me copy and paste it, but I copied it down exactly as it appeared, only changing the folder and file names.

Thanks again. I'm now going to get some sleep, so I will look in again tomorrow.
Kind regards

09-14-2005, 01:39 AM

"The Plot Thickens or Further Advances in Bizarreness" :))

Ok, I tried 4 little experiments:

1) I downloaded the original files again. In their pristine state, I tried to convert them to audio cd using CDwriter. Worked fine, first time.

2) Made a duplicate folder of newly downloaded files. Used the Program "Tag and Rename" to rename them to my own preferred format. This program has the capability of logging into Amazon or FreeDB to download the album details. On this occasion, I used Amazon.com (US) to get the tag details and renamed files. Converted to audio cd using CDwriter. Worked fine, first time.

3) Made a second duplicate folder of downloaded files. Again, using "Tag and Rename", obtained tag details from Amazon.co.uk (UK). Tried to convert using CDwriter. Same error came up. The only difference between the information given on the US site and the UK site was the album text blurb, which downloads as a text file and gets written to the comment field in the tags.

4) Returned to the original downloaded files which were giving me the problem, retagged and renamed them in "Tag and Rename" using the Amazon.com (US site). The files now convert fine.

Conclusion: Somehow using the UK site on Amazon in "Tag and Rename" seems to have corrupted the original file format. I don't know enough about how this works to understand exactly how this can happen. I thought that that all the tags did was write text coding to the mp3 file, not alter it's basic format. I usually use the UK part of Amazon to obtain the tags I want and haven't noticed this problem before, but then I don't always burn to cd. I will have to do some more investigation on this.

Anyway, it looks as though I have solved the problem, although I still don't understand what happened, so if you have any explanation I'd be interested. This might, however, help someone else if they encounter a similar problem.

Kind regards

09-14-2005, 05:52 AM
Good sleuthing!!

I can speculate about this problem but it would only be speculation on my part. I would guess Spoon might be able to pin the problem down more accurately.

Thanks and best wishes,

09-14-2005, 07:38 AM
If you could send both of those files to me (one tagged with Amazon US, other UK):


09-14-2005, 02:56 PM
On their way - thanks.

Prisca :)

09-15-2005, 01:46 PM
Thanks will look asap, I have a few other priority bugs to look into so it is about 4 on the list.

09-16-2005, 02:50 PM
Hi Spoon

I've been doing some more experimenting. The problem is definitely connected to the comment field in the tags. Some texts installed are ok and others mess up the file to give the reported error. I don't really understand how tags work, so I'm only speculating, but I would hazard a guess that there is a size limitation in the comment field which has been exceeded. Renaming files using the Amazon.co.uk site without filling in the comment field results in error free files, whereas filling in the comment field gives the error when trying to convert them.

Anyway, this might give you a place to start.

Thanks for your interest. I fully understand that this isn't a priority.

Kind regards
Prisca :smile2:

09-17-2005, 02:40 PM
Thanks, it looks like there could be a possible bug in the way it handles large comment fields.